Topic
4 replies Latest Post - ‏2013-10-28T00:54:29Z by bluejoni2306
stonerl
stonerl
4 Posts
ACCEPTED ANSWER

Pinned topic CICS IA plug-in error - IZE0106E Connect failed with error

‏2013-10-03T15:05:19Z |

I am receiving th following error message in the CICS IA plug-in using z/OS Explorer trying to access DB2 sample data on the mainframe.

"IZE0106E Connect failed with error "[jcc][t4][2034][11148][4.14.88] Execution failed due to a distribution protocol error that caused deallocation of the conversation. A DRDA Data Stream Syntax Error was detected. Reason 0x3, ERRORCODE=-4499, SQLSTATE=58009"

I am using the same configuration information that I used with the old IA Explorer which worked.

Any idea on what this is telling me? 

Thanks in advance,

Larry

 

 

  • Colin_Stone
    Colin_Stone
    28 Posts
    ACCEPTED ANSWER

    Re: CICS IA plug-in error - IZE0106E Connect failed with error

    ‏2013-10-04T06:50:08Z  in response to stonerl

    Hi Larry.

    Sorry you are seeing this. Can you advise us what versions of IA plugin you have been using (before and after) along with z/OS/CICS explorer versions, please?. I can tell by the error message you are currently using a DB2 9.7 driver which should be fine. The other thing we may need to check is if any DB2 server upgrades (particularly security) have been applied coincidently.

    Thanks

    Colin Stone

    • stonerl
      stonerl
      4 Posts
      ACCEPTED ANSWER

      Re: CICS IA plug-in error - IZE0106E Connect failed with error

      ‏2013-10-04T15:05:12Z  in response to Colin_Stone

      Hi Colin,

      Thanks for responding back. I have attached the CICS Explorer and z/OS Explorer information you requested.

      I was not getting any error last week when I tried it with either the CICS and z/OS Explorers. Last week the z/OS Explorer version was at V2.1.00. I am getting the error with the current version V2.1.02. Since I've installed V2.1.02, neither CICS or z/OS Explorers have worked.

      I could not get the update software feature on V2.100 to work so I un-installed it and installed the current V2.102 as I am getting ready for a demo with IBM on CICS IA through z/OS Explorer for our CICS team.

      We are currently on DB2 V10 for z/OS RSU1306. This maintenance was applied the weekend of September 21st.

      Thanks for looking at this for me, I truly appreciate it. If you need anything else, please let me know,

      Larry

      P.S. Would you happen to know what file all the Host Connections are stored in? I've had to re-enter them after every install of Explorer

      • Colin_Stone
        Colin_Stone
        28 Posts
        ACCEPTED ANSWER

        Re: CICS IA plug-in error - IZE0106E Connect failed with error

        ‏2013-10-04T15:53:20Z  in response to stonerl

        My initial feeling was this could be a security induced error. For example your connection is SSL but you don't have it checked as such or the other way round. Still with my DB2 hat on I think next up I would be trying to work out if the maintenence applied has had an impact although I would doubt this. I'll  prompt the IA developers and z/OS explorer guys to look at what you have supplied since you say that you have issues with both CICS and z/OS explorers now so it may be a more generic issue rather than a DB2 one.

        One easy thing to remedy is with regard to your connections file. Within the Host Connections view you have two icons at top right which have an arrow over a yellow server graphic. These allow you to import and export your connections for use elsewhere. I tend to back up my connections on a regular basis like this rather than trying to find them in the workspace.

        Colin 

    • bluejoni2306
      bluejoni2306
      19 Posts
      ACCEPTED ANSWER

      Re: CICS IA plug-in error - IZE0106E Connect failed with error

      ‏2013-10-28T00:54:29Z  in response to Colin_Stone

      I am getting a very similar error message with IBM Application Performance Analyser V12 thru Zos Explorer.   V11 works thru CICS explorer.