Topic
  • 9 replies
  • Latest Post - ‏2013-07-15T15:03:29Z by tschramm
Maria_del_R_Ramirez
Maria_del_R_Ramirez
3 Posts

Pinned topic Failed migration from QU2 to WQX

‏2013-06-24T21:41:16Z |
Hi,
 
One of my clients have Web Query 1.1.2 and want to migrate to version 2.1.0. All prerequisites were installed.
 
After installing version 2.1.0, and executing the command STRWEBQRY, the legend 'Performing QU2 to WQX migration. Please wait…' appears. 
 
During the migration there were issues:
- It took more than 15 hrs so it could let me access the Log In window of WQX.
- The list of Domains, now Top-level folders, are reduced to 5 when there were 14 in the QU2 version. 
- Those 5 folders that appear in WQX are empty.
- The legend ''Performing QU2 to WQX migration...' is still present in the session.
- After 3 hours of being stuck in that same legend and without constant activity in the log nor in the active job, I end the migration job and I start it again. The result was the same. 
 
When it was decided to return to QU2:
- It was ended Web Query and started QU2 from the command QWEBQRY77/STRWEBQRY
- The first time the status was 'Partial'. So it was ended.
- The second and third time it didn't change from the status 'Starting'
- If NETSTAT is checked, the ports that were working: 11331, 11332, 11333, 11334, 11335, 11339.
- if QWEBQRY subsystem is checked, the jobs related with Web Query that were in Active status:
 EDAPGWY
 EDAPLOG
 EDAPTH
 JSCOM3C
 TSCOM3
 QP0ZSPWP
 QSQSRVR
 STRBROKER
 WQLWI77

- The options installed in QU2 are 1,2,3,4. In WQX are 2,4,5,6.

 
According to the documentation the two products can coexist. I upgraded QU2 to WQX in a demo environment two or three months ago and it worked fine. but not this one with the client.

I tried to find some log that could tell me what went wrong but I still can't find it.

 
There is a note in "DB2 Web Query New Features Version 2.1.0" that says:
- An unsupported file type in Web Query Version 1.1.x, for example, a file extension of .URL, will cause the migration import process to fail.
- Workaround: Remove the unsupported file type from your v11x installation and rerun the migration process.
- Where do I find this URL file type? are the HTM file type related?. Because I found some HTM files in '/QIBM/UserData/ibi/webfocus77/basedir', and in the folders inside this.
 
I will really appreciate any help you could provide us.
  • ksteinbrink
    ksteinbrink
    281 Posts

    Re: Failed migration from QU2 to WQX

    ‏2013-06-24T21:57:31Z  

    Hi Maria,

    Please open a PMR or send an email to QU2@us.ibm.com for assistance with the migration issue(s). 

    Regards,
    Kathy

     

  • Maria_del_R_Ramirez
    Maria_del_R_Ramirez
    3 Posts

    Re: Failed migration from QU2 to WQX

    ‏2013-06-26T18:21:30Z  

    Hi Maria,

    Please open a PMR or send an email to QU2@us.ibm.com for assistance with the migration issue(s). 

    Regards,
    Kathy

     

    We have the PMR number since Monday.
     
    Also, I found a technical document about the Web Query Collector tool. It says that can be used for deeper investigation into Web Query issues. Yesterday I uploaded the ZIP files to the ECuRep page.
  • tschramm
    tschramm
    23 Posts

    Re: Failed migration from QU2 to WQX

    ‏2013-06-26T18:28:40Z  
    We have the PMR number since Monday.
     
    Also, I found a technical document about the Web Query Collector tool. It says that can be used for deeper investigation into Web Query issues. Yesterday I uploaded the ZIP files to the ECuRep page.

    Please send the pmr # to me at tschramm@us.ibm.com and I can check on it.

     

    Thank you,

    Tracy

  • epos
    epos
    3 Posts

    Re: Failed migration from QU2 to WQX

    ‏2013-07-15T09:18:19Z  
    • tschramm
    • ‏2013-06-26T18:28:40Z

    Please send the pmr # to me at tschramm@us.ibm.com and I can check on it.

     

    Thank you,

    Tracy

    Hi Tracy,

    we're just migration from WQ 112 to 21 and have the same problems as Maria.

    Are there any solutions yet, solving migration problem?

    Please let us know.

    Thank you

    Peter

  • tschramm
    tschramm
    23 Posts

    Re: Failed migration from QU2 to WQX

    ‏2013-07-15T12:39:33Z  
    • epos
    • ‏2013-07-15T09:18:19Z

    Hi Tracy,

    we're just migration from WQ 112 to 21 and have the same problems as Maria.

    Are there any solutions yet, solving migration problem?

    Please let us know.

    Thank you

    Peter

    Hi Peter,

    Please open a pmr of you can so that we can review your logs.  If you don't have a Web Query support contract, please send a note to qu2@us.ibm.com

     

    Thank you,

    Tracy

  • epos
    epos
    3 Posts

    Re: Failed migration from QU2 to WQX

    ‏2013-07-15T12:48:52Z  
    • tschramm
    • ‏2013-07-15T12:39:33Z

    Hi Peter,

    Please open a pmr of you can so that we can review your logs.  If you don't have a Web Query support contract, please send a note to qu2@us.ibm.com

     

    Thank you,

    Tracy

    Hi Tracy,

     

    thanks for caring. Our PMR: 17016,077,724

     

    Regards from germany

     

    Peter

     
  • tschramm
    tschramm
    23 Posts

    Re: Failed migration from QU2 to WQX

    ‏2013-07-15T12:52:13Z  
    • epos
    • ‏2013-07-15T12:48:52Z

    Hi Tracy,

     

    thanks for caring. Our PMR: 17016,077,724

     

    Regards from germany

     

    Peter

     

    Thanks Peter.  Franz is actually working on that issue as I type this.  :-)  We are reviewing your materials, and will be in touch.

     

    Danke!

     

    Tracy

  • epos
    epos
    3 Posts

    Re: Failed migration from QU2 to WQX

    ‏2013-07-15T14:36:18Z  
    • tschramm
    • ‏2013-07-15T12:52:13Z

    Thanks Peter.  Franz is actually working on that issue as I type this.  :-)  We are reviewing your materials, and will be in touch.

     

    Danke!

     

    Tracy

    Hi Tracy,

    with a little help from Franz we got our migration running.

    We recreated lib QWQREPOS and called two programs.

    QSYS/RSTLIB SAVLIB(QWQREPOS) DEV(*SAVF) SAVF(QWEBQRY/QWQREPOS)

    CALL PGM(QWEBQRY/QWQUPDREPO)

    CALL PGM(QWEBQRY/QWQUPREPOS)

    After that every worked like a charm

    Have a nice day

    Peter

  • tschramm
    tschramm
    23 Posts

    Re: Failed migration from QU2 to WQX

    ‏2013-07-15T15:03:29Z  
    • epos
    • ‏2013-07-15T14:36:18Z

    Hi Tracy,

    with a little help from Franz we got our migration running.

    We recreated lib QWQREPOS and called two programs.

    QSYS/RSTLIB SAVLIB(QWQREPOS) DEV(*SAVF) SAVF(QWEBQRY/QWQREPOS)

    CALL PGM(QWEBQRY/QWQUPDREPO)

    CALL PGM(QWEBQRY/QWQUPREPOS)

    After that every worked like a charm

    Have a nice day

    Peter

    Hi Peter,

     

    Thanks for your update.  I am glad to hear that things are working ok.

     

    If other clients run into this, I would encourage them to contact IBM support first.  There can be issues if the library is not dropped first.  Not all migration issues are the same either, so it's best if we look at them.

     

    Thank you,

    Tracy