• 2 replies
  • Latest Post - ‏2013-07-30T12:28:11Z by kossi
13 Posts

Pinned topic Document flags

‏2013-07-04T14:34:49Z | document flag ica

Am I wrong?
We want to use "Document flags". It works fine in an unsecure collection, but it doesn't work in a secure collection: I see the flags, and if I try to set a flag - nothing happens ...

In "Default Application User Privileges" the "Manage documents flags"is checked.
Same behavior on 2 systems, so I think perhaps it is a "systematic thing".
Any ideas?
Thank You

  • DanOBrien
    1 Post

    Re: Document flags


    Hi Michael,

    I tried to reproduce your problem but cannot. I created a secure collection and could manipulate the document flags without a problem. What you are describing sounds like the flags are not fully included in the index yet. Can you try the following steps:

    1. Create collection with security and document flags enabled
    2. Create a crawler
    3. Create some document flags (also make sure the 'Enable document Flags' checkbox is selected)
    4. Perform a full re-crawl
    5. Start a full index rebuild and wait until this stops. Also this may cause the indexer to re-index. If so, wait until this finishes
    6. Log into the search UI and the flags should be visible and fully functional

    If you have any questions let me know.



  • kossi
    13 Posts

    Re: Document flags


    Hi Dan,

    sorry, I was on vacation.

    We had a PMR, and the solution is: cause we made the flags later (after the first crawl) we need a recrawl to get the flags. Now it works.
    My step 1 was different than yours (document flags disabled). Some weeks later I would have the flags, and then I need the recrawl.