Topic
1 reply Latest Post - ‏2013-04-29T05:55:04Z by Ruchi_Dhavalpure
PersistentUser
PersistentUser
4 Posts
ACCEPTED ANSWER

Pinned topic How autowire ELB ?

‏2013-04-26T14:38:02Z |

Hi,

I wanted to enable the autowiring for my application in scaws

Following steps i followed

I have deployed the shared service in my service instance

then i have added service -template in my Vm - template as shown below

{
#set ( $file_name = ${attributes.archive} )
#set( $b = $file_name.replace("artifacts/", "") )
#set( $ctx_root = $b.replace(".war", "") )

    "vm-templates": [
        {
            "name": "${prefix}-A",
            "roles": [
                {
                    "parms": {
                        "ARCHIVE"   : "$provider.generateArtifactPath( $applicationUrl, ${attributes.archive} )",
                        "max_threads": "$attributes.max_threads",
                        "service-ref" : "ProxyClientServiceProvisioner"
                        
                    },
                    "type": "A",
                    "name": "A",
                    "external-uri": [{"ENDPOINT":"http://{SERVER}:8080/$ctx_root"}]
                }
            ],
            "packages":[
                "A",
                "A_SCRIPTS"]
        }               {
 
    ],      
     "service-templates": [
        {
            "sharedservice": {
                "ClientAPIVersion": "2.0",
                "SharedServiceName": "proxy",
                "required": true
            },
            "parms": {
                "deploymentID": "{deployment.id}",
                "virtualHost": "elb.com",
                "elbServiceRequired": true,
                "ctx_root": "UserManagementApplication"
            },
            "type": "routingPolicy_ProxyClientServiceProvisioner",
            "name": "ProxyClientServiceProvisioner"
        },
        {
            "sharedservice": {
                "client-version": "1.0",
                "name": "ITM",
                "required": false
            }
        }
     ]
    
}

 

I am getting error as

"CWZKS1062E: Cannot find ServiceProvisioner for serviceType routingPolicy_ProxyClientServiceProvisioner."

Any help on this topic will be appreciated..

Thanks,

Sheetal Chavan