Topic
2 replies Latest Post - ‏2013-04-25T20:40:30Z by kbmurphy
kbmurphy
kbmurphy
97 Posts
ACCEPTED ANSWER

Pinned topic RPE 1.2 is driving me crazy

‏2013-04-23T00:29:35Z |

I started using RPE 1.2 last week for a client.

It's driving me crazy and I'm wanting to vent and see if others are having issues with it.

Complaints:

  1. If I double-click a .dsx file, the export wizard comes up no matter what. Yes, I've set my preferences to not use the stupid wizard. It doesn't matter. I always have to cancel out of the wizard.
  2. Preferences to not use the wizard must be set in launcher and studio separately.
  3. The default Word driver doesn't actually create Word documents. You have to remove it and then add it to get the Telelogic Word Driver, which does work. This is not obvious, and this was a fix suggested by IBM. You can't select the driver from a drop-down.
  4. I have not figured out how to use a module_id in a dsx for DOORS. Oh, the field is there, but you must also specify a URI. There's a new option for "configuration required" and it's set to "uri" but I can't change it (not in the launcher, anyway). If you try to run it with just a module_id it won't export a document.
  5. In the studio, the properties window can no longer be set to be in the bottom right. I've tried.
  6. In the studio, the properties window has been setup to be more "user friendly" which means "slow" if you know what you're doing.
  7. In the studio, I'm sick of having to always click "advanced" in the properties and then there's still no option to expand all in the properties. But clicking advanced bothers me. IBM has added a million more clicks while I'm creating a document because of this change. 
  8. In the studio, clicking different items sometimes causes the properties to go to the actual document and not what is selected. I've done this with containers and table cells.
  9. In the studio, load a .dsx file along side your .dta file. Run the .dsx file. Change something in the .dta file. Run the .dsx file. Oh what's that? It unloaded your .dsx file? It did to me too.
  10. In the studio, the properties window is very wide, regardless of how narrow you've set the columns in the advanced window. That scrollbar remains so it can accommodate the GUI widgets I don't want to use.

I know Dragos and his team work really hard on RPE and that changes like this won't always be pleasing to users, but I also believe that RPE is a development tool, and not a tool for normal end users. And these changes make the tool much harder to work with, especially for those who've been working with it for years (I'm approaching year 4 myself). I don't want to have to enter an RFE for each of the items above.

I understand IBM would want to keep these changes--especially the properties one--that's fine, but can you at least make a "simple properties" and "advanced properties" palette? That way users who know what they're doing can work.

That's all for now, but I am wondering to all of you --how is your RPE 1.2 experience?

Updated on 2013-04-23T18:01:39Z at 2013-04-23T18:01:39Z by kbmurphy
  • Dragos.Cojocari
    Dragos.Cojocari
    1606 Posts
    ACCEPTED ANSWER

    Re: RPE 1.2 is driving me crazy

    ‏2013-04-24T07:08:44Z  in response to kbmurphy

    Hey Kevin,

    these are valid points and I felt some of them myself as a long time RPE user. With RPE 1.2 we have tried to make RPE much simpler for the end users but some of these changes did not turned out to be that great for advanced users. We have already done some changes that you should be able to see quite soon and we still work to simplify common UI tasks:

    1,2. we've seen this requested by other users and we also feel it's not working out well for all users. In our up-coming release there is now a different UI entry that allows you to run/preview the document without modifying the preferences or going though the wizard. Basically this is the old preview/run button. But we still won't have a common setting for Launcher/Studio.

    Later Edit: to clarify my statement above: when opening a docspec the Wizard will still pop-up, that behavior is not changed but we will revisit this decission in a future release. Launching the docgen however has been changed to be done with or without the wizard without needing to alter the preferences.

    3. that sounds like  a bug. I have not experienced it nor have I seen other users reporting it so please send this to support.

    4, 8. that is a defect.  please submit it to support.

    5. this is still possible: click on the properties label and drag till the frame occupies the bottom half of the outline view. But due to the size of the new properties window this might not work well on lower  screen resolutions

    6, 7, 10. Indeed, we are aware of this and we've also received complaints from other users. We are looking at what would be the best way to fix it. For the time being I use the "advanced" tab from that property view since it gives me access to the old representation.

    9. this is a defect and it is fixed in our upcoming release

     

    Regards,

       Dragos

    Updated on 2013-04-24T11:57:21Z at 2013-04-24T11:57:21Z by Dragos.Cojocari
    • kbmurphy
      kbmurphy
      97 Posts
      ACCEPTED ANSWER

      Re: RPE 1.2 is driving me crazy

      ‏2013-04-25T20:40:30Z  in response to Dragos.Cojocari

      Dragos,

      Just wanted to thank you for your reply. The Word bug has been reported officially, and I can reproduce it at will.

      I'm glad to know I'm not the only one who's frustrated and that your team is trying to make things better for all users.

      Thanks again,

      Kevin Murphy

      http://www.baselinesinc.com