Topic
  • 4 replies
  • Latest Post - ‏2013-07-29T07:18:18Z by HH0C_MICHAEL_DUFFY
kuki2333
kuki2333
24 Posts

Pinned topic A CWTBG0048E error occurs when service data is retrieved using REST Service API for IBM BPM

‏2013-07-06T11:55:12Z |

Hi guys

 

We have a java application as our BPM frontend application that uses REST API to make calls to our BPM Process.

 

For some reason we fail to find tasks that we know are there and get this error .This happens when we have more users logging on 

the system.

This is the error we get 

"CWTBG0048E: Task '123' does not exist; it might have been deleted in the meantime.",

But the task is there and we can see it on the Rest API.

 

Please advise,this is happenning on Production.

 

 

 

 

  • kolban
    kolban
    3316 Posts

    Re: A CWTBG0048E error occurs when service data is retrieved using REST Service API for IBM BPM

    ‏2013-07-08T05:07:59Z  

    What REST API is being used which returns this error?  If you execute a REST API task query on the task that claims it does not exist, what is reported?

    For production issues, please don't hesitate to create a support request with IBM.  The forum is a great resource but there is no time guarantee nor accuracy on the answers.

  • kuki2333
    kuki2333
    24 Posts

    Re: A CWTBG0048E error occurs when service data is retrieved using REST Service API for IBM BPM

    ‏2013-07-08T05:21:04Z  
    • kolban
    • ‏2013-07-08T05:07:59Z

    What REST API is being used which returns this error?  If you execute a REST API task query on the task that claims it does not exist, what is reported?

    For production issues, please don't hesitate to create a support request with IBM.  The forum is a great resource but there is no time guarantee nor accuracy on the answers.

    Hi

     

    This is the call we are making  from a third party java application frontend running on Websphere..Task 17715 is not there 

    but cant be found .If i run it on RestAPI  bpmrest-ui frontend ,we get the results for this task.Running this call 10 minutes later we get the results so

    its intermittent.

    [7/6/13 14:43:09:078 SAST] 0000003a SystemOut     O 14:43:09.078 [Thread-72] DEBUG c.s.m.m.a.i.b.util.BPMRestClientImpl - BPM call took: 600ms
    [7/6/13 14:43:09:147 SAST] 0000003a SystemOut     O 14:43:09.147 [Thread-72] DEBUG c.s.m.m.a.i.l.b.SearchAndPollForLeadsBPMTaskActivityImpl - Waited [1673] and found [Lead Overview]
    [7/6/13 14:43:09:147 SAST] 0000003a SystemOut     O 14:43:09.147 [Thread-72] DEBUG c.s.m.m.a.i.b.util.BPMRestClientImpl - JSON Request: GetTaskDetails
    [7/6/13 14:43:09:175 SAST] 0000003a SystemOut     O 14:43:09.174 [Thread-72] DEBUG c.s.m.m.a.i.b.util.BPMRestClientImpl - BPM call took: 27ms
    [7/6/13 14:43:09:175 SAST] 0000003a SystemOut     O 14:43:09.175 [Thread-72] DEBUG c.s.m.m.a.i.b.util.BPMRestClientImpl - JSON Response: GetTaskDetails
    {"status":"error","Data":{"status":"error","exceptionType":"com.ibm.bpm.wle.api.TaskDoesNotExistException","errorNumber":"CWTBG0048E","errorMessage":"CWTBG0048E: Task '17715' does not exist; it might have been deleted in the meantime.","errorMessageParameters":["17715"],"responses":null}}
    [7/6/13 14:43:09:175 SAST] 0000003a SystemOut     O 14:43:09.175 [Thread-72] ERROR c.s.m.m.a.i.b.util.BPMRestClientImpl - Error getting task detail:
    [7/6/13 14:43:09:188 SAST] 0000003a SystemOut     O 14:43:09.185 [Thread-72] ERROR c.s.m.m.a.impl.bpm.BPMAdaptorImpl - Problem getting task
    com.sbsa.mca.mc.data.bpm.exception.BPMException: CWTBG0048E: Task '17715' does not exist; it might have been deleted in the meantime.
     
  • kuki2333
    kuki2333
    24 Posts

    Re: A CWTBG0048E error occurs when service data is retrieved using REST Service API for IBM BPM

    ‏2013-07-08T05:21:38Z  
    • kuki2333
    • ‏2013-07-08T05:21:04Z

    Hi

     

    This is the call we are making  from a third party java application frontend running on Websphere..Task 17715 is not there 

    but cant be found .If i run it on RestAPI  bpmrest-ui frontend ,we get the results for this task.Running this call 10 minutes later we get the results so

    its intermittent.

    [7/6/13 14:43:09:078 SAST] 0000003a SystemOut     O 14:43:09.078 [Thread-72] DEBUG c.s.m.m.a.i.b.util.BPMRestClientImpl - BPM call took: 600ms
    [7/6/13 14:43:09:147 SAST] 0000003a SystemOut     O 14:43:09.147 [Thread-72] DEBUG c.s.m.m.a.i.l.b.SearchAndPollForLeadsBPMTaskActivityImpl - Waited [1673] and found [Lead Overview]
    [7/6/13 14:43:09:147 SAST] 0000003a SystemOut     O 14:43:09.147 [Thread-72] DEBUG c.s.m.m.a.i.b.util.BPMRestClientImpl - JSON Request: GetTaskDetails
    [7/6/13 14:43:09:175 SAST] 0000003a SystemOut     O 14:43:09.174 [Thread-72] DEBUG c.s.m.m.a.i.b.util.BPMRestClientImpl - BPM call took: 27ms
    [7/6/13 14:43:09:175 SAST] 0000003a SystemOut     O 14:43:09.175 [Thread-72] DEBUG c.s.m.m.a.i.b.util.BPMRestClientImpl - JSON Response: GetTaskDetails
    {"status":"error","Data":{"status":"error","exceptionType":"com.ibm.bpm.wle.api.TaskDoesNotExistException","errorNumber":"CWTBG0048E","errorMessage":"CWTBG0048E: Task '17715' does not exist; it might have been deleted in the meantime.","errorMessageParameters":["17715"],"responses":null}}
    [7/6/13 14:43:09:175 SAST] 0000003a SystemOut     O 14:43:09.175 [Thread-72] ERROR c.s.m.m.a.i.b.util.BPMRestClientImpl - Error getting task detail:
    [7/6/13 14:43:09:188 SAST] 0000003a SystemOut     O 14:43:09.185 [Thread-72] ERROR c.s.m.m.a.impl.bpm.BPMAdaptorImpl - Problem getting task
    com.sbsa.mca.mc.data.bpm.exception.BPMException: CWTBG0048E: Task '17715' does not exist; it might have been deleted in the meantime.
     

    We have a logged a call with IBM as well and they are looking at it.

  • HH0C_MICHAEL_DUFFY
    HH0C_MICHAEL_DUFFY
    6 Posts

    Re: A CWTBG0048E error occurs when service data is retrieved using REST Service API for IBM BPM

    ‏2013-07-29T07:18:18Z  
    • kuki2333
    • ‏2013-07-08T05:21:38Z

    We have a logged a call with IBM as well and they are looking at it.

    Hi there kuki2333,

    Could you please let me know as to the progress with resolving this issue ? We are experiencing something very similar in our application.

    Thanks in advance,

    Mike.