Topic
  • 3 replies
  • Latest Post - ‏2013-08-26T07:25:50Z by JanMeyer
6JWW_Kurt_Johnson
6JWW_Kurt_Johnson
1 Post

Pinned topic Java API: how to specify rhapsody release in RhapsodyAppServer

‏2013-05-20T21:55:46Z |

I have 2 versions of Rhapsody installed, 7.6.1 and 8.0.1.  When obtaining a reference to a IRPApplication thru RhapsodyAppServer.getActiveRhapsodyApplication() or createRhapsodyApplication() I get an exception:

Exception in thread "main" com.telelogic.rhapsody.core.RhapsodyRuntimeException: Wrong Rhapsody Release
Expected:       7.6.1.0
Actual:         8.0.1.0

How do I specify/configure which version that the Java API should use?  I'm running on Windows 7.  Is there a registry setting to change to flip back and forth if I can't do it programatically thru the API?  Where is the javadoc for RhapsodyAppServer?

(I can get rid of the exception by using the rhapsody.dll from version 8 but doesn't answer the question of how to specify version.)

  • RockeyBhardwaj
    RockeyBhardwaj
    10 Posts

    Re: Java API: how to specify rhapsody release in RhapsodyAppServer

    ‏2013-08-22T11:31:56Z  

    Hello 

    I am also suffering from the same problem. If anybody has the solution please mail me at email-ID:

    rockey@allsoftsolutions.in

     

     

    Thanks and regards

    Rockey Bhardwaj 

  • AE91_SHINJI_KANAI
    AE91_SHINJI_KANAI
    199 Posts

    Re: Java API: how to specify rhapsody release in RhapsodyAppServer

    ‏2013-08-23T10:49:47Z  

    Hello

    I don't think what you are trying to do is possible, but following tech note might help:

    http://www-01.ibm.com/support/docview.wss?uid=swg21644501

    Hope it will of any help.

    --Shinji

  • JanMeyer
    JanMeyer
    4 Posts

    Re: Java API: how to specify rhapsody release in RhapsodyAppServer

    ‏2013-08-26T07:25:50Z  

    Hello together,

    the main problem is that the necessary files for the Java API were not updated. So if you replace the Rhapsody.dll file in your jre/bin directory and uses the newest Rhapsody.jar file, then the error message is no longer available.

     

    Best regards

    Jan