Topic
  • 7 replies
  • Latest Post - ‏2014-01-15T05:55:02Z by Filenet_Rokkz
SOA-BOB
SOA-BOB
61 Posts

Pinned topic Slow Logon Response Time

‏2014-01-08T14:25:13Z |

We are experiencing slow response time during logon.  What can we do to trace the issue or performance tune logon?

 

Thanks,

Bob Rogers

  • damorris
    damorris
    825 Posts

    Re: Slow Logon Response Time

    ‏2014-01-08T18:17:39Z  

    Hi Bob,

    Can you quantify "slow" in seconds?  Is it the actual login action after you click the logon button or are you referring to just loading the main Content Navigator page?

    What version - 2.0.1 or 2.0.2?  Any single sign-on solutions in play?

    Generally you can use Firebug or Chrome developer tools and take a look at the Network tab to see the requests being made and note the times taken.  In most cases I recommend a PMR to troubleshoot this type of issue as they can often be quite complex and often very much environment related.

  • SOA-BOB
    SOA-BOB
    61 Posts

    Re: Slow Logon Response Time

    ‏2014-01-08T18:29:36Z  
    • damorris
    • ‏2014-01-08T18:17:39Z

    Hi Bob,

    Can you quantify "slow" in seconds?  Is it the actual login action after you click the logon button or are you referring to just loading the main Content Navigator page?

    What version - 2.0.1 or 2.0.2?  Any single sign-on solutions in play?

    Generally you can use Firebug or Chrome developer tools and take a look at the Network tab to see the requests being made and note the times taken.  In most cases I recommend a PMR to troubleshoot this type of issue as they can often be quite complex and often very much environment related.

     We have verson 2.0.2 installed with SSO.  We are in the process of tracing via Firebug and I pretty sure we are going to open a PMR.  I will let everyone know what we find.

  • damorris
    damorris
    825 Posts

    Re: Slow Logon Response Time

    ‏2014-01-08T18:39:01Z  
    • SOA-BOB
    • ‏2014-01-08T18:29:36Z

     We have verson 2.0.2 installed with SSO.  We are in the process of tracing via Firebug and I pretty sure we are going to open a PMR.  I will let everyone know what we find.

    What type of SSO?  Is it Kerberos?

  • SOA-BOB
    SOA-BOB
    61 Posts

    Re: Slow Logon Response Time

    ‏2014-01-09T12:32:20Z  
    • damorris
    • ‏2014-01-08T18:39:01Z

    What type of SSO?  Is it Kerberos?

    We are actually not utilizing SSO in our PVS (Production/Volume/Stress) environment since we are simulating +3500 users logging onto and performing searches in ICN.

  • damorris
    damorris
    825 Posts

    Re: Slow Logon Response Time

    ‏2014-01-09T13:34:11Z  
    • SOA-BOB
    • ‏2014-01-09T12:32:20Z

    We are actually not utilizing SSO in our PVS (Production/Volume/Stress) environment since we are simulating +3500 users logging onto and performing searches in ICN.

    So are you only seeing slow logon time during the stress test?  What is the think time in between operations?  Are you having the script logon, run a search, then logoff every time you simulate a 'user' (less realistic) or are you having them stay logged in for a while (more realistic).  What other operations do they perform

    The think time is extremely important as if it's too low then you are actually pushing a lot more than 3500 simulated users through the system.  Also worth understanding whether you are testing 3500 users with a multiple node system or just a single node?

    Additional operations that can greatly impact the performance of the system:

    Do you have the Content Navigator thumbnail feature enabled?

    Are you simulating launching the viewer?

    Any other notable operations?

  • Patrick van der Horst
    25 Posts

    Re: Slow Logon Response Time

    ‏2014-01-14T08:13:36Z  

    We experienced the same issue with the Content Analytics plugin enabled. Currently in the process of analysing what the problem is there...

  • Filenet_Rokkz
    Filenet_Rokkz
    6 Posts

    Re: Slow Logon Response Time

    ‏2014-01-15T05:55:02Z  

    We experienced the same issue with the Content Analytics plugin enabled. Currently in the process of analysing what the problem is there...

    Hi,

    Even i am also facing the same issue and done setting as per IBM performance tuning guide. I think for logon issue you can try recommedation given in guide. Also one setting is there is ICN settings tab Cache refresh interval (in minutes) which we can increase.