Topic
  • 7 replies
  • Latest Post - ‏2018-10-30T11:35:17Z by Shanmukha Srivalli Vaddadi
mallikkoduru
mallikkoduru
4 Posts

Pinned topic mqsiprofile has not been run in this environment:

‏2017-01-22T17:03:54Z | been environment: has in mqsiprofile not run this

Hi All,

I'm new to IIB. Was trying to start using the IIB V10, and facing multiple issues.

1. The IIB Toolkit doesnt open when clicked on IBM Integration Toolkit icon. Have tried to launch it using the eclipse icon in the Installation folder, and it worked

2. After launch of the IIB Toolkit, noticed the Integration node never started. Tried starting the same via the Toolkit as well as Command line. The Integration node is not started and is showing the below error

mqsiprofile has not been run in this environment: LocalIAPIConnect (Not found in java.library.path) 

 Check that, 
    1. The integration node is running.
    2. The TCP/IP port of the queue manager is active if it is remote.
    3. The integration node name provided in the connection details matches the name of the integration node if the node is remote.

 

Checked for the mqsiprofile file in the install directory and wasnt able to decode the same in relation to the error. Also, tried reinstalling the Toolkit and MQ 7.5 with no good result. 

OS : Windows 10

IIB : V10,0

MQ : 7.5

JDK : 1.8.111

 

Request your support in resolving the issue ASAP.

Thanks

Malli

  • lancelotlinc
    lancelotlinc
    485 Posts

    Re: mqsiprofile has not been run in this environment:

    ‏2017-01-23T13:35:46Z  

    Hi Malli - sounds like you did not follow the installation steps.

     

    https://www.ibm.com/support/knowledgecenter/en/SSMKHH_10.0.0/com.ibm.etools.mft.doc/bh25992_.htm

     

    There is more to installing than just unzipping files.

     

  • mallikkoduru
    mallikkoduru
    4 Posts

    Re: mqsiprofile has not been run in this environment:

    ‏2017-01-23T16:38:51Z  

    Hi Malli - sounds like you did not follow the installation steps.

     

    https://www.ibm.com/support/knowledgecenter/en/SSMKHH_10.0.0/com.ibm.etools.mft.doc/bh25992_.htm

     

    There is more to installing than just unzipping files.

     

    Hi,

     

    Thanks for the reply. The problem that I'm facing is with the installation on the Windows 10 System. Have tried multiple options of reinstalling the JDK, MQ 7.5 and IIB V10. None of them worked.

    It seems like that there is some type of compatibility issues. 

    I'm newbie to Java and IIB world, and clueless to resolve the issue. Also, seems no post is available on this issue over internet.

     

    Thanks

    Malli

  • lancelotlinc
    lancelotlinc
    485 Posts

    Re: mqsiprofile has not been run in this environment:

    ‏2017-01-23T17:55:54Z  

    Hi,

     

    Thanks for the reply. The problem that I'm facing is with the installation on the Windows 10 System. Have tried multiple options of reinstalling the JDK, MQ 7.5 and IIB V10. None of them worked.

    It seems like that there is some type of compatibility issues. 

    I'm newbie to Java and IIB world, and clueless to resolve the issue. Also, seems no post is available on this issue over internet.

     

    Thanks

    Malli

    To use IIB with windows 10, you must be on 10.0.0.7 maintenance level.

  • mallikkoduru
    mallikkoduru
    4 Posts

    Re: mqsiprofile has not been run in this environment:

    ‏2017-01-23T18:00:43Z  

    To use IIB with windows 10, you must be on 10.0.0.7 maintenance level.

    Ok. Will check with 10.0.0.7 again. However, i did try it before and sure that it hadn't worked (have both 10.0.0.0 and 10.0.0.7 versions with me). Let me know if there any log files that are of significance, for resolving this issue.

    Thanks in advance.

  • lancelotlinc
    lancelotlinc
    485 Posts

    Re: mqsiprofile has not been run in this environment:

    ‏2017-01-23T20:23:01Z  

    Ok. Will check with 10.0.0.7 again. However, i did try it before and sure that it hadn't worked (have both 10.0.0.0 and 10.0.0.7 versions with me). Let me know if there any log files that are of significance, for resolving this issue.

    Thanks in advance.

    I just did an install for 10.0.0.7 on Windows 7. It worked.

  • mallikkoduru
    mallikkoduru
    4 Posts

    Re: mqsiprofile has not been run in this environment:

    ‏2017-01-23T20:30:37Z  

    I just did an install for 10.0.0.7 on Windows 7. It worked.

    Ok. Let me know if any configuration details,services, registry entries have to be validated before reinstalling the IIB V10 (10.0.0.7).

    Thank you

  • Shanmukha Srivalli Vaddadi
    2 Posts

    Re: mqsiprofile has not been run in this environment:

    ‏2018-10-30T11:35:17Z  

    Ok. Let me know if any configuration details,services, registry entries have to be validated before reinstalling the IIB V10 (10.0.0.7).

    Thank you

    hello mallikkoduru ..I am also facing the same issue now.. Did you get any solution for this error ..If so, Please post the solution here...