Topic
  • 1 reply
  • Latest Post - ‏2013-07-16T05:50:11Z by YuanFeng
Brian_Laube
Brian_Laube
5 Posts

Pinned topic Data Studio (4.1 and 3.2) use of SYPROC.DSNUTILS?

‏2013-07-02T17:41:51Z |

I am using IBM Data Studio V4.1 (and v3.2) and I have recently tried using the data source explorer to drill down into into tables under a schema.

I can right-click on the table-name to get a little pop-up window which includes the option "update statistics". 

I then attempt to choose this option but I receive the error message "INVOCATION OF FUNCTION OR PROCEDURE SYSPROC.DSNUTILS FAILED DUE TO REASON 00E79001"

I understand the error message.

But why is IBM data studio using sysproc.dsnutilS (suffix of S) instead of sysproc.dsnutilU (suffix of U)?

According to the IBM documentation "DSNUTILS has been deprecated in favor of DSNUTILU"

http://pic.dhe.ibm.com/infocenter/dzichelp/v2r2/topic/com.ibm.db2z10.doc.ugref/src/tpc/db2z_sp_dsnutils.htm

I know that IBM Data Studio does use sysproc.dsnutilU with other functionality... it does work when I "explain and tuen" sql and I run the suggested repair/complete runtats.  That does work...

Is it just this specific function does not use the proper procedure?

regards,

Brian Laube

  • YuanFeng
    YuanFeng
    81 Posts

    Re: Data Studio (4.1 and 3.2) use of SYPROC.DSNUTILS?

    ‏2013-07-16T05:50:11Z  

    It looks like a defect, we will follow up with that,thanks for raise the issue.