Topic
7 replies Latest Post - ‏2013-08-19T17:50:16Z by AndrewPaier
Shivam Verma
Shivam Verma
25 Posts
ACCEPTED ANSWER

Pinned topic LOGIN Error when changing password for windows

‏2013-08-13T12:30:26Z |

Hello Everyone,
I have a Login problem. I am not able to login to the IBM BPM Server (Process Portal, Process Designer, Process Admin Console or anything else)
This happened right after I changed my windows password. (Before that I was able to login and work)
The server is running fine, all the Portal pages are also getting opened. But not able to login.

How to resolve this issue.
I am using IBM BPM 8.0.1 Express

With Regards,
Shivam Verma

  • AndrewPaier
    AndrewPaier
    711 Posts
    ACCEPTED ANSWER

    Re: LOGIN Error when changing password for windows

    ‏2013-08-13T19:09:22Z  in response to Shivam Verma

    Are you running the server on your local machine?  If so I suspect your server is not starting up right.  This may be because the DB2 Express Instance isn't able to start or some other problem.  What is in the server logs when you start up the server?

    Andrew Paier  |  Director  |  BP3 Global, Inc.
    BP3 Global's Website  |  Twitter  |  Linkedin  |  Google+  |  Blogs

    • Shivam Verma
      Shivam Verma
      25 Posts
      ACCEPTED ANSWER

      Re: LOGIN Error when changing password for windows

      ‏2013-08-14T06:33:42Z  in response to AndrewPaier

      Hello Andrew,
      PFB the start server log from the last run. I did not find any error in this, may be I missed some thing.
      Also PFA the log (SystemOut.log) generated right after I try to log into the PD, it say at the last that unable to authenticate.
      My DB2 is running just fine, I am able to open control center.

      \ProcCtr01\logs\server1\startServer.log
      ************ Start Display Current Environment ************
      Host Operating System is Windows 7, version 6.1
      Java version = 1.6.0, Java Compiler = j9jit26, Java VM name = IBM J9 VM
      was.install.root = C:\IBM\BPM\v8.0.1
      user.install.root = C:\IBM\BPM\v8.0.1\profiles\ProcCtr01
      Java Home = C:\IBM\BPM\v8.0.1\java\jre
      ws.ext.dirs = C:\\IBM\\BPM\\v8.0.1\\java\\lib;C:\\IBM\\BPM\\v8.0.1\\classes;C:\\IBM\\BPM\\v8.0.1\\lib;C:\\IBM\\BPM\\v8.0.1\\installedChannels;C:\\IBM\\BPM\\v8.0.1\\lib\\ext;C:\\IBM\\BPM\\v8.0.1\\web\\help;C:\\IBM\\BPM\\v8.0.1\\deploytool\\itp\\plugins\\com.ibm.etools.ejbdeploy\\runtime
      Classpath = C:\IBM\BPM\v8.0.1\profiles\ProcCtr01\properties;C:\IBM\BPM\v8.0.1\properties;C:\IBM\BPM\v8.0.1\lib\startup.jar;C:\IBM\BPM\v8.0.1\lib\bootstrap.jar;C:\IBM\BPM\v8.0.1/lib/lmproxy.jar;C:\IBM\BPM\v8.0.1/lib/urlprotocols.jar;C:\IBM\BPM\v8.0.1\java\lib\tools.jar
      Java Library path = C:\IBM\BPM\v8.0.1\java\jre\bin\default;C:\IBM\BPM\v8.0.1\java\jre\bin;C:\Windows\system32;C:\Windows;C:\IBM\BPM\v8.0.1\lib\native\win\x86_32;C:\IBM\BPM\v8.0.1\bin;C:\IBM\BPM\v8.0.1\java\bin;C:\IBM\BPM\v8.0.1\java\jre\bin;d:\app\shivam_verma\product\11.1.0\db_1\bin;C:\Windows\system32;C:\Windows;C:\Windows\system32\wbem;C:\Windows\system32\windowspowershell\v1.0\;c:\program files\ati technologies\ati.ace\core-static;c:\program files\microsoft application virtualization client;c:\program files\ibm\gsk8\lib;C:\IBM\BPM\v8.0.1\db2\BIN;C:\IBM\BPM\v8.0.1\db2\FUNCTION;C:\IBM\BPM\v8.0.1\db2\SAMPLES\REPL;.
      Orb Version = IBM Java ORB build orb626ifx-20120304.00 (++191257)
      Current trace specification = *=info:com.ibm.*=all
      ************* End Display Current Environment *************
      [8/14/13 11:47:52:150 IST] 00000000 ManagerAdmin  I   TRAS0017I: The startup trace state is *=info:com.ibm.*=all.
      [8/14/13 11:47:52:212 IST] 00000000 WsServerContr 1   Executing executeUtilityOnWindows with args: C:\IBM\BPM\v8.0.1\profiles\ProcCtr01\config HYDPCM266417DNode01Cell HYDPCM266417DNode01 server1
      [8/14/13 11:47:52:212 IST] 00000000 WsServerContr 1   Getting WindowsService obj with: server1 and C:\IBM\BPM\v8.0.1\profiles\ProcCtr01\config HYDPCM266417DNode01Cell HYDPCM266417DNode01 server1
      [8/14/13 11:47:52:243 IST] 00000000 WindowsServic >  WindowsService for server server1 Entry
                                       <null>
      [8/14/13 11:47:52:243 IST] 00000000 WindowsServic >  getWindowsServiceNameForServer server1 Entry
                                       <null>
      [8/14/13 11:47:52:243 IST] 00000000 WindowsServic >  getWASServiceCmdPath  Entry
                                       <null>
      [8/14/13 11:47:52:243 IST] 00000000 WindowsServic 1   In executeCommand, args are: C:\IBM\BPM\v8.0.1\bin\WASService.exe -getServiceName server1 -profilePath C:\IBM\BPM\v8.0.1\profiles\ProcCtr01
      [8/14/13 11:47:52:274 IST] 00000000 WindowsServic 1   Runtime.exec() returned process java.lang.ProcessImpl@80af8a5e
      [8/14/13 11:47:52:384 IST] 00000000 WindowsServic 1   retCode from childProcess.waitFor() is 0
      [8/14/13 11:47:52:384 IST] 00000000 WindowsServic 3   exitCode = 0
      [8/14/13 11:47:53:398 IST] 00000000 WindowsServic <  getWindowsServiceNameForServer Exit
      [8/14/13 11:47:53:398 IST] 00000000 WindowsServic 1   Trying to new up WindowsService using serverName=server1, winServiceName=null
      [8/14/13 11:47:53:398 IST] 00000000 ManagerAdmin  I   TRAS0018I: The trace state has changed. The new trace state is *=info.
      [8/14/13 11:47:53:834 IST] 00000000 AdminTool     A   ADMU0128I: Starting tool with the ProcCtr01 profile
      [8/14/13 11:47:53:834 IST] 00000000 AdminTool     A   ADMU3100I: Reading configuration for server: server1
      [8/14/13 11:47:53:881 IST] 00000000 ImplFactory   W   WSVR0072W: Ignoring undeclared override of interface, com.ibm.websphere.cluster.topography.DescriptionManager, with implementation, com.ibm.ws.cluster.propagation.bulletinboard.BBDescriptionManager
      [8/14/13 11:47:54:973 IST] 00000000 ModelMgr      I   WSVR0801I: Initializing all server configuration models
      [8/14/13 11:48:03:538 IST] 00000000 WorkSpaceMana A   WKSP0500I: Workspace configuration consistency check is disabled.
      [8/14/13 11:48:07:724 IST] 00000000 AdminTool     A   ADMU3200I: Server launched. Waiting for initialization status.

      With Regards,
      Shivam Verma

      Attachments

      • AndrewPaier
        AndrewPaier
        711 Posts
        ACCEPTED ANSWER

        Re: LOGIN Error when changing password for windows

        ‏2013-08-14T14:14:45Z  in response to Shivam Verma

        That should not be the end of the start server log.  The start server log always ends with something like (emphasis added)- 

        [8/5/13 14:35:40:895 EDT] 00000001 AdminTool     A   ADMU3000I: Server SingleClusterMember1 open for e-business; process id is 2165

        So it would be good to go back and look at that log and see if there is any errors after the above and before the "open for e-business" shows up.  Your login seems to be attempting to validate you against an LDAP connector (if I'm reading properly).  Did you configure an LDAP security provider in your federated provider?  If so, does that provider use a login to connect to LDAP?  It could be that the log simply has LDAP in it even though you haven't actually done any LDAP connections, so I'm just wondering.  It would surprise me that bpmadmin is in your LDAP, but figured I would ask.

        Also, you haven't confirmed if this is a server running on your own machine or a separate box.  I'm assuming your own machine, but can you please confirm?

        Andrew Paier  |  Director  |  BP3 Global, Inc.
        BP3 Global's Website  |  Twitter  |  Linkedin  |  Google+  |  Blogs

         

         

        • Shivam Verma
          Shivam Verma
          25 Posts
          ACCEPTED ANSWER

          Re: LOGIN Error when changing password for windows

          ‏2013-08-14T14:32:52Z  in response to AndrewPaier

          Hello Andrew,
          I double checked the Start Server log and those are the lines from todays log. (I copied entire log till the end from todays date)
          Yes I have an LDAP Server, and the credentials I am using to login into LDAP server are the same as my windows credentials. (which I changed)
          bpmadmin is not a user in my LDAP repository.
          Yes the BPM Server is running on my local machine (windows)

          My Guess based on inputs from you and my little research is this:

          Cause -->
          When I login to any Portal or Process Designer, IBM BPM check the credentials against the user details in DB2 & also in LDAP.
          Since I changed my windows password (which is same as the credential used to login to LDAP) so the authentication process is failing and hence I am not able to log in.

          Theoretical Resolution --> (assuming my root cause is what I think it is)
          Change the credentials in the LDAP configuration file:
          "WAS_Root_directory\profiles\ProcCtr01\config\cells\HYDPCM266417DNode01Cell\wim\config"
          The password is encrypted. (Something like: {xor}XXXXXXXXXXXXXX)
          What I did is I went to a different Server, configured LDAP there with my new password.
          Copied the encrypted password from there and pasted the same in my configuration file.
          But this does not work. (may be the key used for encryption by different server is different)

          Thank You,
          With Regards,
          Shivam Verma

          • AndrewPaier
            AndrewPaier
            711 Posts
            ACCEPTED ANSWER

            Re: LOGIN Error when changing password for windows

            ‏2013-08-19T13:39:27Z  in response to Shivam Verma

            The password is not encrypted differently in each server.  As a matter of fact there is a web site here that can both encrypt and decrypt WAS passwords in those files.  This is logical since really the password is just obfuscated.  WAS needs to be able to submit the real password to the LDAP server in order to login.  Check your current passwords using that site.

            Andrew Paier  |  Director  |  BP3 Global, Inc.
            BP3 Global's Website  |  Twitter  |  Linkedin  |  Google+  |  Blogs

            • Shivam Verma
              Shivam Verma
              25 Posts
              ACCEPTED ANSWER

              Re: LOGIN Error when changing password for windows

              ‏2013-08-19T13:49:50Z  in response to AndrewPaier

              I have already changed the password in the file but it still does not work.
              I verified the new encrypted password with the link that you gave. It is indeed the new password.

              Is there any other place where to change the password apart from the one that I mentioned above?