Topic
  • 2 replies
  • Latest Post - ‏2018-10-25T13:15:14Z by sxiao
SohailRiaz
SohailRiaz
5 Posts

Pinned topic GPFS Client force not mount

‏2018-10-25T07:05:07Z |

Hi Guys,

 

I am looking a way to stop clients to mount filesystem accidentally when I am doing some maintenance and required no client to mount at anytime.

 

Regards,

 

SR

  • oester
    oester
    259 Posts

    Re: GPFS Client force not mount

    ‏2018-10-25T11:32:05Z  

    I'm assuming you want to do more that just turning off automount (mmchfs <fsname> -A no). The only other option I can think of is using ignoreStartupMount and/or ignoreAnyMount  in /var/mmfs/etc/. This is documented in the Wiki:

     

    https://www.ibm.com/developerworks/community/wikis/home?lang=en#!/wiki/General%20Parallel%20File%20System%20(GPFS)/page/File%20System%20Management/version/f438f717-48aa-40ab-a972-93f634263fef

     

    Bob Oesterlin

    Nuance Communications

  • sxiao
    sxiao
    61 Posts

    Re: GPFS Client force not mount

    ‏2018-10-25T13:15:14Z  
    • oester
    • ‏2018-10-25T11:32:05Z

    I'm assuming you want to do more that just turning off automount (mmchfs <fsname> -A no). The only other option I can think of is using ignoreStartupMount and/or ignoreAnyMount  in /var/mmfs/etc/. This is documented in the Wiki:

     

    https://www.ibm.com/developerworks/community/wikis/home?lang=en#!/wiki/General%20Parallel%20File%20System%20(GPFS)/page/File%20System%20Management/version/f438f717-48aa-40ab-a972-93f634263fef

     

    Bob Oesterlin

    Nuance Communications

    5.0.2 release introduced a new filesystem maintenance mode which is designed to prevent filesystem mount during maintenance window.