Topic
  • 5 replies
  • Latest Post - ‏2013-07-15T12:46:19Z by teletype
teletype
teletype
27 Posts

Pinned topic poll: setup failure when making mksysb

‏2013-06-13T12:43:43Z |

Hello all,

This is the error we get back after making a mksysb-image:

   0042-001 nim: processing error encountered on "master":
   m_mkbosi: define the apwgpu04_mksysb@master BOS image resource
   ;
   rc=6
   0042-006 m_mkbosi: (From_Master) connect Error 0

   poll: setup failure



We are running the command below for making an image:

        nim -o define -t mksysb -a location=/export/backups/ standalone/<hostname> \
          -a server=master -a mk_image=yes -a source=<hostname> -a force=yes \
          -a mksysb_flags=-imeX <hostname>

After it failed, we start it again and then it passes:

   +---------------------------- ------------------------------ -----------+
                   System Backup Image Space Information
                 (Sizes are displayed in 1024-byte blocks.)
   +---------------------------- ------------------------------ -----------+

   Required = 2940552 (2872 MB)    Available = 138211856 (134973 MB)



   Creating information file (/image.data) for rootvg..

   Creating list of files to back up.
   Backing up 54275 files......................... .....
   30612 of 54275 files (56%)..............

   54275 of 54275 files (100%)
   0512-038 savevg: Backup Completed Successfully.


It doesn't look like a nim-sh problem because the following commands are also working:

-nim -o showlog <hostname>
-nim -o lslpp <hostname>

We have discovered that this message "poll: setup failure" comes from a library "/usr/lib/libnim.a".
The problem is that we don't know how/why/when this message is generated (in what conditions).

 

I found this blog but that does not help me with this.

Any suggestions were to look? Personaly I think it has someting to do with nfs.

Some more info:

AIX version:

6100-07-05-1228

This is our master object in nim (without the serves lines):

master:
  class               = machines
  type                = master
  max_nimesis_threads = 150
  if_defined          = chrp.64.ent
  if_defined          = chrp.mp.ent
  comments            = machine which controls the NIM environment
  nfs_reserved_port   = yes
  ssl_support         = yes
  global_export       = yes

  platform            = chrp
  netboot_kernel      = mp
  if1                 = nimnet0 <<MASTER_FQDN>> <<CPUID>>
  cable_type1         = tp
  Cstate              = ready for a NIM operation
  prev_state          = ready for a NIM operation
  Mstate              = currently running
  master_port         = 1058
  registration_port   = 1059
  Cstate_result       = success
  reserved            = yes

We changed the bold lines.

Attachments

Updated on 2013-06-13T12:45:44Z at 2013-06-13T12:45:44Z by teletype
  • GarlandJoseph
    GarlandJoseph
    159 Posts

    Re: poll: setup failure when making mksysb

    ‏2013-06-20T17:07:13Z  

    Possible setup issue.  How does the client appear in nim?

  • AIX_KGB
    AIX_KGB
    3 Posts

    Re: poll: setup failure when making mksysb

    ‏2013-06-26T05:01:33Z  

    It doesn't look like a setup issue, because when he starts the command again it is passed. Maybe a timing-issue.

     

  • GarlandJoseph
    GarlandJoseph
    159 Posts

    Re: poll: setup failure when making mksysb

    ‏2013-06-26T17:44:37Z  

    Possible setup issue.  How does the client appear in nim?

    Setup with respect to the client.

  • teletype
    teletype
    27 Posts

    Re: poll: setup failure when making mksysb

    ‏2013-06-28T06:35:19Z  

    The configuration is not different from other clients. However I don't think the setup of the client is the problem. We use a script that runs multiple instances of mksysb in parallel. If I restart the script it will run correctly for that client. It is not everytime the same client that fails. It looks somewat random.

     # lsnim -l client
    client:
       class          = machines
       type           = standalone
       connect        = nimsh (secure)
       current_master = master.<fqdn>
       sync_required  = yes
       platform       = chrp
       netboot_kernel = mp
       if1            = ent-Network1 client.<fqdn> 0
       cable_type1    = tp
       Cstate         = ready for a NIM operation
       prev_state     = not running
       Mstate         = currently running
       cpuid          = 000000000000
       Cstate_result  = reset

    # lsnim -l ent-Network1

    ent-Network1:
       class      = networks
       type       = ent
       comments   = Generated during definition of someclient.<fqdn>
       Nstate     = ready for use
       prev_state = ready for use
       net_addr   = xx.xx.xx.xx
       snm        = 255.255.255.0
       routing1   = default xx.xx.xx.254

     

  • teletype
    teletype
    27 Posts

    Re: poll: setup failure when making mksysb

    ‏2013-07-15T12:46:19Z  

    I made a PMR for thes. The suggestion from IBM is to use a secondary port range on the nimclient. We are looking into that now. I will try to keep you posted.