Topic
  • 2 replies
  • Latest Post - ‏2014-04-23T11:49:25Z by LukeNumrych
LukeNumrych
LukeNumrych
57 Posts

Pinned topic [bug report] Data Studio 4.1.0.1 configuration repository problems

‏2014-04-10T14:07:43Z |

I am trying to set up a connection configuration repository for my team to use with Data Studio 4.1.0.1 (on Windows 7); however, I am running into the following problems:

  1. I can successfully set up a connection to the repository database, and create the repository objects in it.  This works fine.  However, when I right-click on the repository and inspect its Properties->Configuration Repository Connection Properties , I get the following error: "The currently displayed page contains invalid values" (see screenshot 1).
  2. Once I get into the Configuration Repository Connection Properties, I get an error "Required property in driver definition missing value: Connection URL." displayed on the top of the window.  The properties portion of the window is empty. (see screenshot 2).
  3. I attempted to "Edit Driver Definition" by adding a Connection URL to my repository DB; however, this only resulted in a new error: "Define and select a driver..." (even that one is clearly already selected) displayed when accessing the Configuration Repository Connection Properties (see screenshot 3).
  4. The above errors are nuisance, they do not seem to affect the operation of the repository in that I can still add/remove/group connection configurations to it.  The biggest problem is the following: any connection that I attempt to create using the stored connection configuration defaults to database name "SAMPLE", even that the connection configuration has a different database name defined (see screenshots 4 and 5).

 

Updated on 2014-04-10T14:17:25Z at 2014-04-10T14:17:25Z by LukeNumrych
  • Stony
    Stony
    8 Posts

    Re: [bug report] Data Studio 4.1.0.1 configuration repository problems

    ‏2014-04-23T03:29:08Z  

    Thanks for your report! We will look into it.

  • LukeNumrych
    LukeNumrych
    57 Posts

    Re: [bug report] Data Studio 4.1.0.1 configuration repository problems

    ‏2014-04-23T11:49:25Z  
    • Stony
    • ‏2014-04-23T03:29:08Z

    Thanks for your report! We will look into it.

    No problem.  I also submitted a report via the Data Studio built-in reporting feature.