Topic
  • 5 replies
  • Latest Post - ‏2013-04-18T13:47:14Z by nicolas.leralle
UhPikaMiolus
UhPikaMiolus
3 Posts

Pinned topic Enable SSO in Content Navigator

‏2013-04-18T11:42:41Z |

Hi,

i'm try to enable SSO in Content Navigator. I followed the steps described in http://www-01.ibm.com/support/docview.wss?uid=swg27036837 but after that when i try to access the url of CN it prompts me to insert login and password.

 

Has anyone else had this issue?

 

Thanks.

Updated on 2013-04-18T11:42:56Z at 2013-04-18T11:42:56Z by UhPikaMiolus
  • nicolas.leralle
    nicolas.leralle
    102 Posts

    Re: Enable SSO in Content Navigator

    ‏2013-04-18T11:46:11Z  

    Hi,

     

    Can you please describe your environment?

    Application Server, LDAP solution, Operating System, etc.?

     

    Best regards,

     

    Nicolas

  • UhPikaMiolus
    UhPikaMiolus
    3 Posts

    Re: Enable SSO in Content Navigator

    ‏2013-04-18T11:53:14Z  

    Hi,

     

    Can you please describe your environment?

    Application Server, LDAP solution, Operating System, etc.?

     

    Best regards,

     

    Nicolas

    Hi Nicolas,

    i have two machines. One is running Content Engine and the other is running XT and CN.

    The OS is linux based - Suse. The LDAP is ActiveDirectory 2008. The Application server is WAS 7.0.0.23. The Filenet version is 5.0.1 and the Content navigator is in the last version (2.0.1).

    I have already configured SSO for WorkplaceXT and is working fine. The SSO was configured using SPNEGO.

    The content navigator is in the same cell of XT.

    Best regards,

     

    Luis

  • nicolas.leralle
    nicolas.leralle
    102 Posts

    Re: Enable SSO in Content Navigator

    ‏2013-04-18T12:02:01Z  

    Hi Nicolas,

    i have two machines. One is running Content Engine and the other is running XT and CN.

    The OS is linux based - Suse. The LDAP is ActiveDirectory 2008. The Application server is WAS 7.0.0.23. The Filenet version is 5.0.1 and the Content navigator is in the last version (2.0.1).

    I have already configured SSO for WorkplaceXT and is working fine. The SSO was configured using SPNEGO.

    The content navigator is in the same cell of XT.

    Best regards,

     

    Luis

    I have a quite similar configuration (RHEL instead of Suse).

    I forgot the step:

     

    To configure IBM Content Navigator for SSO by using Kerberos/SPNEGO: 


    1. Run the IBM Content Navigator Configuration and Deployment Tool. Create a new deployment on WebSphere Application Server.

      When you complete the Connect to WebSphere Application Server task, ensure that you select the Configure IBM Content Navigator for SSO (P8 only). This option creates the user/group security on WebSphere Application Server when you deploy IBM Content Navigator.


     

     

    I guess you followed this step, but check that the groups are present.

     

    You can also use "windows monitor network traffic" in your client workstation to see what HTTP codes are send by the server. It may explain what's going wrong.

     

    Best regards,

     

    Nicolas

  • UhPikaMiolus
    UhPikaMiolus
    3 Posts

    Re: Enable SSO in Content Navigator

    ‏2013-04-18T13:21:54Z  

    I have a quite similar configuration (RHEL instead of Suse).

    I forgot the step:

     

    To configure IBM Content Navigator for SSO by using Kerberos/SPNEGO: 


    1. Run the IBM Content Navigator Configuration and Deployment Tool. Create a new deployment on WebSphere Application Server.

      When you complete the Connect to WebSphere Application Server task, ensure that you select the Configure IBM Content Navigator for SSO (P8 only). This option creates the user/group security on WebSphere Application Server when you deploy IBM Content Navigator.


     

     

    I guess you followed this step, but check that the groups are present.

     

    You can also use "windows monitor network traffic" in your client workstation to see what HTTP codes are send by the server. It may explain what's going wrong.

     

    Best regards,

     

    Nicolas

    Nicolas,

     

    i've done all the steps but i didn't find the user/groups that are mentioned in the documentation. Do you know what user/groups are?

     

    Thanks

  • nicolas.leralle
    nicolas.leralle
    102 Posts

    Re: Enable SSO in Content Navigator

    ‏2013-04-18T13:47:14Z  

    Nicolas,

     

    i've done all the steps but i didn't find the user/groups that are mentioned in the documentation. Do you know what user/groups are?

     

    Thanks

    I don't have my platform to confirm this point, but I think that you must have the "Everyone" and "All authenticated" groups in your user / groups mapping for navigator:

     

    In WAS 7.0 => Application > Application Types > WebSphere entreprise Applications > navigator > user groups role mapping.

     

    I would say that you have to see the same configuration than WorkplaceXT in order SSO to work.

     

    Best regards,

    Nicolas