Topic
IC4NOTICE: developerWorks Community will be offline May 29-30, 2015 while we upgrade to the latest version of IBM Connections. For more information, read our upgrade FAQ.
2 replies Latest Post - ‏2014-12-16T14:56:48Z by ammarhassan
Developer.works
Developer.works
2 Posts
ACCEPTED ANSWER

Pinned topic Need Help - Sending Email alert using Websphere Business Monitor 8.0.1

‏2013-06-28T03:31:13Z |

Hi,

Product Used - IBM Business Monitor 8.0.1

I am trying to use Monitor Action Services to send EmailAlerts.

I am successfully able to send email alerts to unsecured server like lotus notes. This server does not require any authentication. But when I try to connect to secured SMTP server (like hMailServer), Monitor Server gives error saying authentication failed.

[6/28/13 9:34:00:139 IST] 00000093 EmailHelper   E com.ibm.wbimonitor.actionmgr.handling.EmailHelper sendEmail(String, String, String, ArrayList) CWMAA2006E: An unexpected exception occurred. Exception stack com.ibm.wbimonitor.actionmgr.exception.SMTPException: javax.mail.AuthenticationFailedException: failed to connect
    at com.ibm.wbimonitor.actionmgr.handling.EmailSender.send(EmailSender.java:190)
    at com.ibm.wbimonitor.actionmgr.handling.EmailHelper.sendEmail(EmailHelper.java:97)
    at com.ibm.wbimonitor.actionmgr.handling.EmailActionHandler.sendNotification(EmailActionHandler.java:345)
    at co
Caused by: javax.mail.AuthenticationFailedException: failed to connect
    at javax.mail.Service.connect(Service.java:322)
    at com.ibm.wbimonitor.actionmgr.handling.EmailSender.send(EmailSender.java:186)
    ... 20 more
 

Dashboard alerts goes fine without any problem.

I can't see any place on configuration tab on Monitor Console to specify authentication details (id/password) for SMTP Server.

Attaching the snapshot of configuration tab from my console.

Please help if someone has tried connecting monitor with secured smtp server.

Regards

Attachments

Updated on 2013-06-28T04:09:43Z at 2013-06-28T04:09:43Z by Developer.works
  • GVVS_Brian_Venn
    GVVS_Brian_Venn
    2 Posts
    ACCEPTED ANSWER

    Re: Need Help - Sending Email alert using Websphere Business Monitor 8.0.1

    ‏2013-06-30T11:45:28Z  in response to Developer.works

    Hi.

    I think I hit this during some SVT testing a while back.  Can't recall the fix off the top of my head, but I have 801 monitor setup that I can use to reproduce.  I'll let you know once I recall the fix.

    I'm at vennb@uk.ibm.com if you'd like to drop me a note.

  • ammarhassan
    ammarhassan
    1 Post
    ACCEPTED ANSWER

    Re: Need Help - Sending Email alert using Websphere Business Monitor 8.0.1

    ‏2014-12-16T14:56:48Z  in response to Developer.works

    Hi, 

        Did you manage to resolve this? I am also having the same issue.