Topic
5 replies Latest Post - ‏2014-01-31T12:20:47Z by DXB
DXB
DXB
4 Posts
ACCEPTED ANSWER

Pinned topic How to enable export and import CSV files in LogicNet Plus XE 7.2.

‏2014-01-29T13:46:23Z |

How do I enable the option to import and export CSV files in LogicNet Plus XE 7.2.? I have the latest upgrade patch applied (WS-ILNP-LNP722515_Setup.exe) to my install.

 

Updated on 2014-01-29T13:47:22Z at 2014-01-29T13:47:22Z by DXB
  • rkersh
    rkersh
    47 Posts
    ACCEPTED ANSWER

    Re: How to enable export and import CSV files in LogicNet Plus XE 7.2.

    ‏2014-01-29T17:19:29Z  in response to DXB

    LNP XE 7.2 does not support import/export of CSV files from the GUI.  However, with the latest fix pack (version 7.2.25.15), you can do this using the integration package.  See the LogicNetPlusIntegrationDocumentation.chm in the installation directory for documentation on this.

  • MichelLeofIBM
    MichelLeofIBM
    9 Posts
    ACCEPTED ANSWER

    Re: How to enable export and import CSV files in LogicNet Plus XE 7.2.

    ‏2014-01-30T13:10:37Z  in response to DXB

    It's also possible to write a macro in Excel to transform csv into Excel files and to continue with usual Excel import facilities in LogicNetPlus.

  • DXB
    DXB
    4 Posts
    ACCEPTED ANSWER

    Re: How to enable export and import CSV files in LogicNet Plus XE 7.2.

    ‏2014-01-30T22:27:42Z  in response to DXB

    We want to automate the process of importing and solving the model, so CSV via the LogicNet Plus Integration Package best fits our needs.

    When I try to import a 2 line PlantDetails.CSV file, with one line being the header and the second line being the Plant Code and Name as below:

    'ID,Name
    123,Hello World

    "Operation Failed: Column missing in the Source Table: ID"

    I am getting this for all files, hence it seems to be something missing in the formatting of the CSV file. What is missing?

    The same file saved as EXCEL imports without any errors.

    • rkersh
      rkersh
      47 Posts
      ACCEPTED ANSWER

      Re: How to enable export and import CSV files in LogicNet Plus XE 7.2.

      ‏2014-01-30T23:01:38Z  in response to DXB

      I was able to reproduce your issue with the CLI.  It looks like you have an extra single quote (') in front of "ID".  Take this out and it should import fine (it did for me).  The easiest way to make sure your CSV is well formed is to import some data into LNP using Excel, for example, and then export as CSV (you can even export an empty table).  Then use the exported CSV as a template.

      Just a reminder, if you're satisfied with these responses, please mark this question as answered.


      EDIT: I forgot to mention that the single quote is required when using Excel (not CSV).  This helps Excel figure out the "type" of data in a particular column (in this case alphanumeric).

       

      Updated on 2014-01-30T23:05:28Z at 2014-01-30T23:05:28Z by rkersh
      • DXB
        DXB
        4 Posts
        ACCEPTED ANSWER

        Re: How to enable export and import CSV files in LogicNet Plus XE 7.2.

        ‏2014-01-31T12:20:47Z  in response to rkersh

        I exported all the files in CSV format from a scenario and tried importing all of them back, but I get the same message as before - "Operation Failed: Column missing in the Source Table: ID". Not sure what is wrong as the csv files were generated by LNP in the first place.

        Edit: Found the solution. One has to define it to import each csv file individually and cannot point to a folder containing all the csv files.

        Updated on 2014-01-31T20:42:43Z at 2014-01-31T20:42:43Z by DXB