Topic
  • 1 reply
  • Latest Post - ‏2013-06-20T17:19:03Z by AlexMulholland
BFR3_Peter_Thorson
BFR3_Peter_Thorson
5 Posts

Pinned topic Application X requires feature 'ejblite', which is not supported

‏2013-06-20T16:52:40Z |

When I try to add an EAR with EJB to my Liberty server I get this error:

"Application MYEAR (MY) requires feature 'ejblite', which is not supported by Liberty Profile v8550".

I first saw this in the Next Beta, and created RFE for it. Apparently the feature name changed from ejblite to ejbLite.

I am still getting this error after upgrading to the Liberty 8.5.5.

Is this an issue with using RAD 8.5 with the 8.5.5 server or a bug within Liberty?

  • AlexMulholland
    AlexMulholland
    32 Posts

    Re: Application X requires feature 'ejblite', which is not supported

    ‏2013-06-20T17:19:03Z  

    Hi Peter,

    The 8.5.5 GA runtime is not case-sensitive to feature names, but the tools will warn/correct them.  The correct entry is:

     

    <feature>ejbLite-3.1</feature>

     

    While RAD 8.5 can be used with WAS/liberty 8.5.5, it doesn't support the new programming models so you are correct about that limitation.  To use the new programming models in the 8.5.5 runtime you will need to use RAD 9.0 (or WDT 8.5.5) which you can download from https://www.ibmdw.net/wasdev/downloads/

     

    Regards, Alex.