Topic
  • 6 replies
  • Latest Post - ‏2013-07-27T05:28:36Z by KaranBal
PoulomiGupta
PoulomiGupta
114 Posts

Pinned topic Items are stuck in Automated Workflow Step

‏2013-07-08T03:20:40Z |

Hi,

Items are stuck in Automated Workflow Step.Though there are no complex logics within IN and OUT function.Every thing is fine.but still items are not moving out of these steps.Anyone has any idea what could be the root cause?

 

Thanks

Poulomi.

  • PoulomiGupta
    PoulomiGupta
    114 Posts
    ACCEPTED ANSWER

    Re: Items are stuck in Automated Workflow Step

    ‏2013-07-16T09:41:38Z  
    • KaranBal
    • ‏2013-07-12T16:02:16Z

    That is a pretty strong indication that the workflowengine is not running. You can run the $TOP/bin/go/rmi_status.sh and check whether it returns the workflowengine service or not. Another way to check this is to run "$TOP/bin/go/svc_control.sh --action=status --svc_name=workflowengine".

    If it is down (proof being the above scripts not returning the engine as running), then you can run the following command to start it: "$TOP/bin/go/svc_control.sh --action=start --svc_name=workflowengine". An alternative is to just bounce the server using $TOP/bin/go/start_local.sh.

    Hi Karan.

    What i found that lots of items in that step are corrupted.That is why items are not moving out.

    ForEachEntrySetElement  within IN function of workflow step throwing exception.

     

    Regards,

    Poulomi.

  • KaranBal
    KaranBal
    108 Posts

    Re: Items are stuck in Automated Workflow Step

    ‏2013-07-08T16:22:23Z  

    A couple of things to keep in mind:
    1. Which automated step is it, an actual custom automated step or a generic one used by the system like fixit?

    2. Is it happening at one step or one item or is there a pattern?

    If multiple items are not moving, then the cause may simply be that the workflowengine service is down. Items are moved around using the workflowengine process and not the appserver and so they'll be stuck if the workflowengine is down. You can check using $TOP/bin/go/rmi_status.sh script.

    If it is happening for one item/step and the rest are working fine; then there probably was an error in the workflow and that sent the item to a step like fixit.

  • PoulomiGupta
    PoulomiGupta
    114 Posts

    Re: Items are stuck in Automated Workflow Step

    ‏2013-07-12T07:31:25Z  
    • KaranBal
    • ‏2013-07-08T16:22:23Z

    A couple of things to keep in mind:
    1. Which automated step is it, an actual custom automated step or a generic one used by the system like fixit?

    2. Is it happening at one step or one item or is there a pattern?

    If multiple items are not moving, then the cause may simply be that the workflowengine service is down. Items are moved around using the workflowengine process and not the appserver and so they'll be stuck if the workflowengine is down. You can check using $TOP/bin/go/rmi_status.sh script.

    If it is happening for one item/step and the rest are working fine; then there probably was an error in the workflow and that sent the item to a step like fixit.

    Hi Karan,

    Sorry for the late reply.

    It is a custom automated step and lots of items are stuck there.It is happening for several steps.System as well as custom automated steps.

    what information i need to observe against below command?

     

    $TOP/bin/go/rmi_status.sh

     

    Thanks

    Poulomi.

  • KaranBal
    KaranBal
    108 Posts

    Re: Items are stuck in Automated Workflow Step

    ‏2013-07-12T16:02:16Z  

    Hi Karan,

    Sorry for the late reply.

    It is a custom automated step and lots of items are stuck there.It is happening for several steps.System as well as custom automated steps.

    what information i need to observe against below command?

     

    $TOP/bin/go/rmi_status.sh

     

    Thanks

    Poulomi.

    That is a pretty strong indication that the workflowengine is not running. You can run the $TOP/bin/go/rmi_status.sh and check whether it returns the workflowengine service or not. Another way to check this is to run "$TOP/bin/go/svc_control.sh --action=status --svc_name=workflowengine".

    If it is down (proof being the above scripts not returning the engine as running), then you can run the following command to start it: "$TOP/bin/go/svc_control.sh --action=start --svc_name=workflowengine". An alternative is to just bounce the server using $TOP/bin/go/start_local.sh.

  • PoulomiGupta
    PoulomiGupta
    114 Posts

    Re: Items are stuck in Automated Workflow Step

    ‏2013-07-16T09:41:38Z  
    • KaranBal
    • ‏2013-07-12T16:02:16Z

    That is a pretty strong indication that the workflowengine is not running. You can run the $TOP/bin/go/rmi_status.sh and check whether it returns the workflowengine service or not. Another way to check this is to run "$TOP/bin/go/svc_control.sh --action=status --svc_name=workflowengine".

    If it is down (proof being the above scripts not returning the engine as running), then you can run the following command to start it: "$TOP/bin/go/svc_control.sh --action=start --svc_name=workflowengine". An alternative is to just bounce the server using $TOP/bin/go/start_local.sh.

    Hi Karan.

    What i found that lots of items in that step are corrupted.That is why items are not moving out.

    ForEachEntrySetElement  within IN function of workflow step throwing exception.

     

    Regards,

    Poulomi.

  • Ronskie
    Ronskie
    1 Post

    Re: Items are stuck in Automated Workflow Step

    ‏2013-07-25T23:49:12Z  

    Hi Karan.

    What i found that lots of items in that step are corrupted.That is why items are not moving out.

    ForEachEntrySetElement  within IN function of workflow step throwing exception.

     

    Regards,

    Poulomi.

    Hi,

    I do experience the same problem.  Currently, there a lot of items stuck in Send Accept, Send view, Require Enrichment and some just stayed in Success step. How did you identify the corrupted items?  Can you provide the script you ran?  I think there are items that are choking the adapter.  Is there a way to identify those choked items?

    Any help would be highly appreciated.  THanks a lot.

    Rona

  • KaranBal
    KaranBal
    108 Posts

    Re: Items are stuck in Automated Workflow Step

    ‏2013-07-27T05:28:36Z  
    • Ronskie
    • ‏2013-07-25T23:49:12Z

    Hi,

    I do experience the same problem.  Currently, there a lot of items stuck in Send Accept, Send view, Require Enrichment and some just stayed in Success step. How did you identify the corrupted items?  Can you provide the script you ran?  I think there are items that are choking the adapter.  Is there a way to identify those choked items?

    Any help would be highly appreciated.  THanks a lot.

    Rona

    Hi Ronskie,

    Poulomi may have the exact answer for you but in general corruption in newer versions of the product like 9.x and 10.x is quite rare and so I would be surprised if its that. Items getting stuck usually means the workflowengine is down or that there are errors in the IN/OUT script or general errors. I assume you have checked the workflowengine status and so my suggestion would be to perform the following checks:

    Remove the IN and OUT scripts from the workflow step and check whether the items move through the workflow step or still get stuck.
    If they do move through, then we have narrowed down the issue to the scripts. Restore just the IN script and then just  the OUT script to further narrow down the issue. We can then review the corresponding script and the error we get in the workflowengine/exception.log.
    If they don't, then check the logs. If you see an error in workflowengine/exception.log, then it would suggest some dynamic is not working correctly and the error stack would dictate how to proceed.

    There is not a one size fits all strategy and so we really need to know the error before recommending anything.

    - Karan