Topic
  • 13 replies
  • Latest Post - ‏2014-04-25T12:03:12Z by PaulLiskay
charekc
charekc
10 Posts

Pinned topic Rational Performance Tester 8.5

‏2013-06-20T14:34:43Z |

Hi

can someone from RPT dev/support describe for the benefit of users in this forum:

1) Can one upgrade to RPT 8.5 from RPT 8.3.x (My IBM installation manager 1.6 pointing to service repositories mentions no updates/fixes found). 

2) Why the jump from 8.3 to 8.5 as I see no 8.4? 

 

Thanks

  • Rajeshavanthi
    Rajeshavanthi
    112 Posts

    Re: Rational Performance Tester 8.5

    ‏2013-06-24T04:50:23Z  

    Hi

    Yes, you can upgrade to RPT v8.5 from any previous versions of RPT.

    However with RPT v8.5 there is a change in the IM version ( v1.6.3.1 is shipped) as compared to earlier versions. This would automatically gets installed if you proceed with the v8.5 installation by clicking on the launchpad.exe file.

    You might need to un-install previous versions of RPT to get v8.5 installed successfully.

    I might not be able to comment on your second question :)

     

    Thanks and Regards

    Rajesh Avathi

  • THKK_Naresh_Shetty
    THKK_Naresh_Shetty
    5 Posts

    Re: Rational Performance Tester 8.5

    ‏2013-06-24T07:39:33Z  

    Hi

    Yes, you can upgrade to RPT v8.5 from any previous versions of RPT.

    However with RPT v8.5 there is a change in the IM version ( v1.6.3.1 is shipped) as compared to earlier versions. This would automatically gets installed if you proceed with the v8.5 installation by clicking on the launchpad.exe file.

    You might need to un-install previous versions of RPT to get v8.5 installed successfully.

    I might not be able to comment on your second question :)

     

    Thanks and Regards

    Rajesh Avathi

    adding a little information,Chen u have to uninstall RPT 8.3, install RPT 8.5 and import assets into RPT 8.5 workspace.

  • performance tester
    performance tester
    2 Posts

    Re: Rational Performance Tester 8.5

    ‏2013-07-25T08:33:33Z  

    adding a little information,Chen u have to uninstall RPT 8.3, install RPT 8.5 and import assets into RPT 8.5 workspace.

    It seems RPT 8.5 missing some important xml file data which supports custom code. We are facing lot of issues as ITestExecutionServices itself not detecting by eclipse. Please help.

  • KMooney
    KMooney
    283 Posts

    Re: Rational Performance Tester 8.5

    ‏2013-07-25T13:42:48Z  

    It seems RPT 8.5 missing some important xml file data which supports custom code. We are facing lot of issues as ITestExecutionServices itself not detecting by eclipse. Please help.

    That is a rather fundamental missing piece.  I would suspect an installation problem.  Ideas:

    -- Uninstall & reinstall

    -- Install on another box with no other Rational products

    -- Choose all default values during installation

    If you get it working on another system then it may be possible to compare to discover the source of the problem.

     

  • PaulLiskay
    PaulLiskay
    644 Posts

    Re: Rational Performance Tester 8.5

    ‏2013-08-21T19:47:05Z  

    there's no upgrade from 8.3 to 8.5,it's an uninstall of 8.3 and installation of 8.5

    There's no 8.4 version of RPT because RPT is part of the packaging of Rational Test Workbench which includes Rational Performance Tester, Rational Functional Tester, and Rational Integration Tester.  The last release of all three of these products have been updated to 8.5 level and can use a common floating license key

     

  • ErasmusTapera
    ErasmusTapera
    1 Post

    Re: Rational Performance Tester 8.5

    ‏2013-08-27T15:25:22Z  

    I have upgraded my workbench to 8.5, however I notice that my tests have not been upgraded, even when I selected the option to do so.  Now none of my tests run and give me compile errors.  How can I kick off the task again to convert all of my script from 8.3 to 8.5?

    Updated on 2013-08-27T15:26:02Z at 2013-08-27T15:26:02Z by ErasmusTapera
  • petersda
    petersda
    376 Posts

    Re: Rational Performance Tester 8.5

    ‏2013-08-27T17:00:38Z  

    I have upgraded my workbench to 8.5, however I notice that my tests have not been upgraded, even when I selected the option to do so.  Now none of my tests run and give me compile errors.  How can I kick off the task again to convert all of my script from 8.3 to 8.5?

    If you try opening one individual test are you given a prompt saying test is version 8.3 but we are now in 8.5 (and some other words).  Or does it open cleanly?

     

    You say you have compile errors, can you list a sample of  what  those errors are?

     

  • JMalone
    JMalone
    10 Posts

    Re: Rational Performance Tester 8.5

    ‏2013-08-30T10:40:46Z  

    I have upgraded my workbench to 8.5, however I notice that my tests have not been upgraded, even when I selected the option to do so.  Now none of my tests run and give me compile errors.  How can I kick off the task again to convert all of my script from 8.3 to 8.5?

    if in RPT8.3 you made a copy of your originally recorded script using right hand click and copy/paste and included in your schedule,  then in RPT8.5 you will see a null pointer exception when trying to execute the schedule. 

    The work around is to open the originally recorded script in RPT8.5 and use save as via file menu. 

    right hand click copy/paste of scripts seems to be broken in RPT8.5.0 (I have reported to Rational)

    Updated on 2013-08-30T10:41:36Z at 2013-08-30T10:41:36Z by JMalone
  • nansinha
    nansinha
    1 Post

    Re: Rational Performance Tester 8.5

    ‏2014-03-27T11:10:20Z  

    HI Team,

    I want to download the RPT for the OS window 7 with 64 bit .

    Can any body let me know from where I can and which version will support the win7 .

  • PaulLiskay
    PaulLiskay
    644 Posts

    Re: Rational Performance Tester 8.5

    ‏2014-04-04T12:22:46Z  
    • nansinha
    • ‏2014-03-27T11:10:20Z

    HI Team,

    I want to download the RPT for the OS window 7 with 64 bit .

    Can any body let me know from where I can and which version will support the win7 .

    The download for RPT is packaged as multiplatform, at install time it'll install the version appropriate for your OS, eg. Windows 7.  On 64 bit OS's the architecture option which can be either 32 or 64 bit will default to 64 bit on 64 bit machines.  If using Citrix, Siebel, or SAP  you'll want the 32 bit versions at install time

    The trial version of RPT can be downloaded from http://www.ibm.com/developerworks/downloads/r/rpt/

     

  • jsanka
    jsanka
    2 Posts

    Re: Rational Performance Tester 8.5

    ‏2014-04-25T01:28:45Z  

    The download for RPT is packaged as multiplatform, at install time it'll install the version appropriate for your OS, eg. Windows 7.  On 64 bit OS's the architecture option which can be either 32 or 64 bit will default to 64 bit on 64 bit machines.  If using Citrix, Siebel, or SAP  you'll want the 32 bit versions at install time

    The trial version of RPT can be downloaded from http://www.ibm.com/developerworks/downloads/r/rpt/

     

    I am not able to install RPT8.5.1. I am receiving this error message.

    Wrong disk set: expected com.ibm.rational.performance.tester_8.5.1000.RPTO851-I20131106_1239 but found com.ibm.rational.license.key.administrator_8.1.1.20100805_1559.

  • Rajeshavanthi
    Rajeshavanthi
    112 Posts

    Re: Rational Performance Tester 8.5

    ‏2014-04-25T06:18:57Z  
    • jsanka
    • ‏2014-04-25T01:28:45Z

    I am not able to install RPT8.5.1. I am receiving this error message.

    Wrong disk set: expected com.ibm.rational.performance.tester_8.5.1000.RPTO851-I20131106_1239 but found com.ibm.rational.license.key.administrator_8.1.1.20100805_1559.

    Probably at the time when you see the prompt asking for "Disk1" you are pointing to LKAD's disk1 directory..

    From RPTv8.5.1 point of view, can you check if you have 3 folders namely :

             "RPT_8.5_Part_1" ;  "RPT_8.5_Setup" and  "RPTAgentController85"

    The "disk1" should be part of the "RPT_8.5_Part_1" folder.....

     

  • PaulLiskay
    PaulLiskay
    644 Posts

    Re: Rational Performance Tester 8.5

    ‏2014-04-25T12:03:12Z  

    Probably at the time when you see the prompt asking for "Disk1" you are pointing to LKAD's disk1 directory..

    From RPTv8.5.1 point of view, can you check if you have 3 folders namely :

             "RPT_8.5_Part_1" ;  "RPT_8.5_Setup" and  "RPTAgentController85"

    The "disk1" should be part of the "RPT_8.5_Part_1" folder.....

     

    to add , here's a technote for installing 8.5 and mentions those packages as well recommendation to install the LKAD first if on a 64  bit machine. Same steps would apply to 8.5.1

     

    http://www-01.ibm.com/support/docview.wss?uid=swg21654409

    Updated on 2014-04-25T12:04:37Z at 2014-04-25T12:04:37Z by PaulLiskay