Topic
  • 7 replies
  • Latest Post - ‏2013-07-12T20:36:37Z by KathyMR
Almonds
Almonds
12 Posts

Pinned topic Drop Down List not functioning on Web Query reports (V2R1) after OS upgrade from V6R1 to V7R1

‏2013-07-09T19:33:08Z |

We recently updated our IBM i OS from V6R1 to V7R1.  On V6R1 we were already running V2R1 of DB2 Web Query.  Our current PTF group for web query is SF99647.  After the OS update, we have a number of users on different reports where when they go to run a report that does prompting for parameters, the reports with a drop down list on a parameter no longer have any data listed in the drop down list.

To eliminate this being an authority issue with the IBM i authority, I tried to give the user profile *ALLOBJ authority.  Still no data appeared in the drop down list.  Next I added the user to the Web Query Administrator Group and the drop down list then had the desired data.  I removed that *ALLOBJ authority from the profile and retried with the drop down data still appearing.  Removing the user from Web Query Administrator and retrying caused the drop down data to not appear again. 

These reports and their drop down lists all worked prior to our OS upgrade to V7R1 for users that did not belong to the Web Query Administrator Group.  Is this a known issue with a solution available?

  • ktrisko
    ktrisko
    58 Posts

    Re: Drop Down List not functioning on Web Query reports (V2R1) after OS upgrade from V6R1 to V7R1

    ‏2013-07-09T19:46:39Z  

    We have seen a few cases that sounds like yours ... Try what I like to call WebQuery 2.1.0 Group PTF level "4.2" (SI49880 and SI49881)

    Kevin

  • GeneCobb
    GeneCobb
    371 Posts

    Re: Drop Down List not functioning on Web Query reports (V2R1) after OS upgrade from V6R1 to V7R1

    ‏2013-07-09T21:02:25Z  
    • ktrisko
    • ‏2013-07-09T19:46:39Z

    We have seen a few cases that sounds like yours ... Try what I like to call WebQuery 2.1.0 Group PTF level "4.2" (SI49880 and SI49881)

    Kevin

    Mark and Kevin - I was able to repro on my V7R1 system. Loading and applying the 2 PTFs Kevin suggested did not fix the problem. However, I then loaded and applied ALL of the individual PTFs documented in the following 2.1 APAR doc:
    http://www-912.ibm.com/n_dir/nas4apar.nsf/c79815e083182fec862564c00079d117/d686487797ec0c8586257a0a003ca96d?OpenDocument

    This fixed the problem. So make sure you get all of those applied.

  • Almonds
    Almonds
    12 Posts

    Re: Drop Down List not functioning on Web Query reports (V2R1) after OS upgrade from V6R1 to V7R1

    ‏2013-07-10T15:07:54Z  
    • GeneCobb
    • ‏2013-07-09T21:02:25Z

    Mark and Kevin - I was able to repro on my V7R1 system. Loading and applying the 2 PTFs Kevin suggested did not fix the problem. However, I then loaded and applied ALL of the individual PTFs documented in the following 2.1 APAR doc:
    http://www-912.ibm.com/n_dir/nas4apar.nsf/c79815e083182fec862564c00079d117/d686487797ec0c8586257a0a003ca96d?OpenDocument

    This fixed the problem. So make sure you get all of those applied.

    Gene/Kevin - SI49880 & SI49881 did not initially fix the problem as you stated it would not.  After I loaded & applied PTF's listed in APAR my drop down lists were back.  Thanks much for the help!   -Al

  • GeneCobb
    GeneCobb
    371 Posts

    Re: Drop Down List not functioning on Web Query reports (V2R1) after OS upgrade from V6R1 to V7R1

    ‏2013-07-10T15:17:06Z  
    • Almonds
    • ‏2013-07-10T15:07:54Z

    Gene/Kevin - SI49880 & SI49881 did not initially fix the problem as you stated it would not.  After I loaded & applied PTF's listed in APAR my drop down lists were back.  Thanks much for the help!   -Al

    Thanks for posting your results Al (not Mark - sorry, not sure where that came from :-)

  • KathyMR
    KathyMR
    82 Posts

    Re: Drop Down List not functioning on Web Query reports (V2R1) after OS upgrade from V6R1 to V7R1

    ‏2013-07-12T20:03:22Z  

    I work with Al and I am now seeing a new issue in Developer Studio since he applied these fixes.  I want to join synonyms, and in the past when 'inserting reference to existing synonym', I could select from the same folder of synonyms I was in.  But now the only choice I have is the baseapps folder.  There is a dropdown for 'Look in' and the only choice besides baseapp is 'foccache(Temporary)'.  What is that?  There is nothing in that folder.  What happened to the main folder?  Since the baseapps folder is seen by everyone, only a small listing of synonyms is located there.  Is this related to the updates made?  If not, what is causing this and what is the fix?

    Kathy   

  • GeneCobb
    GeneCobb
    371 Posts

    Re: Drop Down List not functioning on Web Query reports (V2R1) after OS upgrade from V6R1 to V7R1

    ‏2013-07-12T20:14:00Z  
    • KathyMR
    • ‏2013-07-12T20:03:22Z

    I work with Al and I am now seeing a new issue in Developer Studio since he applied these fixes.  I want to join synonyms, and in the past when 'inserting reference to existing synonym', I could select from the same folder of synonyms I was in.  But now the only choice I have is the baseapps folder.  There is a dropdown for 'Look in' and the only choice besides baseapp is 'foccache(Temporary)'.  What is that?  There is nothing in that folder.  What happened to the main folder?  Since the baseapps folder is seen by everyone, only a small listing of synonyms is located there.  Is this related to the updates made?  If not, what is causing this and what is the fix?

    Kathy   

    Hi Kathy - This is a known issue that we hope will be fixed in our upcoming group PTF. In the meantime, there is a "manual workaround:"

    In the Name field in that dialog window, type the desired application folder followed by a  slash followed by the synonym you want to join to. Example screenshot attached.

  • KathyMR
    KathyMR
    82 Posts

    Re: Drop Down List not functioning on Web Query reports (V2R1) after OS upgrade from V6R1 to V7R1

    ‏2013-07-12T20:36:37Z  
    • GeneCobb
    • ‏2013-07-12T20:14:00Z

    Hi Kathy - This is a known issue that we hope will be fixed in our upcoming group PTF. In the meantime, there is a "manual workaround:"

    In the Name field in that dialog window, type the desired application folder followed by a  slash followed by the synonym you want to join to. Example screenshot attached.

    Yes that works, I didn't realize that was there.  Thanks for the info.