Topic
7 replies Latest Post - ‏2014-04-16T04:49:52Z by DigitalMeister2010
DigitalMeister2010
DigitalMeister2010
9 Posts
ACCEPTED ANSWER

Pinned topic TM1Web 10.2 export to slice format errors

‏2013-09-16T04:20:34Z |

I just downloaded TM1 10.2... it seems good.  I haven't been able try MTQ yet, although it does seem to be kicking in.  However, when I use TM1 Web and export to a sliced sheet, I'm noticing that the formatting that worked fine in TM1  10.1.1 is now a little messed up for Active Forms.  Is anyone else encountering this?  If so, is there a fix or method of correcting the issue?

  • HeathWebster
    HeathWebster
    1 Post
    ACCEPTED ANSWER

    Re: TM1Web 10.2 export to slice format errors

    ‏2013-09-30T20:01:49Z  in response to DigitalMeister2010

    We are experiencing the same issue with any of the Exports from TM1 Web.  Examples:

    1. Multiple dims on Row ends up exporting it as without suppress zeros (considers all the combinations) but the data against it is what we see on screen with suppress zeros on rows selected.  So when you look at the export, the first element of the first dimension is repeated, but the data that was displayed in the view is output next to these duplicates.
    2. Multiple dims on Columns also throws up the issue mentioned above.
    3. If you have one dim on row, one on column and multiple in context, it may or may not export (reasons unknown), you will only see a status of "Currently Publishing"... and the "Cancel Export" button.
  • Petter_Huseby
    Petter_Huseby
    3 Posts
    ACCEPTED ANSWER

    Re: TM1Web 10.2 export to slice format errors

    ‏2013-10-24T12:15:19Z  in response to DigitalMeister2010

    Hi

    Hi

     

    We also have a customer with this error.

    Got the same error, after applying interim fix 1 also.

     

    Maybe we shall create a case on this?

     

    Br

    Petter Huseby

    RAV Norway

  • Petter_Huseby
    Petter_Huseby
    3 Posts
    ACCEPTED ANSWER

    Re: TM1Web 10.2 export to slice format errors

    ‏2013-10-24T12:17:37Z  in response to DigitalMeister2010

    Here is the error in the log file

     

    Exception in thread "Thread-37" java.lang.RuntimeException: java.lang.ArrayIndexOutOfBoundsException: Array index out of range: 20
     at com.ibm.cognos.tm1.web.exports.CubeViewExportHelper.export(CubeViewExportHelper.java:177)
     at com.ibm.cognos.tm1.web.exports.CubeViewExportHelper.run(CubeViewExportHelper.java:91)
    Caused by: java.lang.ArrayIndexOutOfBoundsException: Array index out of range: 20
     at com.ibm.cognos.tm1.exports.cubeviewer.CubeViewExporter.makeAnExportSheet(CubeViewExporter.java:356)
     at com.ibm.cognos.tm1.exports.cubeviewer.CubeViewExporter.doSingularExport(CubeViewExporter.java:98)
     at com.ibm.cognos.tm1.web.exports.CubeViewExportHelper.export(CubeViewExportHelper.java:167)