Topic
  • 2 replies
  • Latest Post - ‏2014-06-30T12:37:37Z by AdS_CT1H
AdS_CT1H
AdS_CT1H
5 Posts

Pinned topic How setting up AD in federated repository?

‏2014-06-27T20:16:07Z |

Hello.

I set up an ad server in federated repository, but it did not work well. When I try to authenticate in any application (that use ad to login), the app shows Invalid Username or Password. I verified that user administration does not display User Id, only the First Name. Is it possible adjust the federated repository configuration to work properly UserID??

 

Thanks in advance! :)

  • AdS_CT1H
    AdS_CT1H
    5 Posts
    ACCEPTED ANSWER

    Re: How setting up AD in federated repository?

    ‏2014-06-30T12:37:37Z  
    • gas
    • ‏2014-06-29T20:15:59Z

    Hi,

    Check two potential settings:

    • in wimconfig.xml - check how uid parameter is mapped to the AD attribute
    • check if you bind user has wright to read that uid attribute (you could test that using some kind of ldap browser or ldapsearch command)

    Regards
    Gas

    Thank you so much for your answer.

    I change Directory Type Microsoft Windows Active Directory to Microsoft Active Directory Application Mode, now it works!

  • gas
    gas
    36 Posts

    Re: How setting up AD in federated repository?

    ‏2014-06-29T20:15:59Z  

    Hi,

    Check two potential settings:

    • in wimconfig.xml - check how uid parameter is mapped to the AD attribute
    • check if you bind user has wright to read that uid attribute (you could test that using some kind of ldap browser or ldapsearch command)

    Regards
    Gas

  • AdS_CT1H
    AdS_CT1H
    5 Posts

    Re: How setting up AD in federated repository?

    ‏2014-06-30T12:37:37Z  
    • gas
    • ‏2014-06-29T20:15:59Z

    Hi,

    Check two potential settings:

    • in wimconfig.xml - check how uid parameter is mapped to the AD attribute
    • check if you bind user has wright to read that uid attribute (you could test that using some kind of ldap browser or ldapsearch command)

    Regards
    Gas

    Thank you so much for your answer.

    I change Directory Type Microsoft Windows Active Directory to Microsoft Active Directory Application Mode, now it works!