• 2 replies
  • Latest Post - ‏2013-09-09T17:24:36Z by fotang
3 Posts

Pinned topic Enable tcp/ip on Linux

‏2013-08-30T08:13:56Z |

I installed db2 on linux and it seems to work so far. What doesn't work is tcp/ip. I found db2c_db2inst1 50000/tcp in /etc/services and SVCENAME is also db2c_db2inst1 but I when I try telnet localhost 50000 I get 'Connection refused'

Any idea what is wrong here?


  • nivanov1
    53 Posts

    Re: Enable tcp/ip on Linux


    Nothing is wrong -- it's just the firewall seems to be doing its job.

  • fotang
    1 Post

    Re: Enable tcp/ip on Linux


    Have you  configured db2 to use TCP/IP on that port? Run netstat -nat|grep LISTEN and see if port 50000  is listed.  Otherwise you may have to do what I do: run the following command:

    update database manager configuration using svcename db2c_db2inst1