Topic
4 replies Latest Post - ‏2013-11-15T23:00:51Z by weiren
garryd
garryd
2 Posts
ACCEPTED ANSWER

Pinned topic nmon analyser v34a.xls: MERGE error

‏2013-06-06T16:51:00Z |

Greetings...  I am attempting to use the MERGE option with nmon analyser v34a.xls,  but I receive the following error:

"Run-time error '5':  Invalid procedure call or argument

I then click on the "Debug" button, and it points to this line in the code:

Line 933:  "Name Filename As aa0"

I receive the error when trying to process two files, as well only trying to process one file (with the MERGE option set to YES).

The NMON files that I am attempting to process were produced by running the following command:

# topasout -a <topasrec file>

Which, in turn, creates a "csv" file.

The topasrec files were produced by the following command running via the "xmdaily" entry in /etc/inittab:

/usr/bin/topasrec  -L -s 300 -R 1 -r 7 -o /etc/perf/daily/ -ypersistent=1 -O type=bin -ystart_time=20:52:18,May29,2013

Each processed "topasout" file is 6348 lines.  I have done no post-processing on those files (sorts, etc).

The server running topasrec is at AIX 6100-07-06-1241

The version of bos.perf.tools is at: 6.1.7.17

I have attempted to process the NMON files transferred via FTP in both ascii and binary mode, just in case.

I am attempting this on a corporate laptop running Windows XP Pro, Version 2002, SP 3.

The Microsoft Excel versions that I have tried are 2003, 2007, and 2010, all published to my XP laptop via Citrix; and I receive the same error for each Excel version I attempt

I have also attached the copy of the "nmon analyser v34a.xls" file that I am using, as well as copies of the "NMON" files (produced via topasrec command), both the "ftp ascii" files and the "ftp binary" files.

I have reviewed the User Guide, the forums here, as well as some various Google searches; however, I've yet to hit upon this as a known issue.

Not quite sure why the MERGE is producing this error on me..

Any suggestions would be appreciated...

Thanks.

Garry

  • ksteinruecke
    ksteinruecke
    1 Post
    ACCEPTED ANSWER

    Re: nmon analyser v34a.xls: MERGE error

    ‏2013-10-02T06:51:16Z  in response to garryd

    Hi there,

     

    I've got the same problem here. I receive a runtime error, when I try to merge two files. I have absolutely no idea how to fix this by myself.

    Maybe, some has a solution for this.

     

    Thanks!

    Katja

    Updated on 2013-10-02T06:51:28Z at 2013-10-02T06:51:28Z by ksteinruecke
  • nagger
    nagger
    1620 Posts
    ACCEPTED ANSWER

    Re: nmon analyser v34a.xls: MERGE error

    ‏2013-10-10T17:05:53Z  in response to garryd

    Hi,

    The file seem acceptable one at a time but they are formatted in an unusual way because (I think) they are generated from topas binary data and not directly by nmon. For example, the AAA lines are at the bottom instead of the top.

    They are also have odd things like the month in the AAA,date is lower case.

    The Analyser is crashing it generating a file name for the merged date. I tried a few hance editing o the file but could not determine the issue.

    Please gather nmon files and try again.

     

    Sorry but I can't debug the planet, Nigel Griffiths

    • garryd
      garryd
      2 Posts
      ACCEPTED ANSWER

      Re: nmon analyser v34a.xls: MERGE error

      ‏2013-10-14T13:55:22Z  in response to nagger

      Hi, Mr. Griffiths..  I appreciate your response.  And, yes, the files that I am trying to process were generated by "topasrec", and then processed by "topasrec -a" to create files "...that can be viewed with the nmon analyzer."  (From the topasrec man page...).   If the analyzer spreadsheet does not currently support the merge of the "topasrec -a" data, I suppose my request should be for an enhancement to the analyzer spreadsheet...(?).  Since the analyzer spreadsheet is not officially supported  by IBM, I'm not sure I'd get very far if I opened a PMR regarding topasrec output formatting...  Again, I appreciate your response. 

      gd

       

    • weiren
      weiren
      1 Post
      ACCEPTED ANSWER

      Re: nmon analyser v34a.xls: MERGE error

      ‏2013-11-15T23:00:51Z  in response to nagger

      Hi Nigel,

      Though it failed, the files are merged fine. I can open the left over merged file and analyze it as a single nmon file without problem.

      The "Debug" shows it fails at statement "Name FileName As aa0":

      d1 = Format(d1, "yymmdd")
      t1 = Format(t1, "hhmm")
      d2 = Format(d2, "yymmdd")
      t2 = Format(t2, "hhmm")
      aa0 = CurDir & "\" & hostname & "_" & d1 & "_" & t1 & "_to_" & d2 & "_" & t2 & ".nmon"
      Name FileName As aa0

      And in Debug, seems all d1, t1, d2 and t2 do not have proper values. Seems it is having trouble with Fomat() call.

      After I change aa0 to a fixed value, it works fine for me now:

      aa0 = "merged_file"

      Name FileName As aa0

       

      Thanks.

      Weiren

       

      Updated on 2013-11-15T23:07:04Z at 2013-11-15T23:07:04Z by weiren