Topic
9 replies Latest Post - ‏2013-10-14T20:56:17Z by RafaelSene
Chern
Chern
4 Posts
ACCEPTED ANSWER

Pinned topic Font issues when starting up server side Power Linux SDK

‏2013-10-11T16:20:56Z |

HI, 

I encountered this issue when attempting to start up the Server side SDK on a client side (as captured in attached file).  It appears that the fonts are not recognized.

I have also added symbolic -link from /usr/share/fonts to /usr/X11R6/share/fonts but it not work. Could anyone please let me know of any other methods to determine the root cause to this issue? 

Thanks in advance,

Chern

 

Attachments

  • Bill_Buros
    Bill_Buros
    85 Posts
    ACCEPTED ANSWER

    Re: Font issues when starting up server side Power Linux SDK

    ‏2013-10-11T21:27:15Z  in response to Chern

    We are checking with the development team..   

  • RodrigoFraxinoAraujo
    2 Posts
    ACCEPTED ANSWER

    Re: Font issues when starting up server side Power Linux SDK

    ‏2013-10-12T12:25:53Z  in response to Chern

    Hi Chern,

     

    Please try to yum install xorg-x11-font* on the remote host.

    Also, you can try IBM SDK 1.4, which is available at https://www-304.ibm.com/webapp/set2/sas/f/lopdiags/sdklop.html

     

    Kind regards,

    Rodrigo.

  • RafaelSene
    RafaelSene
    6 Posts
    ACCEPTED ANSWER

    Re: Font issues when starting up server side Power Linux SDK

    ‏2013-10-13T18:15:38Z  in response to Chern

    Hi Chern,

     

    I noted you are using Tem Viewer to access the remote server. As we have tested remote access using only VNC  or X11 forwarding I will setup an enviroment using Team Viwer to check if it can be the problem.

  • RafaelSene
    RafaelSene
    6 Posts
    ACCEPTED ANSWER

    Re: Font issues when starting up server side Power Linux SDK

    ‏2013-10-13T18:25:24Z  in response to Chern

    Could you provide a short description about  the steps you followed to install SDK ?

  • RafaelSene
    RafaelSene
    6 Posts
    ACCEPTED ANSWER

    Re: Font issues when starting up server side Power Linux SDK

    ‏2013-10-14T12:36:18Z  in response to Chern

    There are some fonts missing. As Rodrigo pointed, yous should install using yum install xorg-x11-font*

    Installing:
     xorg-x11-font-utils-debuginfo     ppc64   1:7.2-11.el6     rhel-ftp3  118 k
     xorg-x11-fonts-100dpi             noarch  7.2-9.1.el6      rhel-ftp3  3.1 M
     xorg-x11-fonts-75dpi              noarch  7.2-9.1.el6      rhel-ftp3  2.8 M
     xorg-x11-fonts-ISO8859-1-100dpi   noarch  7.2-9.1.el6      rhel-ftp3  1.1 M
     xorg-x11-fonts-ISO8859-1-75dpi    noarch  7.2-9.1.el6      rhel-ftp3  933 k
     xorg-x11-fonts-ISO8859-14-100dpi  noarch  7.2-9.1.el6      rhel-ftp3  1.0 M
     xorg-x11-fonts-ISO8859-14-75dpi   noarch  7.2-9.1.el6      rhel-ftp3  906 k
     xorg-x11-fonts-ISO8859-15-100dpi  noarch  7.2-9.1.el6      rhel-ftp3  1.1 M
     xorg-x11-fonts-ISO8859-15-75dpi   noarch  7.2-9.1.el6      rhel-ftp3  933 k
     xorg-x11-fonts-ISO8859-2-100dpi   noarch  7.2-9.1.el6      rhel-ftp3  1.0 M
     xorg-x11-fonts-ISO8859-2-75dpi    noarch  7.2-9.1.el6      rhel-ftp3  901 k
     xorg-x11-fonts-ISO8859-9-100dpi   noarch  7.2-9.1.el6      rhel-ftp3  1.1 M
     xorg-x11-fonts-ISO8859-9-75dpi    noarch  7.2-9.1.el6      rhel-ftp3  931 k
     xorg-x11-fonts-Type1              noarch  7.2-9.1.el6      rhel-ftp3  519 k
     xorg-x11-fonts-cyrillic           noarch  7.2-9.1.el6      rhel-ftp3  395 k
     xorg-x11-fonts-ethiopic           noarch  7.2-9.1.el6      rhel-ftp3  150 k
    Installing for dependencies:
     ttmkfdir                          ppc64   3.0.9-32.1.el6   rhel-ftp3   44 k

    Transaction Summary
    =============================================================================
    Install      17 Package(s)

    Total download size: 17 M
    Installed size: 18 M
    Is this ok [y/N]: y
    Downloading Packages:
    (1/17): ttmkfdir-3.0.9-32.1.el6.ppc64.rpm             |  44 kB     00:30     
    (2/17): xorg-x11-font-utils-debuginfo-7.2-11.el6.ppc6 | 118 kB     00:30     
    (3/17): xorg-x11-fonts-100dpi-7.2-9.1.el6.noarch.rpm  | 3.1 MB     00:30     
    (4/17): xorg-x11-fonts-75dpi-7.2-9.1.el6.noarch.rpm   | 2.8 MB     00:30     
    (5/17): xorg-x11-fonts-ISO8859-1-100dpi-7.2-9.1.el6.n | 1.1 MB     00:30     
    (6/17): xorg-x11-fonts-ISO8859-1-75dpi-7.2-9.1.el6.no | 933 kB     00:30     
    (7/17): xorg-x11-fonts-ISO8859-14-100dpi-7.2-9.1.el6. | 1.0 MB     00:30     
    (8/17): xorg-x11-fonts-ISO8859-14-75dpi-7.2-9.1.el6.n | 906 kB     00:30     
    (9/17): xorg-x11-fonts-ISO8859-15-100dpi-7.2-9.1.el6. | 1.1 MB     00:31     
    (10/17): xorg-x11-fonts-ISO8859-15-75dpi-7.2-9.1.el6. | 933 kB     00:30     
    (11/17): xorg-x11-fonts-ISO8859-2-100dpi-7.2-9.1.el6. | 1.0 MB     00:30     
    (12/17): xorg-x11-fonts-ISO8859-2-75dpi-7.2-9.1.el6.n | 901 kB     00:30     
    (13/17): xorg-x11-fonts-ISO8859-9-100dpi-7.2-9.1.el6. | 1.1 MB     00:30     
    (14/17): xorg-x11-fonts-ISO8859-9-75dpi-7.2-9.1.el6.n | 931 kB     00:30     
    (15/17): xorg-x11-fonts-Type1-7.2-9.1.el6.noarch.rpm  | 519 kB     00:30     
    (16/17): xorg-x11-fonts-cyrillic-7.2-9.1.el6.noarch.r | 395 kB     00:30     
    (17/17): xorg-x11-fonts-ethiopic-7.2-9.1.el6.noarch.r | 150 kB     00:30

  • Chern
    Chern
    4 Posts
    ACCEPTED ANSWER

    Re: Font issues when starting up server side Power Linux SDK

    ‏2013-10-14T15:27:26Z  in response to Chern

    Hi Rafael, Rodrigo & Bill,

    Thank you so much for responding to my queries - greatly appreciate it!

    I did a  >yum install xorg-x11-font*. And that resolved it. It seems that the xorg-x11-font* is the culprit - doing an uninstall of it and starting up the SDK resulted in the same issue as before.

    However, I noticed another issue:
    The Migration Advisor detects errors that are standard C/C++ constructs like stderr, EOF,  FILE (very C construct) and NULL. Therefore based on my experience, this should not throw an error since they are not platform specific constructs such as  ntohl( ) or htonl( ) for XDR as an example, or threading libraries.   

    As a result, I am unable to execute  FDPR, Oprof, CPI, valgrind as they are dependent on the resolution above.  See attached file for the errors captured.

    BTW, what's the compatibility between AT5.0, AT6.0 and AT7.0, especially pertaining to Oprof?

    Could you please advice on this matter?   

    Thanks,
    Chern.

    Attachments

    • RodrigoFraxinoAraujo
      2 Posts
      ACCEPTED ANSWER

      Re: Font issues when starting up server side Power Linux SDK

      ‏2013-10-14T19:52:02Z  in response to Chern

      Hi Chern,

      This errors are not MA dependent. They are problems originating when you created the project.

      Could you tell us how you did that? If you are importing an existing project, please choose the following option:

      File -> Import -> C Project -> Existing project as Makefile

      and see if the compilation works.

       

      Please note that when using Makefile projects you cant customize the AT options in the project properties (like it is possible to do when creating a CDT project from scratch)

       

      Other people will answer for the compatibility among the AT versions for oprofile

    • tuliom
      tuliom
      2 Posts
      ACCEPTED ANSWER

      Re: Font issues when starting up server side Power Linux SDK

      ‏2013-10-14T19:54:04Z  in response to Chern

      AT 5.0 only provides the "legacy" opcontrol profiler.

      AT 6.0 provides both opcontrol and operf, while AT 7.0 includes ocount,  opcontrol and operf.

  • RafaelSene
    RafaelSene
    6 Posts
    ACCEPTED ANSWER

    Re: Font issues when starting up server side Power Linux SDK

    ‏2013-10-14T20:56:17Z  in response to Chern

    Chern, valuable information about SDK can be found here https://www-304.ibm.com/webapp/set2/sas/f/lopdiags/sdklop.html