• 1 reply
  • Latest Post - ‏2013-05-09T21:16:31Z by Sreeharsha_Naik
1 Post

Pinned topic "db2 drop db" returns the be not found error

‏2013-04-23T16:27:56Z |

I recently uninstall DB2 10.1 and reinstall DB2 10.5 Beta since DB2 10.5 Beta doesn't support upgrade. But I forgot to delete the database that my application (TSM server)I created "TSMDB1" before upgrading to 10.5.

After reinstalling, my application (TSM server)  tried to use the DB but it complained the DB not found. So I tired to create the DB using  sqlecrea api and it returned SQLE_RC_DUPALIAS. I tried to delete the DB using sqledrpd and it returned SQLE_RC_NODB. I tried to drop DB using DB2 droup command, it complained the DB not found.

I tried to manually create server1 instance and set db2instance=server1

I tried to catalog the DB, but it complained the DB doesn't exist.

I guess the DB is deleted but somehow there is some residual that affects sqlecrea to create the DB. Any idea how to clean up the residual?

  • Sreeharsha_Naik
    34 Posts

    Re: "db2 drop db" returns the be not found error



    In case you created the database without specifying the path in the create database command, then the database would be created ( physically ) in C:\DB2\NODE0000\TSMDB1 - You may delete the folder and try to create again if you wish