Topic
3 replies Latest Post - ‏2013-09-02T12:57:28Z by Samuel_Pizarro
pueffl
pueffl
3 Posts
ACCEPTED ANSWER

Pinned topic Unable to create DB2 instance

‏2013-08-09T11:49:25Z |

I installed a DB2 Express-C on a Linux Mint 16 / 64bit environment and got one 'minor' exception: as it seems, it was not possible to create a database instance (Seems to be a bug in the installation routine, maybe because I changed the defaults).

The suggestion I got from the setup program is, that I can install it with db2icrt (which is located in /opt/ibm/db2/V10.5/instance on my computer) - so far so good.

During setup, 3 users where created: db2iusr (instance User), db2fusr (fenced user), db2usr

When i try to execute ./db2icrt -u db2fusr db2iusr as root, I just get an exception with the message to try db2icrt (what I already did). So how do I get over this?

Thanks for any help!

 

 

 

  • Henrik_Loeser
    Henrik_Loeser
    4 Posts
    ACCEPTED ANSWER

    Re: Unable to create DB2 instance

    ‏2013-08-13T12:16:57Z  in response to pueffl

    What is the exact error message? Is it similar like that during the installation? What environment do you have when logging into your db2iusr account?

    Henrik

    • pueffl
      pueffl
      3 Posts
      ACCEPTED ANSWER

      Re: Unable to create DB2 instance

      ‏2013-08-23T07:09:20Z  in response to Henrik_Loeser

      Don't know the exact error message. Seems to be a bug in the installation procedure. At least it works when you leave the default values.

  • Samuel_Pizarro
    Samuel_Pizarro
    18 Posts
    ACCEPTED ANSWER

    Re: Unable to create DB2 instance

    ‏2013-09-02T12:57:28Z  in response to pueffl

    I am facing as well the same situatiion.   db2 10.5 express-c 64bits installed on a Linux64 bits as well.

    I have manually created the users and groups as root on my system, and later tried to create an instance using db2icrt as follow:

    $DB2DIR/instance/db2icrt -p 50001 -u db2fencd ieavsicd

    I also get the same error he described, but the instance is not created, The instance home is still empty !

    Indise the db2icrt.log in /tmp, I found this :

    Setting default global profile registry variables :.......Success
    Initializing instance list :.......Success
    ERROR: An error occurred while creating the instance "ieavsicd". The return
    code is "1". Create the instance manually using the command "db2icrt".

     

     

    ERROR: An error occurred while configuring the instance "ieavsicd".

    Configuring DB2 instances :.......Failure

    But it does not says too much. And looking at /tmp I found it has  created a 2nd log file db2icrt_local.log.3642, and inside of it I could find the reason,  but the error applicable, at least not for the reasons he is trying to:

    ## Entering: find_primgrp ieavsicd
    ## User primary group = db2sysadm
    ## Exiting: find_primgrp
    DBI1135E  The primary group db2sysadm of user ID ieavsicd is
          invalid.

    Explanation:

    The primary group name of the instance user ID:

    1. Cannot be one of "guests", "admins", "users" or "local".
    2. Cannot start with "sql" or "ibm".
    3. Cannot start with a numeral number.
    4. Can contain only lowercase letters (a-z), numbers (0-9), and the
       underscore character ( _ ).

    User response:

    Ask a user with root privilege to change the primary group of the
    instance user ID to a valid group as described in this message's
    Explanation and then try the command again.

     My primary group is db2sysadm  and the name does not fit on ANY reason he is giving for rejecting it !?

    Follow the details of my accounts and groups:
     

    Instance User ID:
    # id ieavsicd
    uid=501(ieavsicd) gid=500(db2sysadm) groups=500(db2sysadm),501(db2dbadm),502(db2secadm)

     

    Fenced User ID:
    # id db2fencd
    uid=504(db2fencd) gid=504(db2fadm1) groups=504(db2fadm1)

     

    What is wrong? 

    Samuel Pizarro