Topic
  • 23 replies
  • Latest Post - ‏2015-06-12T02:49:22Z by Mrs.Llanes
Rafael Rodriguez
Rafael Rodriguez
2 Posts

Pinned topic http Error 28

‏2013-06-04T08:41:06Z |

I have this error in the file c: \ Program Files \ BigFix Enterprise \ BES Server \ BESRelay.log. Someone has occurred, if the gather download right?

 

Tue, 04 Jun 2013 10:33:11 +0200 - RelayNotifier4 (4308) - Error running task RelayNotifier4: HTTP Error 28: Timeout was reached: Operation timed out after 10000 milliseconds with 0 out of 0 bytes received
Tue, 04 Jun 2013 10:33:11 +0200 - RelayNotifier7 (4320) - Error running task RelayNotifier7: HTTP Error 28: Timeout was reached: Operation timed out after 10000 milliseconds with 0 out of 0 bytes received
Tue, 04 Jun 2013 10:33:29 +0200 - RelayNotifier8 (4324) - Error running task RelayNotifier8: HTTP Error 28: Timeout was reached: Operation timed out after 10000 milliseconds with 0 out of 0 bytes received
 

  • TallTomD
    TallTomD
    3 Posts

    Re: http Error 28

    ‏2013-06-19T21:12:57Z  

    I've recently begun seeing a lot of these error 28 timeouts.  Working to improve efficiency of my client / relay communications.

     

    Please let me konw if you find a solution.

     

  • Rafael Rodriguez
    Rafael Rodriguez
    2 Posts

    Re: http Error 28

    ‏2013-06-20T05:47:38Z  
    • TallTomD
    • ‏2013-06-19T21:12:57Z

    I've recently begun seeing a lot of these error 28 timeouts.  Working to improve efficiency of my client / relay communications.

     

    Please let me konw if you find a solution.

     

    when it goes to download some files on a Fixlet usually by _BESGather_Comm_UseUrlMoniker. must be configured for that type of communication system using IEM. but this error BESRelay.log file on the central server, I have not been able to find the solution.

  • dhtorsdc
    dhtorsdc
    3 Posts

    Re: http Error 28

    ‏2013-06-28T16:56:34Z  

    I'm also getting these "http Error 28" timeouts in the console.  It's a new thing with 9.0.649.  I've had almost nothing but trouble with the version 9 upgrade.  I have a ticket in with support, but they've gone silent...

  • ItsAvi
    ItsAvi
    2 Posts

    Re: http Error 28

    ‏2013-07-01T08:38:37Z  

    i'm getting this error too, it's plain annoying, opened a thread and then found this empathy thread ;-)

    https://www.ibm.com/developerworks/community/forums/html/topic?id=95f80265-6d51-4f09-bc42-1387aafaf912&ps=25

  • TallTomD
    TallTomD
    3 Posts

    Re: http Error 28

    ‏2013-07-01T20:31:05Z  

    I'm getting a lot of user complaints about these errors in the Console.  I've got a global deployment with probably 200 operators around the world using RDP to connect my Console Server farm.  More and more of them are complaining about these Error 28 http timeout errors.

    I've also had problems where my Console will shut down, or report an error and give me the option to Ignore or continue.

    This all began with version 9.  I've been running BigFix since version 6, over many years.  These errors began almost immediately when I upgraded to version 9.0.649.0

    Anybody find a solution?

  • bxk
    bxk
    4 Posts

    Re: http Error 28

    ‏2013-07-01T21:06:03Z  
    • TallTomD
    • ‏2013-07-01T20:31:05Z

    I'm getting a lot of user complaints about these errors in the Console.  I've got a global deployment with probably 200 operators around the world using RDP to connect my Console Server farm.  More and more of them are complaining about these Error 28 http timeout errors.

    I've also had problems where my Console will shut down, or report an error and give me the option to Ignore or continue.

    This all began with version 9.  I've been running BigFix since version 6, over many years.  These errors began almost immediately when I upgraded to version 9.0.649.0

    Anybody find a solution?

    We've been seeing this error a fair bit since we upgraded to 8.2. It's also seemed to cause us a lot of console data corruption. So much so that we purge all profiles on the RDS servers at 6am. It disallows CO customization, but generally prevents the user from being unable to open the console. 

    I had hoped that v9 would have given them more time to work out this bugs. :(

  • cglimson
    cglimson
    5 Posts

    Re: http Error 28

    ‏2013-07-31T07:03:53Z  
    • dhtorsdc
    • ‏2013-06-28T16:56:34Z

    I'm also getting these "http Error 28" timeouts in the console.  It's a new thing with 9.0.649.  I've had almost nothing but trouble with the version 9 upgrade.  I have a ticket in with support, but they've gone silent...

    Hi dhtorsdc,

    Is there an update from Support about your ticket on this?  I've been following the thread but not sure if this was resolved.

    Thanks!

    Regards.

  • dhtorsdc
    dhtorsdc
    3 Posts

    Re: http Error 28

    ‏2013-07-31T12:15:54Z  
    • cglimson
    • ‏2013-07-31T07:03:53Z

    Hi dhtorsdc,

    Is there an update from Support about your ticket on this?  I've been following the thread but not sure if this was resolved.

    Thanks!

    Regards.

    No solution, just a workaround - which is to add setting _BESData_Comm_TimeoutSeconds to the console machine and set it at a high number.  Logs will tell you how long certain operations are taking, so that you can adjust the setting.  Mine is currently at 300.  I attribute it in part to just plain old bad code and hope that it will be addressed soon by IBM.  8.2 never had this issue, and little changed in the environment I'm working with when I upgraded to 9.

  • KarenKue
    KarenKue
    5 Posts

    Re: http Error 28

    ‏2013-08-01T07:45:39Z  

    I'm in the process of upgrading to 9.0 ( the task 1435 is currently running), and I'm getting the HTTP Error 28 already.

    For those who upgraded to 9.0 using the available tasks, did you faces any issues along the way?

  • TallTomD
    TallTomD
    3 Posts

    Re: http Error 28

    ‏2013-09-05T14:13:54Z  
    • KarenKue
    • ‏2013-08-01T07:45:39Z

    I'm in the process of upgrading to 9.0 ( the task 1435 is currently running), and I'm getting the HTTP Error 28 already.

    For those who upgraded to 9.0 using the available tasks, did you faces any issues along the way?

    My upgrade took almost 6 hours.  I called support after about 3 hours, and we waited.  We reviewed services, processes, and verified everything was still in progress.  I guess it took a lot of time to upgrade the database.  Suddenly it moved on to the next step, and everything was OK.

     

    However, there are 3 new issues that came with version 9:

    1 - The never ending HTTP Error 28 messages - and the occasional "console error" related to the timeout, which prompts to close or ignore.

    2 - Many of the clients running version 9 can no longer determine their hop count to their relay.  I've got a mixture of 7, 8, and 9 clients reporting to the same relay.  My relays are distributed globally, reporting in to a couple top level relays, which then report to my main server.  The version 7 and version 8 clients have almost 100% success reporting the hop count.  The version 9 clients are maybe 50% successful in reporting the hop count.  This throws off my charts and environment health statistics.

    3 - There is almost constantly a yellow exclamation mark, counting up all the authentication errors during my Console sessions.  These don't seem to have any impact.  The console continues working, but the ever increasing error count doesn't look good to customers that notice such a thing.

     

    I'm also having trouble using the pass-through credentials option.  That doesn't work if you have a multi-domain forest with trust relationships between the AD domains.  It only works for users on the same domain as the main server.

     

    Let me know if you solve the HTTP Error 28.  That is very annoying to the users.

     

    Thanks,

    Tom

  • hosmar
    hosmar
    5 Posts

    Re: http Error 28

    ‏2014-03-17T14:19:35Z  
    • TallTomD
    • ‏2013-09-05T14:13:54Z

    My upgrade took almost 6 hours.  I called support after about 3 hours, and we waited.  We reviewed services, processes, and verified everything was still in progress.  I guess it took a lot of time to upgrade the database.  Suddenly it moved on to the next step, and everything was OK.

     

    However, there are 3 new issues that came with version 9:

    1 - The never ending HTTP Error 28 messages - and the occasional "console error" related to the timeout, which prompts to close or ignore.

    2 - Many of the clients running version 9 can no longer determine their hop count to their relay.  I've got a mixture of 7, 8, and 9 clients reporting to the same relay.  My relays are distributed globally, reporting in to a couple top level relays, which then report to my main server.  The version 7 and version 8 clients have almost 100% success reporting the hop count.  The version 9 clients are maybe 50% successful in reporting the hop count.  This throws off my charts and environment health statistics.

    3 - There is almost constantly a yellow exclamation mark, counting up all the authentication errors during my Console sessions.  These don't seem to have any impact.  The console continues working, but the ever increasing error count doesn't look good to customers that notice such a thing.

     

    I'm also having trouble using the pass-through credentials option.  That doesn't work if you have a multi-domain forest with trust relationships between the AD domains.  It only works for users on the same domain as the main server.

     

    Let me know if you solve the HTTP Error 28.  That is very annoying to the users.

     

    Thanks,

    Tom

    Any updates on this issue, I just ugraded the server from 8.2 to 9.x and when I open the console I gues this HTTP error.

  • jgstew
    jgstew
    56 Posts

    Re: http Error 28

    ‏2014-03-17T14:46:01Z  
    • hosmar
    • ‏2014-03-17T14:19:35Z

    Any updates on this issue, I just ugraded the server from 8.2 to 9.x and when I open the console I gues this HTTP error.

    You need to increase the value of the setting "_BESData_Comm_TimeoutSeconds" of the console machines. Try 180 to see if that helps, otherwise try a higher number.

     

    There is a fixlet available here that will do this:  http://bigfix.me/fixlet/details/3676

     

     

  • hosmar
    hosmar
    5 Posts

    Re: http Error 28

    ‏2014-03-17T14:54:22Z  
    • jgstew
    • ‏2014-03-17T14:46:01Z

    You need to increase the value of the setting "_BESData_Comm_TimeoutSeconds" of the console machines. Try 180 to see if that helps, otherwise try a higher number.

     

    There is a fixlet available here that will do this:  http://bigfix.me/fixlet/details/3676

     

     

    Thanks for you quik reply, but if the console doesnt open what has to be done?

  • jgstew
    jgstew
    56 Posts

    Re: http Error 28

    ‏2014-03-17T15:16:18Z  
    • hosmar
    • ‏2014-03-17T14:54:22Z

    Thanks for you quik reply, but if the console doesnt open what has to be done?

    The console won't open at all due to the timeout issue?

    You could try manually deleting the console cache.

    Does the console work anywhere in your environment? You should be able to use the console on the root server to deploy the fix to other machines with the issue. Otherwise I'd suggest using the REST api to set this setting. The other option would be to set the setting by hand in the registry on the console machine.

  • hosmar
    hosmar
    5 Posts

    Re: http Error 28

    ‏2014-03-17T15:20:19Z  
    • jgstew
    • ‏2014-03-17T15:16:18Z

    The console won't open at all due to the timeout issue?

    You could try manually deleting the console cache.

    Does the console work anywhere in your environment? You should be able to use the console on the root server to deploy the fix to other machines with the issue. Otherwise I'd suggest using the REST api to set this setting. The other option would be to set the setting by hand in the registry on the console machine.

    thanks for you quick response, I have a Win 2k8 Server install on a workstation and the console run on the server itself. The console doesnt work from this server itself. I have tried deleting the cache too and doesnt work.

    All I did was did an manual upgrade from 8.2 to 9.0

     

    I just tried to access the URL directly and get this erro in the browser.

    Server is starting

    Status: Waiting for the client CA key to become available

  • jgstew
    jgstew
    56 Posts

    Re: http Error 28

    ‏2014-03-17T15:24:30Z  
    • hosmar
    • ‏2014-03-17T15:20:19Z

    thanks for you quick response, I have a Win 2k8 Server install on a workstation and the console run on the server itself. The console doesnt work from this server itself. I have tried deleting the cache too and doesnt work.

    All I did was did an manual upgrade from 8.2 to 9.0

     

    I just tried to access the URL directly and get this erro in the browser.

    Server is starting

    Status: Waiting for the client CA key to become available

    I would suggest opening a PMR with IBM, this sounds like it could be more than just a timeout issue.

    You could try setting the "_BESData_Comm_TimeoutSeconds" setting in the registry.

  • hosmar
    hosmar
    5 Posts

    Re: http Error 28

    ‏2014-03-17T15:31:52Z  
    • jgstew
    • ‏2014-03-17T15:24:30Z

    I would suggest opening a PMR with IBM, this sounds like it could be more than just a timeout issue.

    You could try setting the "_BESData_Comm_TimeoutSeconds" setting in the registry.

    Thank you, unable to find the registry key though. I will raise a PMR and keep posted if the issue is fixed.

  • jgstew
    jgstew
    56 Posts

    Re: http Error 28

    ‏2014-03-17T15:40:57Z  
    • hosmar
    • ‏2014-03-17T15:31:52Z

    Thank you, unable to find the registry key though. I will raise a PMR and keep posted if the issue is fixed.

    The registry key path should be the following:

    [HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\BigFix\EnterpriseClient\Settings\Client\_BESData_Comm_TimeoutSeconds]

    REG_SZ values:

    "value"="180"

    "effective date"="Fri, 02 Aug 2013 12:00:00 -0400"

     

    The "effective date" can be any date in the past, as long as it is properly formatted.

  • hosmar
    hosmar
    5 Posts

    Re: http Error 28

    ‏2014-04-23T13:30:46Z  
    • jgstew
    • ‏2014-03-17T15:40:57Z

    The registry key path should be the following:

    [HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\BigFix\EnterpriseClient\Settings\Client\_BESData_Comm_TimeoutSeconds]

    REG_SZ values:

    "value"="180"

    "effective date"="Fri, 02 Aug 2013 12:00:00 -0400"

     

    The "effective date" can be any date in the past, as long as it is properly formatted.

    The problem was the IP Address of the server was changed and this was creating the I realized when I executed the diagnostic tool. Changed the IP Address what the TEM Server was looking for and the console is working now.

    Thanks a lot all for your time

  • jgstew
    jgstew
    56 Posts

    Re: http Error 28

    ‏2014-04-23T13:41:03Z  
    • hosmar
    • ‏2014-04-23T13:30:46Z

    The problem was the IP Address of the server was changed and this was creating the I realized when I executed the diagnostic tool. Changed the IP Address what the TEM Server was looking for and the console is working now.

    Thanks a lot all for your time

     

    Glad to hear you got it resolved. Thanks for posting the follow up of how it was resolved, it is very useful.

     

     

  • Mohamed Abd-Elmoneim
    1 Post

    Re: http Error 28

    ‏2015-01-18T10:12:57Z  

    any update about this http error 28

    HTTP Error 28: Timeout was reached: Operation timed out after 10000 milliseconds with 0 out of 0 bytes received

  • Mrs.Llanes
    Mrs.Llanes
    2 Posts

    Re: http Error 28

    ‏2015-06-12T02:47:19Z  
    • jgstew
    • ‏2014-04-23T13:41:03Z

     

    Glad to hear you got it resolved. Thanks for posting the follow up of how it was resolved, it is very useful.

     

     

    It worked! Thank you so much!

     

  • Mrs.Llanes
    Mrs.Llanes
    2 Posts

    Re: http Error 28

    ‏2015-06-12T02:49:22Z  

    The problem was the IP Address of the server was changed and this was creating the I realized when I executed the diagnostic tool. Changed the IP Address what the TEM Server was looking for and the console is working now.

    Thanks a lot all for your time

    -Hosmar

     

    This worked! Thank you so much Hosmar!