Topic
  • 1 reply
  • Latest Post - ‏2013-11-05T14:55:57Z by BirgitHeubach
itzdilip
itzdilip
1 Post

Pinned topic package update causing me error in installing first box

‏2013-10-08T07:00:06Z | firstbox libguestfs libguestfs-tools-1.16.19-1.el6.x86_64 openstack rhel update

am evaluating the SCO product,

 

we are following the first box installation procedure, 

so far we have installed first box,

 

now the open stack install is issue

I have runed install.sh inside

 /install_images/IBM_SmartCloud_Installer_and_OpenStack-2.2.0.0-201305010142/deploy-scripts/allinone 

 

log says :::::

/usr/lib64/python2.6/site-packages/rhsm/certificate.py:123: DeprecationWarning: Call to deprecated function: __init__
  category=DeprecationWarning)
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package python-libguestfs.x86_64 1:1.16.19-1.el6 will be installed
--> Processing Dependency: libguestfs = 1:1.16.19-1.el6 for package: 1:python-libguestfs-1.16.19-1.el6.x86_64
--> Finished Dependency Resolution
Error: Package: 1:python-libguestfs-1.16.19-1.el6.x86_64 (LocalMedia)
           Requires: libguestfs = 1:1.16.19-1.el6
           Installed: 1:libguestfs-1.16.34-2.el6.x86_64 (@rhel-x86_64-server-6)
               libguestfs = 1:1.16.34-2.el6
           Available: 1:libguestfs-1.2.7-1.24.el6.x86_64 (rhel-x86_64-server-6)
               libguestfs = 1:1.2.7-1.24.el6
           Available: 1:libguestfs-1.7.17-17.el6.x86_64 (rhel-x86_64-server-6)
               libguestfs = 1:1.7.17-17.el6
           Available: 1:libguestfs-1.7.17-26.el6.x86_64 (rhel-x86_64-server-6)
               libguestfs = 1:1.7.17-26.el6
           Available: 1:libguestfs-1.16.19-1.el6.x86_64 (LocalMedia)
               libguestfs = 1:1.16.19-1.el6
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
 
inside foreach rpmName: scrub
/usr/lib64/python2.6/site-packages/rhsm/certificate.py:123: DeprecationWarning: Call to deprecated function: __init__
  category=DeprecationWarning)
RPM: scrub already installed
inside foreach rpmName: seabios
/usr/lib64/python2.6/site-packages/rhsm/certificate.py:123: DeprecationWarning: Call to deprecated function: __init__
  category=DeprecationWarning)
RPM: seabios already installed
inside foreach rpmName: sgabios-bin
/usr/lib64/python2.6/site-packages/rhsm/certificate.py:123: DeprecationWarning: Call to deprecated function: __init__
  category=DeprecationWarning)
RPM: sgabios-bin already installed
inside foreach rpmName: spice-server
/usr/lib64/python2.6/site-packages/rhsm/certificate.py:123: DeprecationWarning: Call to deprecated function: __init__
  category=DeprecationWarning)
RPM: spice-server already installed
inside foreach rpmName: usbredir
/usr/lib64/python2.6/site-packages/rhsm/certificate.py:123: DeprecationWarning: Call to deprecated function: __init__
  category=DeprecationWarning)
RPM: usbredir already installed
inside foreach rpmName: vgabios
/usr/lib64/python2.6/site-packages/rhsm/certificate.py:123: DeprecationWarning: Call to deprecated function: __init__
  category=DeprecationWarning)
RPM: vgabios already installed
inside foreach rpmName: yajl
/usr/lib64/python2.6/site-packages/rhsm/certificate.py:123: DeprecationWarning: Call to deprecated function: __init__
  category=DeprecationWarning)
RPM: yajl already installed
inside foreach rpmName: nss_compat_ossl
/usr/lib64/python2.6/site-packages/rhsm/certificate.py:123: DeprecationWarning: Call to deprecated function: __init__
  category=DeprecationWarning)
RPM: nss_compat_ossl already installed
inside foreach rpmName: redhat-lsb
/usr/lib64/python2.6/site-packages/rhsm/certificate.py:123: DeprecationWarning: Call to deprecated function: __init__
  category=DeprecationWarning)
RPM: redhat-lsb already installed
inside foreach rpmName: java-1.6.0-openjdk.x86_64
/usr/lib64/python2.6/site-packages/rhsm/certificate.py:123: DeprecationWarning: Call to deprecated function: __init__
  category=DeprecationWarning)
RPM: java-1.6.0-openjdk.x86_64 already installed
result of install: java-1.6.0-openjdk.x86_64 1:1.6.0.0-1.45.1.11.1.el6       @anaconda-RedHatEnterpriseLinux-201206132210.x86_64/6.3
 
INFO: LIB libguestfs-winsupport has been correctly installed
WARNING: libguestfs-1.16.19-1.el6.x86_64 version will not allow Proxy to provide all the requested image info, please install the recomended version
 
ERROR: libguestfs-tools-c-1.16.19-1.el6.x86_64 is not installed and it is necessary to make Proxy work
 
ERROR: python-libguestfs-1.16.19-1.el6.x86_64 is not installed and it is necessary to make Proxy work
Mon Oct  7 18:13:02 IST 2013: ERROR: Failed check of libguestfs libraries.
 
Mon Oct  7 18:13:02 IST 2013: COPINS100I The script exit code is 118.
                                                                     

------------------------------------------------------------------------------------------------------------------------------------

when i was looking in to logs i saw log file

 

 /tmp/vil/./rpmList_proxy.txt

nfs-utils
dos2unix
perl-Archive-Extract
perl-ExtUtils-MakeMaker
perl-Archive-Tar
unzip
openssh-clients
wget
gcc
ncurses-devel
openssl-devel
sqlite-devel
bzip2-devel
readline-devel
augeas-libs
btrfs-progs
celt051
cyrus-sasl
cyrus-sasl-gssapi
cyrus-sasl-lib
cyrus-sasl-md5
cyrus-sasl-plain
genisoimage
gnutls-utils
hivex
febootstrap-supermin-helper
gpxe-roms-qemu
qemu-img
qemu-kvm
libguestfs-1.16.19-1.el6.x86_64
libguestfs-winsupport-1.0-7.el6.x86_64
libguestfs-tools-1.16.19-1.el6.x86_64
libvirt-client
lzo
lzop
netcf-libs
perl-hivex
python-libguestfs-1.16.19-1.el6.x86_64
scrub
seabios
sgabios-bin
spice-server
usbredir
vgabios
yajl
nss_compat_ossl
redhat-lsb
java-1.6.0-openjdk.x86_64

 

but when i saw the install script its installing like

yum -y install qemu-kvm qemu-img python-virtinst virt-manager virt-viewer libvirt libvirt-client libguestfs
    modprobe kvm && modprobe kvm_intel || modprobe kvm_amd
 

which is getting the  different version, and at the end of installation it fails saying, the needed is 

libguestfs-1.16.19-1.el6.x86_64
libguestfs-winsupport-1.0-7.el6.x86_64
libguestfs-tools-1.16.19-1.el6.x86_64

and fails 

 

pointing to the new packages...

 

 

I request help in this questions

 

how to fix this can any one point?

or

can any one help me?

I have attached the log file with this

 

Attachments

  • BirgitHeubach
    BirgitHeubach
    7 Posts

    Re: package update causing me error in installing first box

    ‏2013-11-05T14:55:57Z  

    Hi, have you been following the SCO install process found in the infocenter at:
    http://pic.dhe.ibm.com/infocenter/tivihelp/v48r1/topic/com.ibm.sco.doc_2.2/welcome.html

    Make sure all the OS and software prereqs as follows are given:

    Required packages

    SmartCloud Orchestrator runs on top of Red Hat Enterprise Linux 6.3 64-bit. The following packages are required:
    1. RHEL6.3-20120613.2-Server-x86_64-DVD2.iso
      Note: Before installing SmartCloud Orchestrator, prepare an ISO file of Red Hat Enterprise Linux 6.3 x86_64 and place it on the first box, for example, in /opt. The kernel version must correspond with the operating system of the first box.
    2. libguestfs-winsupport-*.el6.x86_64.rpm (<= 1.0-7)
    3. rubygems-*.el6.noarch.rpm (<= 1.3.7-1)
    Make sure that all packages are copied into /data/repos/scp.

    best regards, Birgit H.