Topic
3 replies Latest Post - ‏2013-10-09T18:47:52Z by dattark
Okonita
Okonita
15 Posts
ACCEPTED ANSWER

Pinned topic Can I replace DB2v10.1 (w/paid support) with DB2 v10.5 Express-C?

‏2013-10-08T17:38:41Z |

Hello All,

I currently have DB2v10.1 with yearly support subscription license. For obvious reason - eliminate the yearly support fees, we want to replace the current paid-for version (10.1) with the new and FREE version of DB2 v10.5 (DB2v10.5, Express-C). Can this be done? If so, how can I safely replace the old DB2 installation without impacting all the tables and other DB2 objects and db2 data?

Can someone please help with the best way to accomplish this step-down product upgrade/migration.?

 

Thanks very much

 

Okonita

  • Rudolf Bargholz
    Rudolf Bargholz
    4 Posts
    ACCEPTED ANSWER

    Re: Can I replace DB2v10.1 (w/paid support) with DB2 v10.5 Express-C?

    ‏2013-10-09T13:05:32Z  in response to Okonita

    Hi Okonita,

    You will need to export the data using "db2move", export all your objects to a DDL file, uninstall 10.1, install 10.5, create your DB, run your DDL SQL script to create all your tables and database objects, then use the archived "db2move" to import data into the tables. Beware of ADD triggers, you might need to drop these before a db2move IMPORT and recreate them after the import. As far as I am ware with the Express version, you cannot update an installed DB2 keeping your tables and DB objects. You need to go the way of an export/import. I would however love to be corrected should this no longer be the case.

    Regards

    Rudolf

  • nivanov1
    nivanov1
    53 Posts
    ACCEPTED ANSWER

    Re: Can I replace DB2v10.1 (w/paid support) with DB2 v10.5 Express-C?

    ‏2013-10-09T14:34:06Z  in response to Okonita

    I think a good place to start is read the manual: http://publib.boulder.ibm.com/infocenter/db2luw/v10r5/topic/com.ibm.db2.luw.qb.upgrade.doc/doc/t0007200.html

  • dattark
    dattark
    17 Posts
    ACCEPTED ANSWER

    Re: Can I replace DB2v10.1 (w/paid support) with DB2 v10.5 Express-C?

    ‏2013-10-09T18:47:52Z  in response to Okonita

    Hope you are aware that by moving to unsupported Express-C version, you lose the ability to install fix packs. If you are not running a critical project on DB2 then perhaps the unsupported version is a good fit.

    IBM will always be looking to improve the efficiency of DB2 and in doing so, the software development process, including turnover of engineering teams, does introduce bugs that are resolved through fix packs.