Topic
  • 3 replies
  • Latest Post - ‏2014-10-26T11:28:37Z by AngocA
AngocA
AngocA
6 Posts

Pinned topic DB2 does not start after updating Mas OS X to Yosemite

‏2014-10-17T21:54:29Z |

I successfully updated the OS to the most recent version. However, DB2 does not longer start.

When I start the instance, it says:

$ db2start
SQL1220N  The database manager failed to allocate shared memory.

And the db2diag.log has:

2014-10-17-23.50.38.307068+120 E17065E342           LEVEL: Error (OS)
PID     : 1571                 TID : 140735127106304PROC : db2star2
INSTANCE: angoca               NODE : 000
HOSTNAME: Andress-MBP
FUNCTION: DB2 UDB, SQO Memory Management, sqloMemCreateSingleSegment, probe:100
CALLED  : OS, -, shmget                           OSERR: 22

2014-10-17-23.50.38.307339+120 I17408E413           LEVEL: Severe
PID     : 1571                 TID : 140735127106304PROC : db2star2
INSTANCE: angoca               NODE : 000
HOSTNAME: Andress-MBP
FUNCTION: DB2 UDB, base sys utilities, DB2StartMain, probe:4767
MESSAGE : ZRC=0x850F0005=-2062614523=SQLO_NOSEG
          "No Storage Available for allocation"
          DIA8305C Memory allocation failure occurred.

2014-10-17-23.50.38.307687+120 I17822E366           LEVEL: Severe
PID     : 1571                 TID : 140735127106304PROC : db2star2
INSTANCE: angoca               NODE : 000
HOSTNAME: Andress-MBP
FUNCTION: DB2 UDB, base sys utilities, DB2StartMain, probe:3
MESSAGE : ZRC=0xFFFFFB3C=-1220
          SQL1220N  The database manager failed to allocate shared memory.

I recreated the ftok file, but it is still the same problem - http://www-01.ibm.com/support/docview.wss?rs=0&q1=SQL1220N&uid=swg21217932

My sysctl file contains:

$ cat /etc/sysctl.conf
kern.sysv.shmmax=1073741824 
kern.sysv.shmmin=1 
kern.sysv.shmmni=4096 
kern.sysv.shmseg=32 
kern.sysv.shmall=1179648 
kern.maxfilesperproc=65536 
kern.maxfiles=65536 

When I opened a terminal, it appeared:

-bash: ulimit: open files: cannot modify limit: Invalid argument

DB2 worked perfectly before the update.

What do you think about this? how can I solve the problem?

Updated on 2014-10-17T22:37:40Z at 2014-10-17T22:37:40Z by AngocA
  • tsupplis
    tsupplis
    2 Posts

    Re: DB2 does not start after updating Mas OS X to Yosemite

    ‏2014-10-19T16:33:37Z  

    Please, double check that the lines in sysctl.conf do not have a trailing space. This seems to be causing a problem with Yosemite whereas it was properly working with previous versions. Doing so will set the sysctl paramerers at boot and you and DB2 should start no problem.

    Another check is the following type of log statements in /var/log/system.log, see the trailing space.....

    Oct 19 16:12:40 localhost com.apple.xpc.launchd[1]: Could not set sysctl "kern.sysv.shmmni=4096 ": exit code = 1

  • tsupplis
    tsupplis
    2 Posts

    Re: DB2 does not start after updating Mas OS X to Yosemite

    ‏2014-10-19T16:49:22Z  
    • tsupplis
    • ‏2014-10-19T16:33:37Z

    Please, double check that the lines in sysctl.conf do not have a trailing space. This seems to be causing a problem with Yosemite whereas it was properly working with previous versions. Doing so will set the sysctl paramerers at boot and you and DB2 should start no problem.

    Another check is the following type of log statements in /var/log/system.log, see the trailing space.....

    Oct 19 16:12:40 localhost com.apple.xpc.launchd[1]: Could not set sysctl "kern.sysv.shmmni=4096 ": exit code = 1

    Also, if you updated to yosemite, verify that your /etc/services file has not be overriden, hence loosing and tcp port settings for db2....

  • AngocA
    AngocA
    6 Posts

    Re: DB2 does not start after updating Mas OS X to Yosemite

    ‏2014-10-26T11:28:37Z  
    • tsupplis
    • ‏2014-10-19T16:33:37Z

    Please, double check that the lines in sysctl.conf do not have a trailing space. This seems to be causing a problem with Yosemite whereas it was properly working with previous versions. Doing so will set the sysctl paramerers at boot and you and DB2 should start no problem.

    Another check is the following type of log statements in /var/log/system.log, see the trailing space.....

    Oct 19 16:12:40 localhost com.apple.xpc.launchd[1]: Could not set sysctl "kern.sysv.shmmni=4096 ": exit code = 1

    Thank you. This solved the problem, there were some trailing spaces in the values of the sysctl file.

    I just delete them and restart the Mac, and it worked!