Topic
  • 1 reply
  • Latest Post - ‏2014-07-17T21:43:50Z by rick.lacy
STret
STret
1 Post

Pinned topic Unable to map shared libaries

‏2014-06-10T15:47:38Z |

Hi, I am on IBM RAD 9.0.1 (Build ID: RADO901-I20131204_1312) and WAS 8.5.5.2.  I am trying to link an application to a user defined common shared library.  I select the application module and click on 'Reference Shared Libraries' on the 'Shared Library References' page.  On the next page (Shared library mapping), I see my user defined libraries.  I click on one of them, and click the 'right arrow', but nothing happens.  I am simply not able to select / map a library to my app.  On googling someone suggested, I uncheck ''Minimize application files copied to server' under publishing settings for WAS.  But that didn't work either.

I then upgraded my RAD/ WAS environment to the latest levels this morning.  That didn't eliminate the problem either.  But I'm seeing additional errors on the console when I start WAS.  The error messages are "java.net.URISyntaxException: Illegal character in path at index 16: file:/C:/Program Files/IBM/WebSphere/AppServer_1/lib/pc-appext.jar. java.net.URISyntaxException: Illegal character in path at index 16: file:/C:/Program Files/IBM/WebSphere/AppServer_1/lib/rrd-appext.jar".  I would really appreciate it, if anybody could point out something that I'm missing here.  Thanks,

  • rick.lacy
    rick.lacy
    29 Posts

    Re: Unable to map shared libaries

    ‏2014-07-17T21:43:50Z  

    Sorry for the kind of late reply, but I'll try to answer as best I can based on my experience.

    When you deploy a project from your workspace to a local test server, there are several options in the admin console that don't work for managing the modules deployed to the server.  This is because of the way the app is deployed to the server.  If you select Run server with resources on Server instead of Run server instead of Run server with resources on Server (note that this automatically disables the Minimize files option), then the options in the admin console would have been available to you.

    The trouble is, running with resources on the server instead of the workspace is a performance hit and you don't want to do this if you don't have to.

    Fortunately, there is a way to specify these deployment options from within RAD.  If you right click the EAR project and navigate to Java EE -> Open WebSphere Application Server Deployment, then you get back the options to specify things like classloader mode, classloader policy, and shared libraries, even when using resources from the workspace.

    Also, if this is just a test profile with one app deployed to it or if several apps are supposed to use this shared library, you might be better off associating it with the server classloader.  Then you don't have to do any additional EAR configuration at all.