• Add a Comment
  • Edit
  • More Actions v
  • Quarantine this Entry

Comments (42)

1 localhost commented Permalink

Hi Bobby, First thanks for your Blog, really appreciate it, a lot of useful information.My question is: When I select a Web Project -> Create a WebService (from pop-up menu) it brings me a windom where I need to select some webservices confs, what I would like to know is: what's the option called "Generate a Proxy"-> Java Proxy ?? I read this dW tutorial, http://www-128.ibm.com/developerworks/webservices/library/ws-cooprad/it ask me to select this option, but it create a SOAPBindingImpl class that is auto generated and this class tries to implement my Class that will be the WebService, but this class is not a interface, then I got an error.Thanks

2 localhost commented Permalink

tatsuya: Glad you like the blog. Check out the pages Creating a Web service from a Java bean using the IBM WebSphere run-time environment and Creating a Web service from a Java bean using the IBM SOAP run-time environment. That proxy is one you can use to invoke the Web service Java-to-Java, which is helpful for testing. Good luck.

3 localhost commented Permalink

Hi,I have used the earlier versions of RAD6 (WSAD) & also have used earlier versions if WebSphere Site Developer. I now have RAD 6.0.1.In showing some new employees the great features of RAD 6 I picked a very simple example to show rapidly but fell flat on my face when I could not demo how to publish a simple static web page with 'Hello World' in it. Now 3 weeks later I still can't see how to do it unless I install my own Apache & publish to its web dir.In RAD 6 I can publish a JSP & run it on WAS6 without difficulty but could find *no* way to create a startable 'Static web publishing server' - If I select 'Run on web server', RAD opens a window called server selection & offers an only choice of 'Static Web Publishing Server' - if I choose this & 'finish' publishing always fails. If I click 'next' & select a folder (such as C:\MyWebHome) then 'next' and supply a port number (usually 80), then 'finish' the web page gets published in the dir ok, then RAD tries to access it through the internal browser but fails. In the Servers window, in addition to my default WebSphere V6 Server (on port 9080 & started ok), I see a 'Static Web Publishing Server' with a status of started, but there isn't any server listening on port 80 so it is quite clear nothing got started.If I go to Window/Preferences/Server/Installed Runtimes, I see no way to create a Static Web Publishing Server.I am guessing I have to configure one somewhere, I just wish I could find where. I read all the tutorials, went to IBM's redbooks site & read a couple on RAD 6 & how to set up servers but nothing on setting up a static web publishing server.Any clues would be most welcome even though I solved this problem by setting up my own non integrated server.ThanksDoug Marker

4 localhost commented Permalink

Hi Bobby,Last year I attended some of your sessions at the Webpshere Conference in Munich, Germany. This year I planned to visit your session, but the organisation said that the session was cancelled. Maybe next year...I have a question about migrating towards RAD6. Working with WSAD we had the serverconfiguration. When changes were made the whole tree was checked out from ClearCase and changes could easily be made. In RAD there is nothing more than te "Enhanced EAR". Creating a servers project results in an empty project. We decided to create the was-profile we're working with inside the workspace (e.g. inside the CC-view), but changes, which must be made through the admin console are difficult to maintain. Without manually checking these files out the changes result in an "Access denied". So, the question is:- What does IBM suggest about locating the profiles? (inside or outside the workspace).- How could be taken care of versioncontrol for the WAS6 configuration? If you're not able to answer this question, please let me know. I'll try to find other resources. Maybe you know other resources of information.Kind regards,Rik Bosman

5 localhost commented Permalink

Rik: Please see RAD 6: Sharing a Test Environment Configuration.Thanks for looking for me at WebSphere Technical Conference this year; sorry I couldn't present. Next year, when you register, perhaps you can tell them that you want my money back if they don't invite me to present! :-)

6 localhost commented Permalink

Bobby, I didn't find documentation on how to develop and publish a JSP web application to a separate instance of WAS6 instead of the RAD integrated test environment.

7 localhost commented Trackback

I am trying to run the WebSphereApplication Server in RAD. But I am unable to run the server. I don't know what is the reason? what would be the system configuration to run RAD? I am unable to see the log file also? where it'll locate?

8 localhost commented Trackback

Same here buddy.I imported the ear AND CREATED THE SERVER AND I ADDED THIS EAR TO SERVER /PUBLISH/START....................

 
THEN ONWORDS NOTHING IT SAYS STARTING STARTING STARTING....
 
IF ANY ONE FACED THE SAME PROBLEM PLEASE UPDATE ME.
 
/JAMM

9 localhost commented Permalink

I installed RAD 6.0 and tried to start the server. Keep saying starting server. The console showed a message saying "system cannot find the path". I installed the patches 6.0.1.1 and same results. Tried to create a profile, then got a message saying "wasprofile.properties" is missing.I would appreciate if any one can help.

10 localhost commented Permalink

Is RAD the best application I should use to integrate and extend (mashup) web services, or would that functionality best be delivered by WID?

 
I've been poking around RAD, but haven't discovered any easy way to call external web services - whereas writing them ground-up seems well supported in RAD.
 
 
 

11 localhost commented Permalink

Same prob with me..i tried to create the server(6.0) in RAD and after adding the project to the server it automatically starts and keeps on saying starting..but does nothing...sometime s it sys couldnt start chk the console for errors but the console is blank..what a peice of junk is this software?

12 localhost commented Trackback

For those who see "Starting ....".

 
1. It's a bug in RAD/RSA. Use your updater to patch it to RAD v6.0.1.1 plus Interim Fix (Ifix) 001 and 002. It should solve the problem.
 
http://www-1.ibm.com/support/docview.wss?uid=swg21198280
 
2. I had a blog about the fix.
 
http://websphere-mengzhaohua.blogspot.com/2006/01/rsarad-60-console-output-fails-to.html
 
The approach in my blog always worked for me. However, be prepared to NOT see anything in console at any moment. Your only luck then is to restart your embedded runtime several times, possibly your machine. And if it still doesn't work, look at the system.out file directlly as in the following directory.
 
C:\Program Files\IBM\Rational\SDP\6.0\runtimes\base_v6\profiles\default\logs\server1

13 localhost commented Permalink

Hi,

 
We have an application running on RAD 6.0.2.5. The log files are getting created with 0 kb. Is there anything specific configuration needs to be done for RAD 6.0 to log application log level entries.

14 localhost commented Permalink

HI I am having WSAD5.1.2. Now i want to port an application from RAD 6 into this WSAD. Obviously it will have incompatibility with JRE and all. Can you tell me what are the steps need to be taken to migrate the application from RAD6 to WSAD5.1.2

 
ThanksPavan

15 localhost commented Permalink

Hi Bobby, I am planning to use RAD 6 as our development environment, what compiler would you suggest that is compatible with this and JDK 1.4.2.

 
Do you have a list of the pro's and con's among the various compilers.
 
 
 
Kalyani
 

Add a Comment Add a Comment