• Add a Comment
  • Edit
  • More Actions v
  • Quarantine this Entry

Comments (14)

1 localhost commented Permalink

Hi Bob..thanks for providing this place to discuss VLP and how to make it a great capability. A couple of quick questions on behalf of my VC-backed startup friends:

 
(1) Do you or will you support Linux distros like Red Hat, SUSE, etc. as a regular feature or do I need to do something special to get this configured for my session?
 
(2) Re middleware, same question as above for AJAX toolsets like jackBE, Laszlo, Zend, etc. Are these available?
 
(3) If I have runtime instances that are ready to go, can I simply FTP to my sever and run in a Linux runtime environment? What about storage I might need or bandwidth to access during testing?
 
Thanks!
 
Drew

2 localhost commented Permalink

Drew - I'm working on getting answers to your question #2 about the availability of AJAX toolsets.

 
We support RHEL 4, RHEL 5, SLES 9 and SLES10 on POWER5 and POWER6 systems by default. You can access 64-bit distros on x86 platforms by getting to VLP through the Chiphopper program. You can learn more about that program at: http://www.ibm.com/developerworks/linux/chiphopper/
 
I don't know exactly what you mean by "runtime instances." I'm not a super Linux expert.
 
What you will get with a VLP reservation is remote access to a system that has a Red Hat or SLES distro installed and running. You can scp whatever you need to remote server by using a tunnel through an SSH gateway machine. We do this to keep from having to put the provisioned systems out on the Internet.
 
We provide you with on the order of 20Gb of storage by default. We carve up a single large IBM POWER server into logical partitions and these logical partitions are the servers you get access to. So, the system you get won't be suitable for performance testing an application. It will be good for porting, compiling and doing a proof-of-concept.

3 localhost commented Permalink

Drew, the middleware that you listed is not in the Linux images by default. Only middleware that you would find in the stock SLES and RHEL distributions are available. If the middleware is supported on SLES or RHEL, you can copy the software over yourself though and configure it.

4 localhost commented Trackback

Hi Bob - I'm about to reserve a SLES10 server and I have a question about the virtual machine I will be handed. Does it come loaded from a standard VM template with default packages, services and interfaces installed such that if I reserve a second SLES10 server, they would be identical when they are initially delivered to me?

 
We have had experiences in the past with "i" reservations where the virtual machines were quite different in terms of PTF levels (even though they were the same VRM level). Do you know if if this is something I can expect on SLES or RHEL?

5 localhost commented Permalink

Hey Steve - The short answer to your question is yes, the two SLES10 systems will be identical.

 
This is a great question, especially since we recently made VLP like the rest of IBM and stopped making a distinction between POWER5 System p and POWER5 System i servers. I say that because what this means to you is when you reserve a SLES10 on POWER5, you always will get the same kind of hardware. Also, whenever you reserve a SLES10 system on POWER5, you will always get the same base operating system image installed.

6 localhost commented Permalink

I have requested an iSeries i5/OS reservation from VLP. The How To documents do not demonstrate a means of transferring my files from my Windows XP computer to the iSeries computer. Please tell me whether/how I can (1) use FTP to transfer my files to IFS on the iSeries computer and (2) map a Windows network drive to IFS on the iSeries computer or (3) transfer my files via some other means. Thank you.

7 localhost commented Permalink

Yes, FTP can be used to transfer files to you i5/OS system. The easiest way is to establish a VPN connection from your desktop system to the VLP VPN Gateway. Instructions for obtaining and using the VPN connection are in the Connecting to Your VLP System - A User Guide v2 on the How to tab. You will need to first logon to the i5 system with a 5250 emulator and reset your passwords, then you can use the standard FTP functions to do the transfer. You can also use this connection to map a network drive to the i5 system. The VLP i5 systems also have ssh installed, so if you are familiar with ssh and scp, and have an appropriate ssh client installed on your Windows XP system, you can use scp to transfer files as well. If you have iSeries Access or Navigator installed, the included functions will work with the VLP hosted i5 system.

 

8 localhost commented Permalink

I am new to VLP and a real AIX newbie in a Linux software development organization. My assignment is to validate our software products on AIX V5.3 and AIX 6 environments.

 
I am using the provided VPN client and I have used my favorite SSH client and FTP client to, respectively, open a session and transfer files to my reserved machine.
 
I have to say my experience is frustrating for 3 reasons.
 
1) Our development tools are GUI applications, but I can't get a connection from my VLP AIX system back to my X Window client on my Windows workstation. I have used the ipconfig command to get the VPN IP address of my workstation and I have set the $DISPLAY environment variable to that address, but when I attempt to run a GUI program (like xclock) the system tells me that it cannot open the display. I have experience doing this on our company VPN using my Windows workstation, the Cisco VPN client, and our Linux hosts, but I have never tried to do this with AIX.
 
2) In my SSH session, the expected command recall key (up arrow on Linux) and file completion key (tab on Linux) do not do the job.
 
3) Apparently the SFTP server is not active. Now you may argue that the FTP server is good enough, but it is not good enough if your company procedures and automated scripts rely on SFTP.
 
Clearly, I need some AIX skills, but can't be the only Linux user using VLP to run AIX. Do you have an AIX Primer for Linux Users?

9 localhost commented Permalink

Lance,

 
Thanks for letting me know about your experiences. Here is an attempt to address some of your concerns.
 
1) Our users that need a GUI interface to their reserved partitions use VNC. What they do to get this to work is to start the VNC server on their target partition. Then, they go to our SSH gateway machine and establish an SSH tunnel between the port that allows a connection to their remote display (port 5900 for display :0, 5901 for display :1, etc) and a free port on the SSH gateway machine. Then, they tell their VNC veiwer on their desktop/laptop to connect to the tunnel on the SSH gateway machine. This allows their X-windows displays to be displayed remotely in the remote vncserver session and to have the 'screen-scrape' sent through the tunnel to their local VNC viewer.
 
2) By default in AIX, you will have a ksh session. To get a bash session, type 'bash'. You can also use the command set -o vi to enable you to run vi on your command line. Esc-k followed by 'k' will allow you to recall commands.
 
3) You can configure the sftp subsystem using sshd_config. The man page will tell you how.
 
Now the answer to your question: No we do not have a Linux to AIX primer. I will look for one on the IBM site and when I find one, I'll post it here.

10 localhost commented Permalink

1) Thanks for the tip on VNC. With the help of the support team I started the VNC server and the result met my requirements nicely. I suggest you add "Connecting via VNC" to your user guide "Connecting to your VLP System".

 
2) There is no bash on my system. The Esc-k followed by additional k keys will scroll back through previous commands. I guess I will have to work on my VI skills. What a pain!
 
3) To me, it appears that the sshd_config file is correct, but I still can't use SFTP, not even from inside the VLP system. I guess I will have to get the support team to help me with that.
 
Thanks for your effort.

11 localhost commented Permalink

Lance,

 
Both improving our "Connecting to your VLP System" section and including bash by default are good ideas. We will add those to our list of development/documentation tasks.
 
Meanwhile, you can go to /stage/middleware/RPMS.ppc and run rpm to install bash-3.0-19.3.ppc.rpm. On AIX, rpm works the same as on Linux.
 
I admit to being ignorant about sftp, since we use scp for everything internally. I bet if you change the config file slightly, it will work. I did look and I saw this line in sshd_config:
 
Subsystem sftp /usr/libexec/sftp-server
 
/usr/libexec/sftp-server does not exist. These are the files in the openssh.base.server fileset:
 
root@lpar3ml162f_pub[/etc] > lslpp -f openssh.base.server Fileset File ----------------------------------------------------------------------------Path: /usr/lib/objrepos openssh.base.server 3.6.1.5200 /usr/sbin/sshd /usr/sbin/sftp-server
 
Path: /etc/objrepos openssh.base.server 3.6.1.5200 /etc/ssh/sshd_config /etc/ssh/ssh_host_key /etc/rc.d/rc2.d/Ssshd /etc/ssh/ssh_host_dsa_key.pub /etc/ssh/ssh_host_rsa_key /var/empty /etc/rc.d/rc2.d/Ksshd /etc/ssh/ssh_host_key.pub /etc/ssh/ssh_host_rsa_key.pub /etc/ssh/ssh_host_dsa_key /etc/ssh
 
Be careful when you change the sshd_config file, since our system makes use of SSH and radical changes to SSH can fould things up. You should be OK if you limit your changes to simply getting sftp to work.

12 localhost commented Permalink

Ah, Bob! You're a jewel.

 
Thanks for the tip locating a bash package for AIX. I think that will solve most of my script compatibility problems and my keyboard aggravations as well.
 
You are also right about sshd_config. I looked right at that subsystem definition and didn't realize that the path was wrong. I just created /user/libexec, changed its access mode, and added a symbolic link to /usr/sbin/sftp-server. After a shutdown -r, I have SFTP working.
 
sumkdir /usr/libexecchmod 755 /usr/libexecln -s /usr/sbin/sftp-server /usr/libexec/sftp-servershutdown -r
 
I suggest you add "fix SFTP" to you development/documentation tasks as well.
 
Thank-you!!!

13 localhost commented Permalink

Bob, please let me offer a few more observations from my first experience with the virtual loaner program (VLP).

 
1) On the standard configuration of my AIX 5.3 server, root is forbidden to log in via SSH and SFTP. This is a pretty silly restriction since root is allowed to connect using Telnet and FTP clients. I worked around the problem by editing /etc/ssh/sshd_config and adding a comment to the beginning of the PermitRootLogin statement. The default value is PermitRootLogin yes. The new statement looks like this.
 
# PermitRootLogin without-password
 
2) I suggest you add the ezinstall bundles to /stage/middleware/RPMS.ppc. I tried to install bash using just the packages in this directory, but found it impossible to resolve all the dependencies. I followed the directions in README.txt from ftp://ftp.software.ibm.com/aix/freeSoftware/aixtoolbox, obtained the ezinstall/ppc/base bundle, ran rpm -Uvh ezinstall/ppc/base/* and everything installed with no problems.
 
3) I suggest you advertise that each virtual system supports the web-based system manager and help users download the remote client installer (just like you help with the Cisco VPN client). I discovered the web-based system manager by accident. Speaking as a user from a Linux shop, the web based system manager is much less painful than using smit or smitty to manage the system.

14 localhost commented Permalink

I agree that your observation that root can telnet and FTP but cannot SSH in is silly. I worry about pointing this out, since it might result in telnet and ftp being turned off by default.

 
I'll see about adding ezinstall bundles to /stage/middleware, although I have to admit that in VLP we put our energies into adding function to the VLP web and server-side applications as well as into fixing bugs. We don't put a lot of resources into supporting applications hosted on VLP. Other VLP users will find your instructions for locating the ezinstall bundle for bash very helpful though, and I thank you for those.

Add a Comment Add a Comment