Comentarios (13)

1 rgpr_pravin ha hecho un comentario el Enlace permanente

Loved this article... Good 'narration', better called this way"" - Thanks mate!

2 KhalidKhan ha hecho un comentario el Enlace permanente

Hello. Thanks for the article. It is well done.
I have aix server that I have upgraded from 5.3 to 6.1 TL7. I was able to do the remote display prior to the upgrade. I have followed your steps and still running into some issues. Same error "Can't open display: localhost:10".

 
Now I tried "localhost:0", tried 0.0. But no luck. Don't how to proceed with the troubleshooting.
I am running cygwin server and it comes up file on the icon tray.. It shows ":0.0".. and I am using putty and also configured that.. I tried setting the x display location and still no luck..
 
Any suggestion on what the issue can be??

3 UrbanBiel ha hecho un comentario el Enlace permanente

Thanks for the feedbak Khalid
I assume you use ssh X11 forwarding, so ssh must set up DISPLAY variable automaticaly. Do not change it manually
What is the whole message you get when you try to run an x11 app?
Is there any X11 related message you get after you log in?
If there is no firewall and NAT between you and the server (including a firewall on your workstation), do: export DISPLAY=<ip of="of" your="your" workstation="workstation">:0 and locally in your cygwin shell run DISPLAY=localhost:0 xhost +
Does the remote X11 works with a different aix?
install cygwin ssh if you don't have yet and try ssh -v -X <aix>, or try ssh -Y <aix>
during the aix migration, did openssh/openssl update too?
Let me know if it helped.</aix></aix></ip>

4 UrbanBiel ha hecho un comentario el Enlace permanente

Thanks for the feedbak Khalid
I assume you use ssh X11 forwarding, so ssh must set up DISPLAY variable automaticaly. Do not change it manually
What is the whole message you get when you try to run an x11 app?
Is there any X11 related message you get after you log in?
If there is no firewall and NAT between you and the server (including a firewall on your workstation), do: export DISPLAY=[ip of your workstation]:0 and locally in your cygwin shell run DISPLAY=localhost:0 xhost +
Does the remote X11 works with a different aix?
install cygwin ssh if you don't have yet and try ssh -v -X [aix], or try ssh -Y [aix]
during the aix migration, did openssh/openssl update too?
Let me know if it helped

5 KhalidKhan ha hecho un comentario el Enlace permanente


I assume you use ssh X11 forwarding, so ssh must set up DISPLAY variable automatically. Do not change it manually
Khalid: How do I set it automatically ?

 
Khalid:
What is the whole message you get when you try to run an x11 app?
On window's session.. This is what I do...
1.) Run cgywin x-server
2.) Run putty with x-forward enabled.
3.) In the putty session run...
export DISPLAY="localhost:0"
 
xclock
Error: Can't open display: localhost:0
 
xhost +
1356-200 xhost unable to open display "localhost:0"
 
Is there any X11 related message you get after you log in? No
 
Does the remote X11 works with a different aix? No
 
install cygwin ssh if you don't have yet and try ssh -v -X [aix], or try ssh -Y [aix]
Khalid: Don't have this....
 
during the aix migration, did openssh/openssl update too? I am pretty sure.. Since we went to
aix 5.3 to aix 6.1.. I am sure it was updated.. And x11forwarding is enabled in sshd_config.
 
 

6 UrbanBiel ha hecho un comentario el Enlace permanente

First of all, do not set the DISPLAY variable on login. ssh does this for you automatically, if your ssh X11 forwarding is set up correctly. By this I mean, that you have X11 forwarding option set on client (apparently you do) and X11 forwarding is enabled in sshd_config (apparently it is).
Remove export DISPLAY="localhost:0" on log in and try.

7 8XG2_ronald_jenei ha hecho un comentario el Enlace permanente

Thanks for this straightforward instructions!
Nevertheless, I have ran up against some troubles. I use Cygwin on Windows 7 and I have installed only packages you have listed - xorg-server xinit xauth xclock xterm xhost . I have set up my workstation and used SSH X11 port forwarding as described above. xclock and xterm worked fine.
When I tried to launch a graphical installation wizard (IBM CM 8.3), it crashed with:

 
"... The installer is unable to run in graphical mode...".
 
Apparently, I was missing some library packages. Installing the packages listed on following link resolved the problem despite the fact the link deals with different OS:
 
http://pic.dhe.ibm.com/infocenter/wchelp/v7r0m0/index.jsp?topic=%2Fcom.ibm.commerce.install.doc%2Frefs%2Frigprereqrhel61.htm

8 exec2020 ha hecho un comentario el Enlace permanente

All, I had some problems where the "DISPLAY" variable wasn't being set properly. The solution that worked for me is this: In the /etc/ssh/sshd_config, ensure the following is commented (yes, with a '#' in front):
#X11DisplayOffset 10
#X11UseLocalhost yes
#XauthLocation /usr/bin/X11/xauth

 
Of course, the following must be un-commented:
X11Forwarding yes
 
Restart sshd service:
stopsrc –s sshd; sleep 2; startsrc –s sshd
startsrc -s sshd

9 UrbanBiel ha hecho un comentario el Enlace permanente

Thanks for the comment exec2020
leaving the comment # character means, that you let ssh to take the default, which (if you don't alter it) is the same value that is commented. So there is no difference between
#X11DisplayOffset 10
and
X11DisplayOffset 10
If there is a difference in behavior, I'd suspect the version of ssh to be buggy.

10 inkpad ha hecho un comentario el Enlace permanente

A well written article. It has been a great help even to first time user of X windows.

11 ITM_Forum ha hecho un comentario el Enlace permanente

Great! Thank you

12 Leonidas_M ha hecho un comentario el Enlace permanente

Thank you for this artivle, i have spent last hours try to do it.....and the error was the X11Forwarding parameter .!!!
thank you again

13 Leonidas_M ha hecho un comentario el Enlace permanente

Thank you for this article, i have spent last hours try to do it.....and the error was the X11Forwarding parameter .!!!
thank you again