• Add a Comment
  • Edit
  • More Actions v
  • Quarantine this Entry

Comments (4)

1 Sachin_Nairy commented Permalink

Dear EduardoBello,
Information is very much useful. i created custom link by refering this articale, but if i put constrained as "trure" i am not able to see links in link tab. if i change constrained id as "false" i will visble.
is there is any dependency for constrained?
i used below code:

<extension point="com.ibm.team.repository.common.linkTypes">
<linkType constrained="false" id="com.ibm.team.workitem.linktype.ncbcr" internal="false">
<endpoint displayName="Project" icon="icons/ticket.gif" id="project" multiplicity="0..n">
<itemReferenceType itemTypeName="WorkItem" packageURI="com.ibm.team.workitem"></itemReferenceType>
<endpoint displayName="Change Request" icon="icons/enhancement.gif" id="changerequest" multiplicity="0..n">
<itemReferenceType itemTypeName="WorkItem" packageURI="com.ibm.team.workitem"></itemReferenceType>

2 jberry commented Permalink

First off, thank you for your series of blogs on RTC Customizations, they have been really helpful. I am attempting to create 2 new link types following your description above. I have encountered a couple of problems that I was hoping you could assist with. First off, when I was creating my Extension Point, I received a message saying “No schema found for the ‘com.ibm.team.repository.common.linkTypes’ extension point” and the “New-&gt;LinkTypes” option was not available. I tried determining why this might be, but couldn’t figure anything out. Since you showed how to manually edit the plugin.xml, I proceeded with that method. (I have sent my plugin.xml to you via email, in case it would be helpful) <div>&nbsp;</div> I created my feature and site then deployed them as described in your other blogs (I have successfully used these blogs to develop some Operation Advisors and Participants). I then restarted the server and connected to the Web interface for the server. I wanted to see that the new link type was there before I tried updating my Eclipse client. When I open a Work Item and go to links, I do not see my new link type in the list of available link types. Is there some other step needed to fully install the new link type? <div>&nbsp;</div> Thank you, <div>&nbsp;</div> Jamie Berry.

3 jberry commented Permalink

Hello. I have finally been able to successfully create some new custom linktypes. I am now trying to access the new linktypes via some Java code using the Plain Java Class Libraries. The calls to access the new linktypes are not recognizing my types. I am suspecting that I need to do something to make the PJCL aware of the new linktypes, but I haven't found anything documenting how to add new client extensions into the library paths so they can be used. Can you provide any direction for this? <div>&nbsp;</div> Thanks, <div>&nbsp;</div> Jamie Berry.

4 praveenpatidar commented Permalink

How do I see this link in the Link attribute add button. I have seen this link type in the presentation section of the Link attribute, I selected the Option but still it is not showing the link from presentation. Is there any workaround? <div>&nbsp;</div> Also DO I need to tell each and every developer to install this link that. Or once if I enable it from Project area it will automatically get reflected in all the clients? <br />

Add a Comment Add a Comment