Comments (10)
  • Add a Comment
  • Edit
  • More Actions v
  • Quarantine this Entry

1 localhost commented Permalink

I corrected the typo by changing "-dev" to "-vdev". Thank you!I tested this multiple times on my system, and cfgmgr found the new disk every time on the client.By chance are you using the "-dev" flag with mkvdev? That might explain the difference.mkvdev -vdev aix_client_lv -vadapter vhost1 [b]-dev [i]myVTD[/i][/b]

2 localhost commented Permalink

Sounds like you're doing it correctly. The only thing I can think of is that it's a bug. Are you using the same firmware, VIO and AIX levels? My understanding is that this procedure may not work with earlier versions.

3 localhost commented Permalink

From my first comment...VIOS;; AIX 5.3 ML03Model; 9113-550Firmware; SF235_160The "problem" was first identified by me on September 5th - and since then I applied every fix / firmware update available - to no avail so far.The actual AIX level is all of the latest fixes available from suma[code]# oslevel -r5300-03# oslevel -r -g 5300-03Fileset Actual Level Recommended ML-----------------------------------------------------------------------------Java14.sdk[/code]

4 localhost commented Permalink

Couple of issues here. The short answer is to please make certain that the max transfer size on the replacement disk is at least as large as the max transfer on the disk being replaced. The max transfer on a physical disk is the minimum of the max transfer of the disk itself and that max transfer of the adapter to which that disk is attached. For MPIO disks, it is also the minimum of all the adapters providing paths to the physical disk.The VIOC calculates the max transfer size for a host adapter as devices are added to that adapter, and reports that max transfer size to the client when the client adapter is configured. If a device is added to a host adapter that has a smaller max transfer than the one the host adapter reported to the client, the host adapter does not let that new device become visible to the client until that client adapter has been unconfigured and reconfigured, which causes the new, smaller, max transfer size to be reported to the client.That error log ID C972F43B decodes to mean that the client has sent the server a transaction that is larger than the max transfer size currently in force for that virtual host adapter.

5 localhost commented Permalink

The replacement "disk" is an LV of the same size as the "failed disk" (and has been on the same VG, and also on a different VG).I have been using the same virtual host adapter.Therefore I would expect the "max transfer size" to be exactly the same ?How can I check the "max transfer size" ?

6 localhost commented Permalink

Today, I was unable to reproduce the problem.This was because I had multiple backing devices attached to each virtual adapter. Further investigation shows that the problem occurs if all of the following are true;- the final backing device / vtscsiX is removed from the virtual adapter- a new backing device is added to the virtual adapter after it has been "emptied"- the error then occurs when the virtual client attempts to use the new virtual diskCan someone try this procedure, with the above conditions being true and confirm whether or not it works... on my machine, provided the above conditions are true, the problem occurs EVERY time.

7 localhost commented Permalink

Part of the problem described is now solved... if the final virtual target is removed from virtual scsi adapter on the VIOS, then the max_xfer_size value is reduced to a value below the size required by "AIX LV disks" - this is what causes the misbehaved SCSI client error.This problem is solved by IY79400 (devices.vdevice.IBM.v-scsi-host.rte. and devices.vtdev.scsi.rte. being applied to the VIOS at level (and I hope these will be included in the next fixpack which is due shortly).I still have one outstanding problem with this "method", as when I "fail" a virtual disk at the VIOS level, and replace it with another (same size) LV and re-map this, I do not see the new disk until I rmdev the old one - this is being investigated, and I'll provide more info when it is available.

8 localhost commented Permalink

We would like to inquire about quorums and mirroring.<div>&nbsp;</div> 1. Is mirroring an option? If we want an efficient system, do we have to have to mirrored environment? I am aware that doing so would be costly.<div>&nbsp;</div> 2. If initially there was a quorum, and then there was none. How and when do we know there is no quorum?<div>&nbsp;</div> Thanks a lot for your help.

9 localhost commented Permalink

i have a sony vio that shows return code ... 0 when you turn it on. does anyone have a suggestion. I have lost my reinstall disk.