Comments (2)

1 vk1974 commented Permalink

When I do:

 
set enable_zmap_debug=1 in nzsql
 
and after the query is complete, I do not see any data in the following views.
 
_vt_zmap_event
_vt_zmap_flush_detail
_vt_zmap_scan_detail
 
What could be the reason?
 
Thanks,

2 vinoy commented Permalink

Hi vk1974,
You will need to enable the corresponding virtual table before doing these operations.

 
You can enable a virtual table with the "cliqa" command present in /nz/kit/bin/adm dir. Please note that use of "cliqa" is discouraged by IBM (please refer http://www-01.ibm.com/support/knowledgecenter/SSULQD_7.1.0/com.ibm.nz.adm.doc/r_sysadm_cs_tshoot_cmds.html).
 
I would recommend that you run the following "cliqa" command on a test system first before trying it on a production system.
cliqa -vt _vt_zmap_scan_detail on;
Thereafter run the "set enable..." command through nzsql. After running your query, you should see the entries in the _vt_zmap_scan_detail table.
 
Similarly, you can enable the other virtual tables (_vt_zmap_event and _vt_zmap_event) using cliqa and get more details from these tables.
 
Remember to switch off the virtual tables at the end of your exercise.
cliqa -vt _vt_zmap_scan_detail off;
 
Thanks
Vinoy

Add a Comment Add a Comment