Comments (19)
  • Add a Comment
  • Edit
  • More Actions v
  • Quarantine this Entry

1 psczrxb commented Permalink

I've tried this with the link in IBM Installation Manager and receive a message that the MQ Explorer repository is not connected. All other repositories are connected including but no MQ Explorer available. How would I report this issue?

2 JoeWinchester commented Permalink

Hi - thanks for your comment - the MQ Explorer update site does not work with IBM Installation Manager - you need to use the Help -> Install New Software option and follow the screens above.
There are - for historic reasons - two different ways to install software - p2 (which is the one the Eclipse community uses) and Installation Manager which a lot of IBM products use. MQ Explorer is only available through p2.
I hope this helps - let us know if you think this is unacceptable and you think IBM should provide an Installation Manager module for MQ Explorer - or else let us know if you're OK with using the p2 install mechanism from the Eclipse help menu. Tks - Joe

3 OFWHMG commented Permalink

I added MQ Explorer to z/OS Explorer V2.1 installed with IM and to RDz V9 via the P2 site in your blog and everything was fine. Later I installed new AD/PD Tools plug-ins via IM and my MQ Explorer perspective was filled with red circles saying the various views could not be created. I tried to uninstall and reinstall MQ explorer via the P2 site and now I cannot see MQ Explorer in the Window>Open Perspective>Other window.

Is anyone aware of this problem. It would seem to me I need an IM way to install the MQ Explorer. Mixing IM and P2 installs does not seem to work.

4 JoeWinchester commented Permalink

Hi Bill - that shouldn't have happened to get your workspace broken the way it did. We'll try to take a look and see if we can create it here, in the meantime does it help if you start with a new workspace ? Would it be possible for you to get the service data and e-mail it to us to take a look at ? Tks and apologies, Joe

5 DaveN commented Permalink

@Bill - also, it would be great to be clear about where you installed MQ Explorer - into z/OS Explorer? Into RD/z? Which AD/PD tools did you install?

Anything to reduce the trial and error in us reproducing here would be ace :-)

6 OFWHMG commented Permalink

I installed MQ Explorer in both z/OS Explorer V2.1 AND RDz V9. Both via the P2 method. When I installed the File Manager, Fault Analyzer and Debug Tool plug-ins inot both I broke the MQ Explorer. I tried a new workspace and the -clean start option and neither had any effect. I tried to get Dave's email address but was unsuccessful. If you could provide an email address and clarify what you mean by "service data" (do you mean Trace zip file?) I will get that information to you right away. Thank you.

7 OFWHMG commented Permalink

I installed the V12.1.1.04 Fault Analyzer plug-in into RDz V9 via the combined Plug-in zip file. I installed the V12.1.1.03 version of all three plugins via IM into z/OS Explorer v2.1.

8 OFWHMG commented Permalink

Just to be clear the sequence of events was 1) installed RDz V9 and z/OS Explorer v2.1 2) installed MQ Explorer via P2 method into both 3) Installed AD/PD plug-ins into both 4) MQ Explorer now broke in both.

9 DaveN commented Permalink


We're just having another go at recreating because our first attempt didn't cause an error. Did you manage to recreate multiple times, or was it a one off?
To reduce the number of permutations that we have to test before recreating, can you help me understand the sequence a bit better, please?
1) Install RD/z v9
2) Install z/OS Explorer v2.1
----> which did you install first? Did you install into the same package group, or separate
3) Install MQ Explorer separately into each install
4) Install the set of PD tools you detailed from their zip file, using Installation Manager (not p2)
-----> It is not clear from your comment whether you installed or

10 DaveN commented Permalink

Apologies for the broken formatting. What a pain, and no editing facility. Goodness knows how to get it to look right :-/

11 OFWHMG commented Permalink

Sorry for the confusion. The z/OS V2.1 install was totally separate from the RDz V9 install. They were in separate package groups. I just mentioned it because the same problem occurred with MQ Explorer in both. So once again I 1) installed z/OS V2.1 and RDz V9 via IM in separate package groups. I 2) installed MQ Explorer into both via the p2 method with the URL in Joe's blog. I 3) installed the PD/AD Tools plug-ins V12.1.1.04 into RDz via the combined zip file and into z/OS Explorer V2.1 via the consolidated software URL.

It is the sequence of IM install, P2 install of MQ Explorer, and then some IM updates that seems to break MQ Explorer. I hope this helps. Thank you.

12 DaveN commented Permalink

Hi there. We tried recreating like you suggested but installing other plugins (via IM) on top of MQ Explorer (via p2) doesn't cause any problems. Are you able to recreate the problem repeatably? Dave

13 OFWHMG commented Permalink

Dave, It would be difficult for me to recreate the problem but maybe you could explain my present predicament. I have MQ Explorer inistalled via P2 into a IM z/OS Explorer installation but I don't have the MQ Explorer in Window>Open Perspective>other. I have uninstalled and re installed MQ Explorer via the P2 site in the beginning of Joe's blog twice now but nothing makes the MQ Explorer perspective available.

Any thoughts?

14 DaveN commented Permalink

Hey, This kind of remote debugging is the worst kind...! And replying on here is hard without a working enter key......... Debugging the use of p2 within Installation Manager is a bit more challenging, but I would start by checking what p2 thinks is installed. Do Help > About, Installation Details. Look in Insatlled Sfotware, Installation History for clues as to whether it thinks the MQ plugins are installed. Then check under Features and Plug-ins which should show the set of featuers and plug-ins that are ENABLED in the environment. You could start with the OSGi console (have a google for syntax) to see whether the plug-ins are started or not. Let me know what happens!

15 DaveN commented Permalink

ps might be easier to move the discussion to our forum at if you need more help. That way we can format responses more effectively, and I'll actually get notified about your replies :-)