Comentarios (2)

1 TaoFineberg ha hecho un comentario el Enlace permanente

Hi
I have been trying to use node red just the way you have above.
My problem is that I don't get the "OK" as the first part of the message. How do you add that to the TX signal on the emonTH or emonTX

 
Kind Regards
 
Tao

2 BRAMLEYD ha hecho un comentario el Enlace permanente

Hi Tao,

 
The Jeelink should pass through "OK" at the start of each message that it successfully receives on the group it is listening too. The network Group is important if the Jeelink is listening on a different network group to the emonTH then you will still see messages but they will be prefixed with a "?"
 
By default the emonTH uses group 210 (or at least it was when I last tried it). You can change the settings of the Jeelink by using a terminal to connect to it's serial port. The command help will be listed once you connect.
 
If the group is definitely correct then the bad messages could be a result of interference or perhaps incorrect baud rate set in Node Red.
 
Cheers
 
Dom