Comments (18)
  • Add a Comment
  • Edit
  • More Actions v
  • Quarantine this Entry

1 MrShanks commented Permalink

Our oslevel -s indicates 6100-04-02-1007 (TL4, SP2) yet the loopmount command is not in the /usr/sbin folder and therefore not available. <div>&nbsp;</div> Tried to find it on our source install on our NIM server. Couldn't find it. Maybe we forgot to select it during the install, but it's weird smitty install can't find it.

2 oczkov commented Permalink

The loopmount file is part of the devices.loopback.rte fileset. Just install it an you will have an access to the /usr/sbin/loopmount and /usr/sbin/loopumount binaries. <div>&nbsp;</div> Regards, <br /> Oczkov

3 AnthonyEnglish commented Permalink

Thanks, Oczkov. <div>&nbsp;</div> This link may also be helpful in giving some background on loopmount, but the VIO Server VM Library seems to be a good deal easier to use. <div>&nbsp;</div> http://publib.boulder.ibm.com/infocenter/aix/v6r1/index.jsp?topic=/com.ibm.aix.baseadmn/doc/baseadmndita/loopback_main.htm

4 ThinkOpenly commented Permalink

You glossed over the one step I haven't figured out yet. "Once you've copied the ISO image into the VM Library..." How does one do that from the IVM command line?

5 AnthonyEnglish commented Permalink

Via the command line, I use ftp or scp, logging in as padmin and copying the ISO file either directly into /var/vio/VMLibrary or into /home/padmin. If you do it the second (official) way, you need to use the mkvopt command to load it into the library, and then clean up the original file. <div>&nbsp;</div> Through the IVM GUI: <br /> Virtual Storage Management <br /> View/Modify Virtual Storage <br /> Add Media <div>&nbsp;</div> This allows you to Upload media with a Browse button, or Add existing file from a VIOS directory such as /home/padmin. Both options let you specify the file to be Read only, which allows you to share it to multiple virtual optical devices at the same time. <div>&nbsp;</div> To change permissions from read-write to read-only, you can use the chvopt command. This also lets you rename the file. <div>&nbsp;</div> More details about the IVM GUI and optical devices from here http://bit.ly/17kPfy <div>&nbsp;</div> For the HMC GUI, select Server &gt; Configuration &gt; Virtual Storage Management

6 ThinkOpenly commented Permalink

Interesting that you mentioned "I use ftp or scp, logging in as padmin and copying the ISO file either directly into /var/vio/VMLibrary". I found that directory, and was hoping to be able to use it to be able to copy files directly into the library, but I did not have permission: <br /> $ scp user@fileserver:file /var/vio/VMLibrary/. <br /> The authenticity of host 'fileserver' can't be established.[...] <br /> Failed to add the host to the list of known hosts (/home/padmin/.ssh/known_hosts). <br /> user@fileserver's password: <br /> /var/vio/VMLibrary/./file: Permission denied <br /> $ ls -ald /var/vio/VMLibrary <br /> drwxr-xr-x 3 root system 256 Feb 16 18:35 /var/vio/VMLibrary <br /> ...oddly, it can't even store to the "known_hosts" file. It seems padmin is also running in a restricted shell.

7 AnthonyEnglish commented Permalink

Now I realise how much I've been cheating. If you log in as padmin (via ssh or telnet if it's permitted), you can go to the full root shell using oem_setup_env and then set the permissions on /var/vio/VMLibrary directory to owner "padmin" with write permission. <div>&nbsp;</div> chown padmin /var/vio/VMLibrary <div>&nbsp;</div> From that point you should be able to ftp as padmin (no need to switch to root). Even though it's the restricted shell, ftp or scp should allow you to copy into it. <div>&nbsp;</div> The official way is to copy into /home/padmin as the user padmin and then use the restricted shell command mkvopt to copy your file into the VM Library.

8 KarlM commented Permalink

Just for laughs you might like to try: <br /> loopmount -i cdrom.iso -o "-o ro" -m /mnt <br /> and watch your system crash with a Data Storage Interrupt!

9 AnthonyEnglish commented Permalink

Karl, I have seen that loopmount crash once before. In AIX 6100-04 from memory. I wonder if it is a bug which has been fixed in later Technology Levels.

10 KarlM commented Permalink

I raised a PMR on the DSI crash and found there is no fix yet. Here is some info from the PMR that might be of interest: <br /> I think what is going on is that loopmount <br /> command has just issued a mount command, but because the <br /> -V cdrfs option was not specified, the mount is trying to <br /> do a default JFS2 mount. <br /> The cdrfs file system mount does not read the superblock <br /> so if the -V cdrfs option is specified, we will not do <br /> the rawRead and not call the rawIODone function. But <br /> loopmount also allows a mount of a JFS2 file system, for <br /> which this should also crash. <br /> Tested with a Storage Keys enabled test system and <br /> loopmount -i j2image -o "-V jfs2 -o ro" -m /mnt <br /> (where j2image is a file containing a JFS2 file system <br /> image) crashed the system. <br /> The only work- <br /> around for this problem is to disable the hardware <br /> storage keys on the system. Of course you should not <br /> crash if you do use the correct options on the loopmount <br /> command. Observe, however, that I was able to crash the <br /> system by doing the command: <br /> loopmount -i j2image -o "-V jfs2 -o ro" -m /mnt <br /> where j2image was a valid image of a JFS2 file system. <br /> So try to avoid that use as well. <div>&nbsp;</div> From the above I'd say try any loopmount on a test system first!