Comments (1)
  • Add a Comment
  • Edit
  • More Actions v
  • Quarantine this Entry

1 MikeCoble commented Permalink

Thanks for the post! I was trying to load up the Madison Store Hybrid app from feature pack 4 of WCS and had a Sun certificate error "Errors occurred during the build. Errors running builder 'Android Package Builder' on project 'MadisonStore'. sun.security.x509.X500Name." It all made sense after your explanation that "The Android SDK requires a Sun-specific JCE provider in order to add the digital signature to the .apk during the build." <div>&nbsp;</div> One thing is that I think your eclipse.ini settings are for the linux IDE. For those of us developing on Windows, the --launcher.library is a different file. Below is the modified setting that I used for my Windows installation. <div>&nbsp;</div> -startup <br /> plugins/org.eclipse.equinox.launcher_1.1.1.R36x_v20101122_1400.jar <br /> --launcher.library <br /> plugins/org.eclipse.equinox.launcher.win32.win32.x86_1.1.2.R36x_v20101222 <br /> -showsplash <br /> org.eclipse.platform <br /> --launcher.XXMaxPermSize <br /> 256m <br /> --launcher.defaultAction <br /> openFile <br /> -vmargs <br /> -Dosgi.requiredJavaVersion=1.6 <br /> -Xms40m <br /> -Xmx1024m <br />