Comments (7)
  • Add a Comment
  • Edit
  • More Actions v
  • Quarantine this Entry

1 Gondim commented Permalink

Opa grande :) <div>&nbsp;</div> Gostei do 2.6.38 em relação à acesso inetensivo à base de dados que elevava o load em alguns raros momentos à picos de 50.0 e com o 2.6.38 o máximo foi à 4.0. Mas com relação à tráfego de rede achei que não ficou bom. Nós aqui temos um tráfego de 130Mbps com a Internet, com link total de 200Mbps e percebi que o ksoftirq nos processarores chegava à 90% me gerando problemas de perda nos pacotes e momentos de lentidão. Já com o kernel 2.6.32 isso não ocorre. Torço para que melhorem isso. :)

2 PabloHess commented Permalink

Gondim, você simplesmente usou o .config do 2.6.32 e deu um 'make'? Ou você usou o 'make oldconfig' no meio do caminho? <div>&nbsp;</div> Se foi sem 'make oldconfig', experimente usá-lo desta vez. E se você usou o 'make oldconfig'... Bem, isto requer mais testes. :-) <div>&nbsp;</div> Fique à vontade para avisar quando tiver algum avanço!

3 Gondim commented Permalink

Opa Pablo, <div>&nbsp;</div> Eu não usei o método tradicional, eu copiei o config do /boot para o .config, fiz o make menuconfig, dei uma revisada, saí salvando e usei o make-kpkg do Debian que já me gera um .deb do kernel compilado, mas posso tentar usando o método tradicional. <div>&nbsp;</div> O estranho é que fazendo um: watch -n0 cat /proc/interrupts percebo que está havendo uso da interface de rede balanceando nas 4 CPUs, mas do nada começa uma lentidão na console e no top começam à aparecer processos do ksoftirq lá nas alturas com 90% e as vezes até mais justamente referente às CPUs que estão com tráfego alto nas interfaces de entrada e saída da Internet. <div>&nbsp;</div> Achei muito esquisito mesmo e aí tive que voltar para o kernel 2.6.32. Vou fazer o método tradicional e depois posto. Mas valeu a atenção aí :)

4 Gondim commented Permalink

Estou fazendo da seguinte forma agora :) aí mais tarde vou fazer o teste: <div>&nbsp;</div> 1) copiei o config do 2.6.32 <br /> 2) fiz o make oldconfig setando as novas options com o default N <br /> 3) fiz o make menuconfig e setei o que precisava <br /> 4) make-kpkg clean &amp;&amp; make-kpkg --initrd --revision=mg.1.0 kernel_image <div>&nbsp;</div> :) vamos ver se vai ficar legal. Mas valeu pela lembrança do oldconfig hahah não lembrava mais dele fazia um certo tempo porque sempre compilava o kernel da própria distro e aí não precisava.

5 Gondim commented Permalink

Same problem :( <div>&nbsp;</div> Vou dar uma esperada pode ser que saia algum patch corrigindo isso. <div>&nbsp;</div> Grande abraço e parabens mais uma vez pelo belíssimo trabalho deste log.

6 Kelbel commented Permalink

Gondim, sabe se está questão de rede foi solucionada? <br /> Pois trabalho com uma aplicação que utiliza bastante recursos de rede e I/O e precisarei atualizar devido a certos bugs no gerenciamento de I/O... porém não posso ficar na mão com este gargalo de rede.

7 PabloHess commented Permalink

Gondim, se o problema é excesso de interrupções, confira o recurso de "interrupt coalescing". <div>&nbsp;</div> Ele permite definir um limite máximo de interrupções geradas pela interface de rede. Passado esse limite, a interface deixa de gerar uma interrupção a cada pacote recebido e passa a gerá-la a cada "x" milissegundos, passando diversos pacotes ao kernel de uma só vez. <div>&nbsp;</div> Sei que alguns modelos da Intel oferecem suporte a este recurso.