En vedette

Produit du code PL/I qui fonctionne sur tous les niveaux d'AIX

Le compilateur maximise les intergiciels en donnant accès aux systèmes IBM DB2 et IBM TXSeries. Il intègre aussi SQL, IBM CICS et les préprocesseurs, de même que la fonction macro PL/I. Vous pouvez maintenant utiliser le compilateur pour produire du code PL/I qui fonctionne sur tous les niveaux de matériel AIX, y compris les Power Systems.

Interopérabilité accrue avec Java et XML

Le compilateur offre de la souplesse et du contrôle sur le type de documents XML qui sont générés. De plus, il permet aux programmes PL/I et Java d'interopérer en se fondant sur l'interface Java native. Vous pouvez maintenant vous servir du compilateur pour utiliser des messages de programme XML entrants et transformer les contenus en structures de données PL/I en tirant parti de l'interpréteur XML à grande vitesse.

Capacités de débogage étendues

Le compilateur produit de l'information de débogage symbolique, qui peut être lue par n'importe quel débogueur AIX standard. Vous pouvez surveiller les variables, les registres, la mémoire, les piles d'appels et d'autres éléments. En outre, vous pouvez maintenant déboguer des applications écrites en C, C++, COBOL et PL/I à partir de votre poste de travail.

Amélioration de la compatibilité des applications avec PL/I for z/OS

Le compilateur fournit des utilitaires de compatibilité avec le code source et de gestion de données, ce qui permet de diminuer les obstacles et de réduire au minimum les risques de portage à partir d'autres mises en œuvre PL/I.

Renseignements techniques

Exigences logicielles

IBM PL/I for AIX V3.1 fonctionne conjointement avec les versions prises en charge des programmes suivants et leurs versions ultérieures ou l'équivalent. Pour plus d'information sur les programmes énumérés qui requièrent des modifications provisoires du logiciel (PTF), reportez-vous au guide d'installation.

    Exigences matérielles

    IBM PL/I for AIX V3.1 et les programmes objets générés peuvent être exécutés sur tous les processeurs pris en charge par :

    • AIX V5.3.9.0 ou version supérieure
    • AIX V6.1.0.0 ou version supérieure
    • AIX V7.0 avec les PTF les plus récents

    Autres produits susceptibles de vous intéresser

    IBM COBOL for AIX

    Intégrez les applications COBOL avec services Web, XML et Java

    En savoir plus

    IBM XL C/C++ for AIX

    Compilateur pour créer et maintenir des applications C/C++ pour IBM Power Systems.

    En savoir plus