Feature spotlights

Support for open source runtimes and frameworks

IBM® Support for Runtimes provides service and support for Java, Swift and Node.js customers. When customers request support that results in a code change, the appropriate community will be involved by the IBM team. Where a code change is needed, IBM will develop the fix and contribute to the owning community under their normal contributor process.

Supported Java versions

The two most recent Java versions will be supported while they remain in support by the Eclipse OpenJ9 community: OpenJDK V9 with Eclipse OpenJ9 until mid-2018 (V8 LTS until 2025), OpenJDK V18.03 with Eclipse OpenJ9 until mid-2018 (V18.09 LTS starting in mid-2018). The following platforms are supported: RHEL, SLES and Ubuntu distributions running on x86-64, IBM 64 bit Power Systems™ (in Little Endian architecture format for use on IBM POWER® 8) or IBM 64 bit z Systems® (including IBM LinuxONE™).

Supported Swift versions

The Swift compiler and runtime will be supported when run via binaries acquired from the Swift download page. Kitura framework and Kitura Homebrew tap and Application Metrics for Swift (SwiftMetrics) are supported. Swift V4 will be supported while it remains in support by the Swift community. Ubuntu V14.04 LTS and Ubuntu 16.04 LTS for x86-64 platforms are supported.

Supported Node.js versions

The two most recent Node.js long-term service (LTS) versions will be supported—Node.js V6 until mid-2019 and Node.js V8 until the end of 2019. Node.js modules are supported at the latest level. In addition, the following platforms are supported: RHEL, SLES and Ubuntu distributions running on x86-64, IBM 64 bit Power Systems (in Little Endian architecture format for use on IBM POWER 8) or IBM 64 bit z Systems (including IBM LinuxONE).