Medium Severity

IBM Security Bulletin: Vulnerability in OpenSSL affects AIX (CVE-2019-1559) Security Bulletin

Share this post:

There is a vulnerability in OpenSSL used by AIX.

CVE(s): CVE-2019-1559

Affected product(s) and affected version(s):
AIX 7.1, 7.2
VIOS 2.2.x
The following fileset levels are vulnerable:

key_fileset = osrcaix Fileset Lower Level Upper Level KEY
——————————————————
openssl.base 1.0.2.500 1.0.2.1601 key_w_fs
openssl.base 20.13.102.1000 20.16.102.1600 key_w_fs
Note:
A. 0.9.8, 1.0.1 OpenSSL versions are out-of-support. Customers are advised to upgrade to currently supported OpenSSL 1.0.2 version. B. Latest level of OpenSSL fileset is available from the web download site:
https://www-01.ibm.com/marketing/iwm/iwm/web/pickUrxNew.do?source=aixbp&S_PKG=openssl

To find out whether the affected filesets are installed on your systems, refer to the lslpp command found in the AIX user’s guide.
Example: lslpp -L | grep -i openssl.base

Refer to the following reference URLs for remediation and additional vulnerability details:
Source Bulletin: https://www-01.ibm.com/support/docview.wss?uid=ibm10878172
X-Force Database: https://exchange.xforce.ibmcloud.com/vulnerabilities/157514

More stories

IBM Security Bulletin: Password exposure via job log in IBM Spectrum Protect Plus (CVE-2019-4385)

Jun 18, 2019 9:02 am EDT | Medium Severity

IBM Spectrum Protect Plus may display the vSNAP CIFS password in the Spectrum Protect Plus job log CVE(s): CVE-2019-4385 Affected product(s) and affected version(s):IBM Spectrum Protect Plus 10.1.2.219 through 10.1.2.303. Refer to the following reference URLs for remediation and additional vulnerability details:Source Bulletin: http://www.ibm.com/support/docview.wss?uid=ibm10886099X-Force Database: https://exchange.xforce.ibmcloud.com/vulnerabilities/162173 ...read more


IBM Security Bulletin: IBM Maximo Asset Management is vulnerable to CSV Injection (CVE-2019-4364)

Jun 18, 2019 9:01 am EDT | Medium Severity

IBM Maximo Asset Management is vulnerable to CSV injection, which could allow a remote authenticated attacker to execute arbirary commands on the system. CVE(s): CVE-2019-4364 Affected product(s) and affected version(s): This vulnerability affects the following versions of the IBM Maximo Asset Management core product, and all other IBM Maximo Industry Solution and IBM Control Desk ...read more


IBM Security Bulletin: IBM Maximo Asset Management is vulnerable to cross-site scripting (CVE-2019-4303)

Jun 18, 2019 9:01 am EDT | Medium Severity

IBM Maximo Asset Management is vulnerable to cross-site scripting. This vulnerability allows users to embed arbitrary JavaScript code in the Web UI thus altering the intended functionality potentially leading to credentials disclosure within a trusted session. CVE(s): CVE-2019-4303 Affected product(s) and affected version(s): This vulnerability affects the following versions of the IBM Maximo Asset Management ...read more