Medium Severity

IBM Security Bulletin: Vulnerability in Apache Batik affects IBM Maximo Asset Management (CVE-2017-5662)

Share this post:

Apache Batik used by IBM Maximo Asset Management could allow a remote authenticated attacker to obtain sensitive information, caused by an XML external entity (XXE) error when processing XML data. By using a specially-crafted SVG file, a remote attacker could exploit this vulnerability to obtain sensitive information or possibly cause a denial of service.

CVE(s): CVE-2017-5662

Affected product(s) and affected version(s):

The following Apache Batik versions are affected:

  • Apache Batik 1.8 and earlier releases

IBM supplied Apache Batik with the following:

The 7.5.0.x and 7.6.0.x versions of Maximo Asset Management bundled Apache Batik 1,8.

This vulnerability affects the following versions of the IBM Maximo Asset Management core product, and all other IBM Maximo Industry Solution and IBM Control Desk products, regardless of their own version, if they are currently installed on top of an affected IBM Maximo Asset Management. *

Maximo Asset Management core product affected versions:
Maximo Asset Management 7.6, 7.5
Maximo Asset Management Essentials 7.5

Industry Solutions products affected if using an affected core version:
Maximo for Aviation
Maximo for Government
Maximo for Life Sciences
Maximo for Nuclear Power
Maximo for Oil and Gas
Maximo for Transportation
Maximo for Utilities

IBM Control Desk products affected if using an affected core version:
SmartCloud Control Desk
IBM Control Desk
Tivoli Integration Composer

* To determine the core product version, log in and view System Information. The core product version is the “Tivoli’s process automation engine” version. Please consult the Product Coexistence Matrix for a list of supported product combinations.

Refer to the following reference URLs for remediation and additional vulnerability details:
Source Bulletin: http://www.ibm.com/support/docview.wss?uid=swg22008816
X-Force Database: https://exchange.xforce.ibmcloud.com/vulnerabilities/125198

More stories

Security Bulletin: IBM® Db2® is vulnerable to an information disclosure (CVE-2021-20579)

Aug 4, 2021 8:42 pm EDT | Medium Severity

IBM® Db2® is vulnerable to an information disclosure as it could allow a user who can create a view or inline SQL function to obtain sensitive information when AUTO_REVAL is set to DEFFERED_FORCE. ...read more


Security Bulletin: IBM Security Privileged Identity Manager is affected by security vulnerabilities (CVE-2019-12450)

Aug 4, 2021 8:28 pm EDT | Medium Severity

IBM Security Privileged Identity Manager has addressed an issue for glib2 as follows. ...read more


Security Bulletin: IBM Security Privileged Identity Manager is affected by vulnerability in IBM SDK, Java Technology Edition Quarterly CPU – Oct 2020

Aug 4, 2021 8:26 pm EDT | Medium Severity

IBM Security Privileged Identity Manager has addressed several vulnerabilities in Java SE. ...read more