IBM Support

How to remove Override option for credit card authorization failure in Sterling Order Management

Question & Answer


Question

How do you remove Override and Continue option for authorization failure for credit card in IBM Sterling Order Management?

Cause

You do not want Customer Service Representative (CSR) to confirm order if the credit card authorization fails.

Answer

In order creation flow, clicking Confirm Payment button sends a credit card authorization request to the respective payment gateway. If the authorization for any payment method fails, an appropriate error message is displayed and the failed payment method is displayed in red. Customer Service Representative (CSR) is given an option to override and continue this authorization failure.

To disallow order creation in this scenario, make the Override and Continue check box permission driven by following the steps below:

  1. Set up the new resource and grant/revoke permission to the resource for the users as required.
    Refer the Create New Resource and Administering user group permissions section in product documentation for more details on how to perform these tasks.

  2. In your custom code, include a logic which checks if the user has permission to this resource or not. In case the permission is granted then enable the override checkbox and vice versa.

[{"Product":{"code":"SS6PEW","label":"IBM Sterling Order Management"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Sterling Call Center","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF010","label":"HP-UX"},{"code":"PF016","label":"Linux"},{"code":"PF034","label":"Windows Mobile"},{"code":"PF027","label":"Solaris"},{"code":"PF033","label":"Windows"}],"Version":"9.0;9.1;9.2;9.2.1","Edition":"","Line of Business":{"code":"LOB59","label":"Sustainability Software"}}]

Document Information

Modified date:
10 May 2022

UID

swg21664902