IBM® InfoSphere DataStage Error: Job xxx is being accessed by another user
A job can be accessed only by one user at a time.
Symptoms
You are unable to view a job, and receive the following
error message.
Error: Job xxx is being accessed by another user
Causes
The job that you are trying to view is accessed by another user.
Resolving the problem
Perform the following actions:
- Check the active sessions with the web console. If the job is listed, disconnect the session. In the web console, click the Administration tab. In the Navigation pane, select Session Management > Active Sessions. The Active Sessions pane shows the users that are currently connected to the server.
- Check for universe locks and clear them.
- Start the DataStage Director
- Go to Select Job > Cleanup Resources. If the Cleanup Resources option is disabled, skip to step i, where you start the DataStage Administrator client.
- In the Processes pane, click Show All
- In the Locks pane, click Show All
- In the Locks pane, scroll to the job name in the Item ID field
- Note the PID/User # associated with the job
- Click the PID # in the upper pane (Processes)
- Click Show by process (Locks pane)
- Start the DataStage Administrator
- In the Projects tab, highlight the job
- Click Properties
- Check Enable job administration in Director
- Click OK
- Click close
- Exit DataStage Director and relaunch
- Repeat steps C through I.
- Log in to the server as the dsadm user
- cd to the DSEngine directory
- Enter ./dsenv to source the dsenv file
- Enter ./bin/uvsh to get into DataStage prompt
- At ">" DataStage engine prompt, enter LOGTO project name
- Run LIST.READU EVERY to list all the locks
- Check active record locks under "Item Id" column for job name or RT_CONFIG# or RT_LOG# (# matches the job description number
- Write down the Inode numbers and user numbers that are associated with these locks
- Enter LOGTO UV. If the LOGTO command is disabled, enter the following
command:
The UNLOCK command lives in the UV account.CHDIR path_to_the_DSEngine_folder
- Enter UNLOCK INODE inode# USER user# ALL
- You can use Q to get out of DataStage engine
- Use the xmetaAdmin cleanupAbandonedLocks utility
to clear any abandoned locks. The xmetaAdmin cleanupAbandonedLocks utility
deletes session locks from the Information Server repository that
were left over from some usage of an Information Server suite application
such as DataStage. Log in to the services tier as the root user on
UNIX or Linux or as an Administrator user on Windows.On UNIX or Linux:
cd /opt/IBM/InformationServer/ASBServer/bin ./xmetaAdmin.sh cleanupAbandonedLocks -dbfile ../conf/database.properties
On Windows:cd c:\IBM\InformationServer\ASBServer\bin xmetaAdmin.bat cleanupAbandonedLocks -dbfile ..\conf\database.properties