IBM® InfoSphere DataStage Error: Job xxx is being accessed by another user

A job can be accessed only by one user at a time.

Symptoms

You are unable to view a job, and receive the following error message.
Error: Job xxx is being accessed by another user

Causes

The job that you are trying to view is accessed by another user.

Resolving the problem

Perform the following actions:

  1. Check the active sessions with the web console. If the job is listed, disconnect the session. In the web console, click the Administration tab. In the Navigation pane, select Session Management > Active Sessions. The Active Sessions pane shows the users that are currently connected to the server.
  2. Check for universe locks and clear them.
    1. Start the DataStage Director
    2. Go to Select Job > Cleanup Resources. If the Cleanup Resources option is disabled, skip to step i, where you start the DataStage Administrator client.
    3. In the Processes pane, click Show All
    4. In the Locks pane, click Show All
    5. In the Locks pane, scroll to the job name in the Item ID field
    6. Note the PID/User # associated with the job
    7. Click the PID # in the upper pane (Processes)
    8. Click Show by process (Locks pane)
    9. Start the DataStage Administrator
    10. In the Projects tab, highlight the job
    11. Click Properties
    12. Check Enable job administration in Director
    13. Click OK
    14. Click close
    15. Exit DataStage Director and relaunch
    16. Repeat steps C through I.
    17. Log in to the server as the dsadm user
    18. cd to the DSEngine directory
    19. Enter ./dsenv to source the dsenv file
    20. Enter ./bin/uvsh to get into DataStage prompt
    21. At ">" DataStage engine prompt, enter LOGTO project name
    22. Run LIST.READU EVERY to list all the locks
    23. Check active record locks under "Item Id" column for job name or RT_CONFIG# or RT_LOG# (# matches the job description number
    24. Write down the Inode numbers and user numbers that are associated with these locks
    25. Enter LOGTO UV. If the LOGTO command is disabled, enter the following command:
      CHDIR path_to_the_DSEngine_folder
      The UNLOCK command lives in the UV account.
    26. Enter UNLOCK INODE inode# USER user# ALL
    27. You can use Q to get out of DataStage engine
  3. Use the xmetaAdmin cleanupAbandonedLocks utility to clear any abandoned locks. The xmetaAdmin cleanupAbandonedLocks utility deletes session locks from the Information Server repository that were left over from some usage of an Information Server suite application such as DataStage. Log in to the services tier as the root user on UNIX or Linux or as an Administrator user on Windows.
    On UNIX or Linux:
    cd /opt/IBM/InformationServer/ASBServer/bin
    
    ./xmetaAdmin.sh cleanupAbandonedLocks -dbfile ../conf/database.properties
    On Windows:
    cd c:\IBM\InformationServer\ASBServer\bin
    
    xmetaAdmin.bat cleanupAbandonedLocks -dbfile ..\conf\database.properties